Results 1 to 8 of 8

Thread: failed to create ppd database

  1. #1

    Default failed to create ppd database

    Opensuse 11.1 X64. System/services says cups is started, when I try to add a printer it asks to restart the cups service, I say ok and it says it's restarted, waiting 30 seconds, then says no local cups daemon is accessible, can't show print queue's, failed to detect print queues. Netstat says it's running on port 631.

    Uninstalled and reinstalled, I tried ignoring the error (I know.. As if...) and it says it can't create the PPD database.

    Ideas?
    Brian

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: failed to create ppd database

    Opensuse 11.1 X64. System/services says cups is started, when I try to add a printer it asks to restart the cups service, I say ok and it says it's restarted, waiting 30 seconds, then says no local cups daemon is accessible, can't show print queue's, failed to detect print queues. Netstat says it's running on port 631.
    Dis you try adding printer via YaST or via CUPS web interface?

    Did you try to add pppd file? If so, can you give more details about printer model and file?

    What does 'rccups status' report?

    Not sure about the problem here myself. Hopefully, someone may know how to zone right in on the problem.

  3. #3

    Default Re: failed to create ppd database

    Via YaST. I don't even know where to look for the CUPS web interface.

    I didn't try to add the ppd file. Manufacturer-PPDs are installed in the YaST software management. The hplip and hplip-hpijs are installed. It's not finding any print drivers at all. One printer is a Brother MF7840, the other in an HP PhotoSmart C5100. Both have worked in the past. I recently rebuilt this machine when I went from a small drive to raid 0.

    rccups status says running.

    Brian

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: failed to create ppd database

    Hmmmm... not easy to get a handle on this. I'm not sure if this a problem with a config file, or perhaps yast2-printer or cups-drivers package. (You could always try reinstalling these via yast software manager). Anyway, try browsing (formerly configured printers) via the CUPS http interface:

    http://localhost:631/

    Do you see any printers configured? If so, can you print test page?

    Can you post output of
    cat /etc/cups/printers.conf

  5. #5

    Default Re: failed to create ppd database

    cups http interface won't load. Says page not found. Already tried reinstalling cups via YaST. Output of printers.conf says no such file or directory.

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: failed to create ppd database

    Ok, we need to check your CUPS installation. Do

    rpm -qa|grep cups
    You may have to reinstall CUPS.

  7. #7

    Default Re: failed to create ppd database

    Found it. When I first installed Suse I was having performance issues with Firefox. An article I read suggested turning off IPv6. But the localhost-loopback line was still in the hosts file. I can either remove the line, or enable IPv6 and it works like a champ. But if I leave IPv6 off and remove the line from the hosts file, my vmware server breaks.

    Interestingly, with IPv6 on and the line in the host file, after a reboot Firefox is still quick. THAT I don't get. But now cups works and vmware is happy so I am too.

    Thanks!

    Advice is what you ask for when you know the answer but don't like it.

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: failed to create ppd database

    But if I leave IPv6 off and remove the line from the hosts file, my vmware server breaks.
    Thats a gotcha! I didn't even think to ask if you were running via a VM. There are many situations where knowing this is vital before any useful help can be given.

    I remember reading this thread dealing with similar IPv6 problem.

    Glad you got it sorted though.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •