Results 1 to 4 of 4

Thread: Zypper/Yast Update Issue - fresh install 11.1

  1. #1

    Default Zypper/Yast Update Issue - fresh install 11.1

    Hello,
    I did a fresh install of 11.1 which went fine, however when I attempted to update the system via zypper I recieved multiple errors regardings different mirrors that couldn't be resolved. The whole update process would stop at various points and ask me to abort, retry, or skip. This became very frustrating and time consuming durring the update. I did a search in the forums and found that there were other posts like this one. My questions are is this problem identified as a area to addressed with the next release, and is the best way to fix this to simply point yast and zypper to a local mirror? Thanks in advance for any info.

    Thanks,
    Mike

  2. #2

    Default Re: Zypper/Yast Update Issue - fresh install 11.1

    If you put in the DVD in the drive do the error messages disappear? If they do disapper then go to YaST, Software repositories and remove or disable the DVD repo (it should have /dev/sr0 somewhere), you can always use the iso you downloaded to use it as a repository instead of putting the DVD in the drive every time you want to install something. Just save the iso somewhere, again open YaST, go to Software Repositories, click add and on the bottom you'll have the iso image. Don't worry that it says that it doesn's look like an iso image, jusr proceed further.
    How does a linux geek make love??

    - rtfm; unzip; strip; touch; finger; mount; fsck; more; yes; umount; zip; sleep;

  3. #3

    Default Re: Zypper/Yast Update Issue - fresh install 11.1

    Quote Originally Posted by BenderBendingRodriguez View Post
    If you put in the DVD in the drive do the error messages disappear? If they do disapper then go to YaST, Software repositories and remove or disable the DVD repo (it should have /dev/sr0 somewhere), you can always use the iso you downloaded to use it as a repository instead of putting the DVD in the drive every time you want to install something. Just save the iso somewhere, again open YaST, go to Software Repositories, click add and on the bottom you'll have the iso image. Don't worry that it says that it doesn's look like an iso image, jusr proceed further.
    I don't think that the issue since I deleted the DVD repo. I even deleted all repos and then re-added them and I get the same issues. I have tried the net-install and live cd installs and get the same results. It appears that the faster-mirror feature is pointing to either incorrect mirrors or for some reason is unable to resolve them.

  4. #4

    Default Re: Zypper/Yast Update Issue - fresh install 11.1

    the problem is not opensuse, but download.opensuse.org they use a redirector that should work, but doesn't, just find a local mirror and change to that mirror for everything except the update repo.

    openSUSE Download Mirrors - 11.1
    openSUSE Download Mirrors - Overview

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •