Hello,

I have a problem with the default torrent client for the Gnome, Monsoon.

I think it has a bug, but I couldn't find anything on the forum, so maybe it's me.

After I download a torrent with Firefox (any .torrent) I should have the file added in Monsoon (Monsoon is already open). It's not there on the list right away. If I download it again with Firefox, Monsoon crashes. That's because the file was added with a delay.
It's OK that Monsoon tells me that the file already exists, but why did it crash?

Here you have the log of the error:

MonoTorrent.Common.TorrentException: Failed to add torrent, ubcd411.zip already exists.
at Monsoon.TorrentController.addTorrent (System.String torrentPath, Boolean startTorrent, Boolean moveToStorage, Boolean removeOriginal, MonoTorrent.Client.TorrentSettings savedSettings, System.String savePath, Boolean isUrl) [0x00000]
at Monsoon.TorrentController.addTorrent (System.String torrentPath, Boolean startTorrent, Boolean moveToStorage, Boolean removeOriginal, MonoTorrent.Client.TorrentSettings savedSettings) [0x00000]
at Monsoon.TorrentController.addTorrent (System.String torrentPath, Boolean startTorrent, Boolean moveToStorage) [0x00000]
at Monsoon.MainWindow.LoadTorrent (System.String path) [0x00000]
at Monsoon.MainClass+<>c__CompilerGenerated5+<>c__CompilerGenerated37.<StartLocalFileWatcher>c__38 () [0x00000]
at GLib.Timeout+TimeoutProxy.Handler () [0x00000] at Monsoon.TorrentController.addTorrent (System.String torrentPath, Boolean startTorrent, Boolean moveToStorage, Boolean removeOriginal, MonoTorrent.Client.TorrentSettings savedSettings, System.String savePath, Boolean isUrl) [0x00000]
at Monsoon.TorrentController.addTorrent (System.String torrentPath, Boolean startTorrent, Boolean moveToStorage, Boolean removeOriginal, MonoTorrent.Client.TorrentSettings savedSettings) [0x00000]
at Monsoon.TorrentController.addTorrent (System.String torrentPath, Boolean startTorrent, Boolean moveToStorage) [0x00000]
at Monsoon.MainWindow.LoadTorrent (System.String path) [0x00000]
at Monsoon.MainClass+<>c__CompilerGenerated5+<>c__CompilerGenerated37.<StartLocalFileWatcher>c__38 () [0x00000]
at GLib.Timeout+TimeoutProxy.Handler () [0x00000]
Is it because I use the 64 bit version of OpenSUSE?
I didn't install any additional software so I'm real puzzled.

I have another issue with this program: if I pause all the downloads and close it, when I re-open it the files are no longer paused. But maybe this is not a bug.

And a last thing: my Firefox 3.0b5 from time to time stalls. It's not responding. Eventually (after 2 or 3 minutes) it resumes working or it crashes.

I have some basic hardware, except for the additional IDE controller which is on a ITE chipset. The network is on-board ethernet. No proxy. And no problems in Windows.

One more thing: I use the French version of OpenSUSE.

Thanks for any clues.