Results 1 to 3 of 3

Thread: Why doesn't YAST obey theme / colour settings?

  1. #1
    Join Date
    May 2009
    Location
    US
    Posts
    867

    Default Why doesn't YAST obey theme / colour settings?

    I can't seem to get YAST to obey my colour settings. It insists on using a bluey purple selector bar and also paints a purple border around the selected window pane.

    I've chosen my colour scheme to look more like SUSE's green theme but can't get YAST to conform. I've set GTK styles to use KDE style in GTK apps. The bluey purple colours don't exist in my desktop colour settings so I have no clue where they are being picked up. Any clues? It's really bugging me.
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,312
    Blog Entries
    14

    Default Re: Why doesn't YAST obey theme / colour settings?

    Since Yast and all it's apps are always running through 'kdesu' they run as root. I suppose the changes should be made as root. Try this in a terminal window:
    kdesu systemsettings
    This gives you the systemsettings program for user root. Try making changes here and see what they do to your Yast.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    May 2009
    Location
    US
    Posts
    867

    Default Re: Why doesn't YAST obey theme / colour settings?

    Oh thanks man. That did the trick.

    I think to expect the window decorations and colours to not carry over into apps that run as root.

    Happy now.
    IBM Thinkpad X60s | Intel L2400 | Intel 945GM | 3GB | openSUSE Tumbleweed
    Dell XPS 13 9360 | openSUSE Leap 42.3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •