Results 1 to 7 of 7

Thread: apply chage of max_map_count

  1. #1
    andreycheg NNTP User

    Unhappy apply chage of max_map_count

    Hi,

    In OpenSUSE 10, where can I find a documented way to make sure change in /proc/sys/vm/max_map_count is applied to all new processes?

    Should I reboot for sure? Is it expected that just

    echo 300000 > /proc/sys/vm/max_map_count

    has no effect for new background process?

    Thanks!

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,781

    Default Re: apply chage of max_map_count

    This answer may not be very helpfull because I do not know what the parameter should do. But one thing is certain: setting things in /proc will be lost over a boot. So rebooting will not be of any help, you have to do the echo again after the boot and are then in the same position as before.

    Hope others come to tell you more about the paramter involved, but I try to save you from useless testing.
    Henk van Velden

  3. #3
    andreycheg NNTP User

    Default Re: apply chage of max_map_count

    Henk,

    Thanks, I also set it in sysconfig file.

    But my question is more about how to make sure about the moment when the change is actually applied to new processes.

    Thanks again!

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,781

    Default Re: apply chage of max_map_count

    You are welcome.

    I have the idea I am missing some info that would help the more knowledgable people to help you (if you are stiill with me ).

    I think your text implies that the parameter does not function for new processes, but you never say so explicit and you also do not povide the means how you proved that to yourself. Helpers love seeing things copied/pasted here direct from your system.
    Henk van Velden

  5. #5
    andreycheg NNTP User

    Default Re: apply chage of max_map_count

    > Helpers love seeing things copied/pasted here direct from your system.

    I understand this, I just trying to solve some really complex memory allocation problem and not sure if it is related to max_map_count parameter.

    So let my question be just "general": about how things should work.

    At the same time I modified that parameter to 100 and that quickly hanged up the whole system. So it looks changes are applied immediately for new processes.

    Thanks for help!

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,781

    Default Re: apply chage of max_map_count

    Welcome again. I like to ask stupid questions that lead to the OP to understand his problems while I am still ignorant

    Success!
    Henk van Velden

  7. #7
    goldie NNTP User

    Default Re: apply chage of max_map_count

    i believe it is mostly a "windows thing" to require a reboot for
    config files to be read when a new process is started..

    since Linux is patterned after Unix, it was designed to run and run
    and run (while individual users came and went, each launching
    processes and changing their environment as they wished--and having it
    APPLY to them TODAY....NOW...not in six months when the machine was
    shut down for 15 minutes of maintenance)..

    on the other hand, most game machines are shut down when the players
    sleep....or, change any configuration, add any program, etc etc
    etc...or run into any problem.....until all is fixed by the standard,
    and periodically required reinstall to un-jumble "the registry" and
    clean out the key-loggers, trojans, and zombie-bot-net spammer and DOS
    attacking executables..

    --
    goldie

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •