Results 1 to 7 of 7

Thread: The Network and the Noob

  1. #1
    Dan-K NNTP User

    Thumbs down The Network and the Noob

    Hello everyone! I am having some trouble with a piece of software that is windows native. It installs on several windows machines then and can externaly access a database which i decided to put on a computer running OpenSuSe 11.1. The problem im having is that linux is only allowing one client to use the database at a time. Ive tried having each client use different and the same accounts. Ive done chmod -R 777 and still it will not let more than one person on. Any help would be apreciated.

  2. #2
    Join Date
    Oct 2008
    Location
    Birmingham. AL
    Posts
    858

    Default Re: The Network and the Noob

    Need more input, #5.

    1. What kind of server? What ports should be opened?

    2. Who built the server? You, or did you download and install it?

    Provide a few more details and I'll bet it's probably just a config setting. Maybe the database is configured to only let one person access at a time. (Or maybe it locks the entire database, instead of just the small part being accessed.)

  3. #3

    Post Re: The Network and the Noob

    Hi there,

    I think some more info would help isolate the issue.

    The database on the Suse box - what exactly is it and how are the connections from the clients being made?

    The clients themselves, they are a windows only app? Are they connecting via ODBC or the MySQL Connector, etc.?


    Pete

  4. #4
    Dan-K NNTP User

    Default Re: The Network and the Noob

    The Server is just a gateway slimline computer I installed SuSe on and the database is being shared over a LAN with samba. The database is writen by the software itself, I do not know what kind or type it is.

  5. #5
    PV NNTP User

    Default Re: The Network and the Noob

    On Mon August 24 2009 06:06 pm, Dan-K wrote:

    >
    > The Server is just a gateway slimline computer I installed SuSe on and
    > the database is being shared over a LAN with samba. The database is
    > writen by the software itself, I do not know what kind or type it is.
    >
    >

    Dan-K;

    Try adding the following parameter to the database share definition
    of /etc/samba/smb.conf
    Code:
    oplocks = No
    level2 oplocks = No
    These are enabled by default but database shares usually perform much better
    when they are disabled. See the writeup in:
    http://samba.org/samba/docs/man/Samb...n/locking.html
    particularly the section: "Multiuser Databases"

    --
    P. V.
    "We're all in this together, I'm pulling for you." Red Green

  6. #6
    goldie NNTP User

    Default Re: The Network and the Noob

    > chmod -R 777

    anyone else think it would be a FINE IDEA to *find* every single
    instance of that on the entire internet and ERASE it!!!

    i just have to believe it was FIRST put on the net by someone from the
    M$ FUD team..

    --
    goldie

  7. #7

    Cool Re: The Network and the Noob

    Quote Originally Posted by goldie View Post
    > chmod -R 777

    anyone else think it would be a FINE IDEA to *find* every single
    instance of that on the entire internet and ERASE it!!!

    i just have to believe it was FIRST put on the net by someone from the
    M$ FUD team..

    --
    goldie
    Indeed . . .

    sed -i s/777/000/g < Internets



    Lews Therin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •