Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Issue installing nVidia drivers the "hard way"

  1. #1

    Default Issue installing nVidia drivers the "hard way"

    So I am following the instructions found: NVIDIA/The hard way - openSUSE

    And I have installed all of the following via yast:
    Code:
    compiler gcc,
    program make and
    package kernel-source
    package kernel-syms
    How ever I get the following error message from the nVidia package installer when I try to run it:
    Code:
    The kernel header file '/lib/modules/2.6.37.7-9-default/build/include/linux/kernel.h' does not exist.
    Did I do something wrong/am I missing something here? Not sure if it matters but I am on run level 3 and logged in as super user as the page also says. Using OpenSUSE 11.1 64bit

    Any help would be awesome,
    ~Jeff
    Sager - 2.8gzh p9700 - 4 gigs DDR3 - nVidia 260m - 320gig HDD - Linux 64bit
    Asus EEE 900A - Atom 1.6ghz - 2gigs DDR2 - 32gig SSD - Ubuntu 32bit

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,339
    Blog Entries
    15

    Default Re: Issue installing nVidia drivers the "hard way"

    Quote Originally Posted by Jeff91
    So I am following the instructions found: 'NVIDIA/The hard way -
    openSUSE' (http://en.opensuse.org/NVIDIA/The_hard_way)

    And I have installed all of the following via yast:
    Code:
    --------------------
    compiler gcc,
    program make and
    package kernel-source
    package kernel-syms
    --------------------


    How ever I get the following error message from the nVidia package
    installer when I try to run it:
    Code:
    --------------------
    The kernel header file
    '/lib/modules/2.6.37.7-9-default/build/include/linux/kernel.h' does not
    exist. --------------------


    Did I do something wrong/am I missing something here? Not sure if it
    matters but I am on run level 3 and logged in as super user as the page
    also says. Using OpenSUSE 11.1 64bit

    Any help would be awesome,
    ~Jeff
    Hi
    You need the linux-kernel-headers as well

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
    up 3 days 23:28, 4 users, load average: 2.09, 1.75, 1.61
    GPU GeForce 8600 GTS Silent - Driver Version: 190.18


  3. #3
    Join Date
    Jun 2008
    Location
    Concord, California
    Posts
    264

    Default Re: Issue installing nVidia drivers the "hard way"

    I just looked through the repos and did not find a kernel v 2.6.37. Did you upgrade/update your kernel from a source outside the repos? If so, you will need to get the source files for that kernel. It looks like the kernel source available in the repos is 2.6.27, 2.6.29, 2.6.30 and 2.6.31.

    The kernel and kernel-source version have to match.
    OpenSUSE Leap 15, KDE5 (plasma 5.16.5, frameworks 5.62, QT 5.13.1)

  4. #4

    Default Re: Issue installing nVidia drivers the "hard way"

    Ahh thank you much. Should have realized that! Someone should really add that to the wiki...

    ~Jeff
    Sager - 2.8gzh p9700 - 4 gigs DDR3 - nVidia 260m - 320gig HDD - Linux 64bit
    Asus EEE 900A - Atom 1.6ghz - 2gigs DDR2 - 32gig SSD - Ubuntu 32bit

  5. #5

    Default Re: Issue installing nVidia drivers the "hard way"

    Quote Originally Posted by cybertaz View Post
    I just looked through the repos and did not find a kernel v 2.6.37. Did you upgrade/update your kernel from a source outside the repos? If so, you will need to get the source files for that kernel. It looks like the kernel source available in the repos is 2.6.27, 2.6.29, 2.6.30 and 2.6.31.

    The kernel and kernel-source version have to match.
    It is the .27 - sorry typoed it when I copied it over (using my netbook to post as I am still setting up my Sager darn tiny keyboard!) will fix in first post.

    ~Jeff
    Sager - 2.8gzh p9700 - 4 gigs DDR3 - nVidia 260m - 320gig HDD - Linux 64bit
    Asus EEE 900A - Atom 1.6ghz - 2gigs DDR2 - 32gig SSD - Ubuntu 32bit

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Issue installing nVidia drivers the "hard way"

    Simplest way to solve all this, is starting the software installer, Pattern View, select Linux Kernel Development. This will install all needed files to install the NVidia driver 'the hard way'. If you managed to install, don't forget the 'sax2 -r -m0=nvidia'......
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7

    Default Re: Issue installing nVidia drivers the "hard way"

    I installed Linux Kernel Development package via YaST and I am still getting the same error message when trying to install the nvidia driver Other suggestions?

    And what do you mean by don't forget
    sax2 -r -m0=nvidia
    ?

    Thanks,
    ~Jeff
    Sager - 2.8gzh p9700 - 4 gigs DDR3 - nVidia 260m - 320gig HDD - Linux 64bit
    Asus EEE 900A - Atom 1.6ghz - 2gigs DDR2 - 32gig SSD - Ubuntu 32bit

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Issue installing nVidia drivers the "hard way"

    Assuming you have the Matching kernel packages (Check the version numbers carefully)

    This is my method:

    Alright so here is how to install the nvidia driver manually, in case the one in the repo doesn't work or u just want to use the latest.
    Go to Yast>Software>Software Management
    Search for and install if you don't have these:

    make
    gcc
    kernel-source

    Now download the latest Nvidia driver:
    Place the file in your /home/username
    Now restart and at the boot screen, pause the boot by moving the down button, then move back up and clear any text in the boot arguments by holding backspace. Then just type the number: 3
    At the login
    Type "root" then enter and then your root password and press enter.
    now type
    cd /home/username
    *Now remember you can use the {TAB} key to auto complete
    so type:
    sh NVIDIA{TAB}
    and the whole file name should auto complete
    eg: sh NVIDIA-Linux-x86-185.14.09-pkg1.run
    Follow the installer and let it compile the kernel module for you.
    Say Yes to everything
    Use TAB to move around
    reboot
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9

    Default Re: Issue installing nVidia drivers the "hard way"

    I followed all the instructions in your guide as listed and I still get the
    Code:
    The kernel header file '/lib/modules/2.6.27.7-9-default/build/include/linux/kernel.h' does not exist.
    Error message from the nvidia 190.18 binary file when trying to run it. (I can confirm the file works - I just installed with it in Fedora11 and Ubuntu 9.04)

    I am open to suggestions still... but for now I am admitting default and just installing the version from the repos But I would really like to extra performance the beta drivers grant :/

    ~Jeff
    Sager - 2.8gzh p9700 - 4 gigs DDR3 - nVidia 260m - 320gig HDD - Linux 64bit
    Asus EEE 900A - Atom 1.6ghz - 2gigs DDR2 - 32gig SSD - Ubuntu 32bit

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Issue installing nVidia drivers the "hard way"

    Please open a terminal and do this:

    Code:
    rpm -qi linux-kernel-headers
    post result
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •