Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: KDE 4.3 & Firefox 3.5.x

  1. #1

    Default KDE 4.3 & Firefox 3.5.x

    Why is it so hard to upgrade to these? I just installed openSUSE 11.1 for the first time. It installed with KDE 4.1 & Firefox 3.0.x.

    I go into Software Management to install software and can't find the newer versions of either. I've been hunting in this forum for clues as to how to do this. I've added repositories that this august group says they should be in, but I don't see them.

    I've tried some of the One Click and none of them work. The results are a bunch of dependencies that it can't find.

    What am I missing? I never had this problem with package managers in Ubuntu and PCLinuxOS. Of course, they couldn't run all the hardware on this particular system, but openSUSE can.

    I don't want to have to build or compile this; I just want to install them.

    Thanks for the help,
    Clyde

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,579
    Blog Entries
    1

    Default Re: KDE 4.3 & Firefox 3.5.x

    I've just searched via webpin:

    http://packages.opensuse-community.o...o=openSUSE_111

    Here's the 1-click link:

    http://api.opensuse-community.org/se...528917272c2706

    Try that.

    If you have further problems, post the errors and maybe give us the list of your configured repos with

    zypper lr --details

  3. #3

    Default Re: KDE 4.3 & Firefox 3.5.x

    That was great for Firefox 3.5.2! Thanks I got it very nicely.

    I didn't know about Webpin. Thanks for that too.

    However, a search in Webpin didn't show KDE 4.3 or even 4.2. Any idea where I can get a working package for 4.3?

    Thanks,
    Clyde


    PS - Here is my zypper lr --details results:

    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+-----------------------------------------------------------------------------------------+-----------------------------------------------------------------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------------------------------------+--------
    1 | 20090823-182206 | 20090823-182206 | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.1 |
    2 | 20090823-184122 | 20090823-184122 | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.1 |
    3 | 20090823-185635 | 20090823-185635 | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_Factory |
    4 | KDE4 | KDE4 | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.1 |
    5 | devel:tools:building | devel:tools:building | Yes | Yes | 99 | rpm-md | Index of /repositories/devel:/tools:/building/openSUSE_11.1 |
    6 | Index of /repositories/home:/kzjeef:/branches:/mozilla/openSUSE_11.1 | Index of /repositories/home:/kzjeef:/branches:/mozilla/openSUSE_11.1 | Yes | Yes | 99 | rpm-md | Index of /repositories/home:/kzjeef:/branches:/mozilla/openSUSE_11.1 |
    7 | openSUSE 11.1-0 | openSUSE 11.1-0 | Yes | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
    8 | openSUSE-11.1-Updates | openSUSE-11.1-Updates | Yes | Yes | 99 | rpm-md | Index of /update/11.1 |
    9 | openSUSE-NonOSS-Add-on_11.1-0 | openSUSE-NonOSS-Add-on 11.1-0 | Yes | No | 99 | yast2 | cd:/// |
    10 | openSUSE:11.1:Update | openSUSE:11.1:Update | Yes | Yes | 99 | rpm-md | Index of /update/11.1 |
    11 | repo | openSUSE BuildService - OpenOffice.org | Yes | Yes | 99 | rpm-md | Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.1 |
    12 | repo-debug | openSUSE-11.1-Debug | No | Yes | 100 | NONE | Index of /debug/distribution/11.1/repo/oss |
    13 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.1/repo/non-oss |
    14 | repo-oss | openSUSE-11.1-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.1/repo/oss |
    15 | repo-source | openSUSE-11.1-Source | No | Yes | 100 | NONE | Index of /source/distribution/11.1/repo/oss |
    16 | repo-update | openSUSE-11.1-Update | Yes | Yes | 20 | rpm-md | Index of /update/11.1 |
    17 | repo_1 | openSUSE BuildService - X11:Compiz | Yes | Yes | 99 | rpm-md | Index of /repositories/X11:/Compiz/openSUSE_11.1 |
    18 | repo_2 | openSUSE BuildService - Games | Yes | Yes | 99 | rpm-md | Index of /repositories/games/openSUSE_11.1 |
    19 | repo_3 | openSUSE BuildService - Mozilla | Yes | Yes | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_11.1 |
    20 | repo_4 | VideoLan Repository | Yes | Yes | 99 | rpm-md | Index of /pub/videolan/vlc/SuSE/11.1/ |

  4. #4
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: KDE 4.3 & Firefox 3.5.x

    Follow this link and use the 1 click installer for kde4.3.
    KDE/KDE4 - openSUSE
    OR: You can add the factory repo for kde 4.3 in repos, and do zypper up in terminal after become su.

    Your repos are messed up. Not necessary all these repos.
    Just update, OSS, Non OSS, mozilla, packman should be enough to stick. Advise: Disable the others or delete it completely.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  5. #5
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: KDE 4.3 & Firefox 3.5.x

    Hi,

    Also make sure to change your openSUSE Update repository to priority 99. Otherwise the package numbering for KDE will be overridden and you'll get conflicts.

    As was mentioned before, your repositories are messed up a bit. Read this guide first to learn how to manage your repositories:

    Repository Management - openSUSE Forums

    Then you can upgrade to 4.3. Here's a How-to guide for upgrading to KDE 4.3:

    KDE4.3.* Upgrade - HowTo - openSUSE Forums

    Take Care,

    Ian
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,579
    Blog Entries
    1

    Default Re: KDE 4.3 & Firefox 3.5.x

    You have far too many enabled repos. This can give you all sorts of trouble with package conficts!

    Most choose to have packman repo enabled, but if you have videolan repo, don't have both as this can lead to conflicts. Clean up your repos first before attempting the upgrade. Have a read of the KDE 4.3 HOW TO. It offers similar advice.

  7. #7

    Default Re: KDE 4.3

    Thanks to both of you. I got my repositories straight and KDE 4.3 successfully installed. I had to hand pick what to do with a lot of discrepancies, but most of them were just confusion over the openSUSE version of the dependency. Those worked just fine.

    It did temporarily screw up Amarok and digikam, as I didn't have those choices. I told them to ignore dependencies. Later I upgrade those so they are now working too.

    I guess this level of safety and control is good. I kind of miss the easy of Ubuntu's and PCLinuxOS's simple package management. This brings back the days when I was using Linux serious and professionally; it feels good.

    Thanks,
    Clyde

  8. #8

    Default Re: KDE 4.3 & Firefox 3.5.x

    Quote Originally Posted by deano_ferrari View Post
    I've just searched via webpin:

    Webpin

    Here's the 1-click link:

    http://api.opensuse-community.org/se...528917272c2706

    Try that.

    If you have further problems, post the errors and maybe give us the list of your configured repos with

    Hi deano_ferrari
    I have read your reply to this issue what i was looking for as i have the same problem
    However followed your instruction to a point where the install returned the following :-

    Mozilla Firefox translation requires 3.0.13-1.2.i586 requires M firefox But the requirement cannot be provided

    Conflict resolution
    The following actions will be done
    Replacement of M F translation 3.0.13-12 with M F 3.5.2-3

    List of 13 conflicks

    options:-
    do not install
    Ignore some dependences

    What can you advise here?
    Thanks

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: KDE 4.3 & Firefox 3.5.x

    I take it you are using FF 3.5?
    We could do with the complete dependency error. Use the expert box to save it to file and then copy it here.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10

    Default Re: KDE 4.3 & Firefox 3.5.x

    Quote Originally Posted by caf4926 View Post
    I take it you are using FF 3.5?
    We could do with the complete dependency error. Use the expert box to save it to file and then copy it here.
    Thanks for getting back to me

    Current Firefox is 3.0.13 - Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.0.13)
    Not sure what you mean as to use expert box:- OK got it


    #### YaST2 conflicts list - generated 2009-08-29 20:54:14 ####

    MozillaFirefox-translations-3.0.13-0.1.2.i586 requires MozillaFirefox = 3.0.13, but this requirement cannot be provided

    [ ] Following actions will be done:
    replacement of MozillaFirefox-translations-3.0.13-0.1.2.i586 with MozillaFirefox-translations-common-3.5.2-3.1.i586
    install mozilla-nspr-4.8-1.1.i586 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service
    install mozilla-nss-3.12.4-1.1.i586 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service
    install libfreebl3-3.12.4-1.1.i586 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service
    install MozillaFirefox-branding-openSUSE-3.5-12.8.i586 (with vendor change)
    openSUSE
    -->
    openSUSE Build Service
    [ ] do not install MozillaFirefox-3.5.2-2.1.i586

    [ ] Ignore some dependencies of MozillaFirefox-translations




    #### YaST2 conflicts list END ###

    Something new to add to my notes.

    Many thanks hope it is of help.
    Last edited by londonman; 29-Aug-2009 at 12:59. Reason: update

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •