Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: OpenSuseLinux no Internet Connection on Asus Eeepc 1005HA

  1. #1

    Exclamation OpenSuseLinux no Internet Connection on Asus Eeepc 1005HA

    Within a dual boot option two os are now available on the asus eeepc 1005ha,

    (1) the windows xp system and in addition (2) the linux 11.1 version of opensuse.

    After and also during the installation process of the linux 11.1 os, an error message had occured:

    No network found!

    I tried to fix it by changing some settings (network manager on/off), but no

    improvement could be achieved. Some people argue to wait for a kernel

    update higher than *.27.*


    Somebody knows something how to fix the network (eth0) internet connection?


    Thanks and cheers.

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: OpenSuseLinux no Internet Connection on Asus Eeepc 1005HA

    The first step is for you to tell us what Ethernet device is on the
    machine. To do that, open a terminal and run the command

    /sbin/lspci -nnv | egrep "Network|Ethernet"

    and post the results.

  3. #3

    Default Re: OpenSuseLinux no Internet Connection on Asus Eeepc 1005H

    01:00.0 Ethernet controller [0200]: Attansic Technology Corp. Device [1969:1062] (rev c0)
    02:00.0 Network controller [0280]: Atheros Communications Inc. Device [168c:002b] (rev 01)

    That's the output of the command above.
    What do you mean?

  4. #4
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: OpenSuseLinux no Internet Connection on Asus Eeepc 1005HA

    pic4colo wrote:
    > 01:00.0 Ethernet controller [0200]: Attansic Technology Corp. Device
    > [1969:1062] (rev c0)
    > 02:00.0 Network controller [0280]: Atheros Communications Inc. Device
    > [168c:002b] (rev 01)
    >
    > That's the output of the command above.
    > What do you mean?


    The codes are used by the system to load the correct driver. Your
    Ethernet device is supported by the latest kernels, but the code was
    not entered into the kernel until last February, which means that it
    is not in the kernel for openSUSE 11.1. It will be supported in 11.2.

    Your wireless device (the Atheros unit) is supported by ath9k. That
    too is fairly new.

    My suggestion is that you try the Live CD for 11.2 M6. It should
    recognize both your Ethernet and wireless. It has some bugs, but I
    find it usable. Otherwise, you can wait for later milestones or for
    the release in November.

  5. #5

    Default Re: OpenSuseLinux no Internet Connection on Asus Eeepc 1005H

    Thanks for the suggestions. I will wait for November.

    Cheers

  6. #6

    Wink Re: OpenSuseLinux no Internet Connection on Asus Eeepc 1005H

    Hi, why to wait?
    I got mine with everything working.

    There are some issues to know anyway. The 1005HA is not the same as 1000H. The key is to install the drivers for wired and wireless and replace networkmanager by wicd.

    The general idea is that you have to add "Kernel-source", and "make" (needed by the driver for wired networking). You can get this by downloading the KDE DVD ISO file in windows, copying it from SuSE and adding the ISO file as a repo source using Yast/Add-on. I am assuming you do not have a DVD/CD external device.

    Getting Wire networking (ethernet JP45)
    The network device is a Atheros AR8132 PCI-E.
    Get the driver...
    Go to Atheros' website, and search for AR8132, and download the only file for Linux Family.
    Link to download Atheros drivers
    Unpack/extract the file in a folder, then with Konsole/terminal, as root:
    Code:
    su
    make install
    go to /lib/modules/kernel.....default/kernel/drivers/net/atl1e/ (while installing it appears the folder path on terminal)
    and also as root:
    Code:
    insmod atl1e.ko
    rcnetwork restart
    connect to wire and test it with knetworkmanager.

    For wireless
    This is an Atheros AR9285 Wireless Network Adapter
    Get the community driver from the opensuse Built Service website.
    Link to the Community Athero's wireless driver compat-wireless-kmp-default
    And restart.

    Still wireless not working? do not worry.
    This is very common since Network Manager is used by default and has many problems.
    I tried with NM and networkmanager-KDE or with networkmanager-KDE4 and neither were stable or even connected.

    The solution is simple:
    Replace NM with WICD. Again this you can download from the Build Service
    Link to get the WICD packages
    Accept the installation of the repositories.
    Once it is installed, go again to Yast, Install Software, search and uninstall Networkmanager. It will uninstall the KDE clients as well. No problem. And on Yast/Network Devices/Network Settings/Global Options, select "traditional method with Ifup".

    It is possible that WICD will request for root password the first time.

    If a D-BUS error shows up, it is due to updates that did not deleted the previous setting files. A solution is to uninstall WICD, restart, install WICD again, run it, give the root pass, check the settings, and restart again. After this, I do not get any password request when booting nor D-BUS errors.

    Hope this helps.
    regards,
    gps

  7. #7

    Default Re: OpenSuseLinux no Internet Connection on Asus Eeepc 1005H

    Hi
    i have a similar problem. My Laptop is an fairly new Compaq Presario CQ71, with the network card Realtek RTL8102E I think.
    I searched for a driver, but didn't find one. Do I have to wait for 11.2 or is there another way to fix it?

  8. #8

    Default Re: OpenSuseLinux no Internet Connection on Asus Eeepc 1005H

    hi kannete;

    general etiquette would suggest you should start a new post as your problem is a new one;

    for now have a read at this

    Realtek rtl8192e wireless concerns - openSUSE Forums

    sounds like you need ndiswrapper;

    start a new post if you need continued help with the realtek in the title: then folks can help you more easily

  9. #9
    Join Date
    Oct 2009
    Location
    Massachusetts, USA
    Posts
    12

    Default Re: OpenSuseLinux no Internet Connection on Asus Eeepc 1005H

    Thanks for the info gpsanino, I followed your advice after installing openSUSE 11.1 on my 1005HA and it worked great!
    Lap1: ASUS Eee PC 1005ha, openSUSE 11.1(2.6.27.29-0.1 i686), KDE 4.1.3
    Lap2: HP Presario C500, dualBoot: Ubuntu 8.04 + Gnome, Vista

  10. #10

    Default Re: OpenSuseLinux no Internet Connection on Asus Eeepc 1005H


Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •