Results 1 to 5 of 5

Thread: NFS mount --- file system read only ...

  1. #1
    Join Date
    Jun 2008
    Location
    Portugal
    Posts
    249

    Default NFS mount --- file system read only ...

    Hi,

    I have set up a usb bootable pc with NFS server configured in Ubuntu 8.10 64bit.

    My desktop is (and has always been a OpenSuSE box, currently 11.1 x86_64.


    On the server, under:

    /etc/exports
    I have exported a directory like this:

    /mnt/data 192.168.0.0/255.255.255.0(rw,sync)


    My openSuSE box sees the export, i can make
    showmount -e <server machine name>

    and the exports are showned

    In my desktop I try to mount the nfs export and it really mount with no problem.
    I can see every file on the server's /mnt/data dir.

    I mount that with:

    mount -v -t nfs <servernema>:/mnt/data /mnt/util

    My problem is when I try to send data do /mnt/util.

    It always says gives an error like reaqd-only filesystem

    In the server /mnt/data is mounted as rw. All access properties as rw for all.
    Same as in /mnt/util on the local desktop.


    Someone has any idea at what is happenning ??


    Regards,
    Pedro

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,792

    Default Re: NFS mount --- file system read only ...

    The directory where you mount (in your case /mnt/data) also has an owner/group and access bits . Did you check them?
    When e.g. ls -l shows it as:
    Code:
    drwxr-xr-x  14 root root  4096 jan 12  2008 /mnt/data/
    only root can write to it. This should not surprise you.

    EDIT: sorry, I did miss your sentence about: All access properties as rw for all.
    I may have to reread your post, but you name your systems not consistent. Sometimes it is openSUSE box, then again it is desktop, then again it is local desktop. very embarassing. Can't you not simply give names to them in a consistent way?
    Btw, I do not see a rw option in your mount statement. Are you sure that is the default?
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    Portugal
    Posts
    249

    Default Re: NFS mount --- file system read only ...

    Hi,

    Ok, I was not consistent on the namespace ...
    But you have a point there on the permissions !

    Quote Originally Posted by hcvv View Post
    The directory where you mount (in your case /mnt/data) also has an owner/group and access bits . Did you check them?
    When e.g. ls -l shows it as:
    Code:
    drwxr-xr-x  14 root root  4096 jan 12  2008 /mnt/data/
    only root can write to it. This should not surprise you.

    EDIT: sorry, I did miss your sentence about: All access properties as rw for all.
    I may have to reread your post, but you name your systems not consistent. Sometimes it is openSUSE box, then again it is desktop, then again it is local desktop. very embarassing. Can't you not simply give names to them in a consistent way?
    Btw, I do not see a rw option in your mount statement. Are you sure that is the default?

    The dir where I mount the remote remote nfs server /mnt/data is:
    /mnt/util
    This /mnt/util in on the OpenSuSE desktop.


    Both the server /mnt/data and the local /mnt/util have permissions for the same user (UID 1000 on both systems.)

    I noticed that on the server the Group id for the user 1000 is different from the one on the Desktop OpenSuSE ...
    Default groupid for users on OpenSuSE is 100. On the Ubuntu server it is 1000 on the Ubuntu server...
    This can be a problem ...
    Anyway theoretically this should not be a problem as both dirs are wr for all users ...

    Anyone else tried to make this setup work ?


    Regards,
    Pedro

  4. #4
    Join Date
    Jun 2008
    Location
    Portugal
    Posts
    249

    Default Re: NFS mount --- file system read only ...

    Hi,


    For all of those with the same problem ... I know what happened to my setup ...


    Googling around I found this thread:
    NFS system mounts as read-only - Ubuntu Forums

    The exact same happened to me:

    on the exports file there can not be space between hostname/ip and the ().

    This is Not correct in exports:

    Code:
    /mnt/data 192.168.1.0/255.255.255.0 (rw,sync,no_root_squash)

    This is correct: No spaces on second string!

    Code:
    /mnt/data 192.168.1.0/255.255.255.0(rw,sync,no_root_squash)
    So when making NFS work careful with typos ...

    Regards,
    Pedro

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,792

    Default Re: NFS mount --- file system read only ...

    !) be ALWAYS carefull with typos

    2) it would have helped when in your first post the computer configs and statements were put in between CODE tags, as you did in your last post. Difficult to read white space in 'normal' text.

    Nice you found it.

    And when systems are strongly connected to the same users on both, try to give them the same uid/guid on both sytems. Saves a lot of trouble.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •