Results 1 to 4 of 4

Thread: upgrading a rpm package (libcurl)

  1. #1
    theairraidsiren NNTP User

    Default upgrading a rpm package (libcurl)

    hi experts and forum people. I've just started to learn linux(suse) and tenacious to be master on this way..
    This is my first question in this forum..
    I've been trying a c++ app uses libcurl api for ftp operation.
    I think I damaged a file in package or do anything and app doesn't work properly for this. I want to reinstall upgrade libcurl package. But I couldn't it. please help...

  2. #2
    Join Date
    Oct 2008
    Location
    North Wales, UK
    Posts
    1,114

    Default Re: upgrading a rpm package (libcurl)

    Go to yast>software>software management and search for libcurl. Filter on installed. When the package comes up, choose re-install.

  3. #3
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: upgrading a rpm package (libcurl)

    su -c "zypper in -f libcurl4"

    If you're using 11.1.

  4. #4
    theairraidsiren NNTP User

    Default Re: upgrading a rpm package (libcurl)

    There is no option reinstall.. only update can be selected but nothing is changed.
    I downloaded two rpm files libcurl4 and libcurl-devel. And I want to upgrade existing packages with this files.
    I used command like "rpm -Uvh libcurl4..." But it doesnt Work
    it gives warning as Header V3 DSA signature: Nokey , Key id 09ca02b

    I use 10.3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •