Results 1 to 4 of 4

Thread: OpenSUSE not "saving settings on exit"

  1. #1

    Default OpenSUSE not "saving settings on exit"

    I've just installed OpenSUSE for the first time this weekend. It was working okay for a while, but with several issues (most as yet unfixed) such as openGL not working, sound not working (even though the volume slider detects), had to use ndiswrapper (or whatever) to get wireless to work...

    Anyway, lately it's stopped "saving the settings on exit". Everytime I restart it uses the default wallpaper. The one I have downloaded is a selection if I right-click and change background, it just doesn't boot with it automatically. And even more annoying is that I have to run the Network Settings thingy every time to get the wireless to work. This is only a recent problem. Initially it was saving the background and wireless settings fine.

    Lastly, if anyone can offer suggestions as far as getting the video drivers (to enable Desktop effects) and the RealTek sound working, I'd be thankful! The card is an ATI Raedon Express 200M. I already downloaded the drivers from the ATI site but that hasn't made any difference, even though they seemed to install okay, I still can't enable Desktop Effects.

    I've been in-front of the laptop for the past 20 hours setting this up, so I'm not being lazy here! Just a point in the right direction would be nice.

  2. #2
    Join Date
    Oct 2008
    Location
    North Wales, UK
    Posts
    1,114

    Default Re: OpenSUSE not "saving settings on exit"

    The best way to install the ati driver is to get it from the suse rpository - this way you don't have to re-install it every time the kernel is changed.
    Go to yast>software>repositories and choose add.
    Select community repo and then add the ati repo.
    Once installed, go to software management, filter on repositories>ati and you will see the correct drivers selected for your card.
    Install them.
    There is a how to for ati cards in the how-to section (How To/FAQ (read only) - openSUSE Forums)
    For the sound, try setting up the mixer to use the oss version. I've found this works best for me.
    What desktop are you using. In gnome you can set it up in the control center.
    Then play around with the settings for the volume in all the ones you can.
    You can also, set the volume in yast>hardware>sound.
    Wireless is generally a problem in linux, especially if it's an unsupported card.

  3. #3
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,611

    Default Re: OpenSUSE not "saving settings on exit"

    First of all, Linux saves settings as you change them; it does not have to save them on exit. Your personal settings are all in hidden files in /home.

    The reason why the changes you have made are not being saved is because the relevant hidden file was not changed when you made the change. There are several possible reasons for this but one is that you are making changes in a non-standard way and by-passing the mechanism that updates the hidden files.

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: OpenSUSE not "saving settings on exit"

    Quote Originally Posted by wombatvvv View Post
    .... sound not working (even though the volume slider detects)....
    Lastly, if anyone can offer suggestions as far as getting the ... RealTek sound working, I'd be thankful!
    You could try working your way through the openSUSE audio troubleshooting guide:
    SDB:AudioTroubleshooting - openSUSE

    Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

    speaker-test -Dplug:front -c2 -l5 -twav

    Note Linux is case sensitive, and D is not the same as d. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

    If that test yields errors (and its not uncommon to get errors there), try instead this more simple test:
    speaker-test -c2 -l5 -twav
    You should hear a female voice saying 'FRONT LEFT', 'FRONT RIGHT' five times. Its quite common that one of those speaker tests will work and one will NOT work, so don't be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version ... etc ... ).

    Or alternatively, for testing the simple playback, use aplay program. Prepare a WAV file and simply run like:
    Code:
    aplay -vv somefile.wav
    With the option -vv, aplay shows the verbose information of the PCM device, and a VU-peak meter during playing the file.

    Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

    Assuming no sound, can you provide more very detailed information so a good recommendation can be given? For openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole
    Code:
    /usr/sbin/alsa-info.sh
    Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

    Then run it again (as either a regular user or as root). This time it will diagnose your PC's hardware and software configuration for audio, and it will post its output on the Internet/web. It will give you the URL of the web site. Please post that URL here. JUST the URL.

    Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound
    ... with that information I may be able to make a recommendation.

    Also, do NOT waste 20 hours in front of the PC. IMHO thats a waste of time that can be better spent !! Do "some" research / checking on your own, but not 20 hours.

    Simply post on our forum, and look for help that way.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •