Results 1 to 3 of 3

Thread: KWin is missing

  1. #1
    Valok NNTP User

    Default KWin is missing

    So I'm pretty new to openSUSE. Been using it for maybe a week now, and I have to say although it took some getting used to, I'm really diggin' it so far.

    The one problem I've ran into so far that I can't seem to fix myself is one with KWin. I'm trying to enable desktop effects so I can do all the cool cube, wobbly windows etc etc. However, when I go into Apps > Utils > Desktop >

    And then look for KWin, it doesn't appear there. But in YaST, it says that KWin is installed, and I did an upgrade of it just to make sure.

    Also, when I go into "Configure Desktop" and try to enable the features there, everything is grayed out and I don't have the ability to change any of the settings. If it helps, the bottom of that window says

    "Compositing is not supported on your system
    Required X extensions (Xcomposite and XDamage) are not available"

    Does this mean I have to install those two things to get it to work?

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,043
    Blog Entries
    14

    Default Re: KWin is missing

    First hurdle has been taken: you're enjoying linux/openSUSE.

    Now, to help you out, we need some more info:

    What's the videocard in your system ? It needs to be capable of doing the desktop effects, AND probably needs a driver to be installed and configured. Don't get scared, millions have done that to enjoy the eye-candy provided by the linux desktops.

    If a proper driver has been installed, the config file for the graphical desktop, /etc/X11/xorg.conf, will contain a part that enabled the compositing for your system:

    Section "Extensions"
    Option "Composite" "on"
    EndSection

    No use to put it there by hand, will be done during configuration of the video card.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Valok NNTP User

    Default Re: KWin is missing

    Thanks for the quick reply!

    I'm currently using a Gforce 8800GT. I just installed a new driver earlier today via a 1 click download, which then DLed the new driver and installed it via YaST.

    At one point this morning I did have KWin and Compiz on my computer. But I read that KWin can do all the things (pretty much) that compiz can, so I deleted compiz and KWin seems to have gone with it (except for the fact that YaST still says I have it).

    I checked the etc/x11/xorg.conf and my file looks just like what you said it should.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •