Results 1 to 8 of 8

Thread: Immediate shutdown following boot completion.

  1. #1

    Default Immediate shutdown following boot completion.

    If I boot my machine, running openSUSE 11.1 x86_64 with 2.6.27.25 kernel, it reaches the graphical login prompt then immediately performs an orderly shutdown, just as if I'd asked it to shutdown by hand.

    This happens if I boot into failsafe mode
    This happens if i boot into init level 3.

    It does *not* happen if I boot into single user mode init level 1.
    It does *not* happen if I use the rescue disk.

    It managed a complete fsck of 6 disks once, and seems happy in single user mode, staying up for at least half an hour until I shut it down myself, which rather rules out overheating.

    This started some weeks ago, and was rare enough for me to think I'd hit a key by mistake, but now it seems permanent.

    This is out of my comfort zone, but at least I can get into the machine at init level 1. Any help will be much appreciated, sincerely.

  2. #2
    goldie NNTP User

    Default Re: Immediate shutdown following boot completion.

    > it reaches the graphical login prompt then immediately performs
    > an orderly shutdown


    it shuts down before you give your password and hit enter?

    sometime just before you first saw this behavior had you done any
    editing of any files as root?

    or changed any boot up settings in YaST??

    --
    goldie

  3. #3

    Default Re: Immediate shutdown following boot completion.

    It shuts down before I can login, but stays up if I boot in single user mode.

    My boot parameters are the defaults AFAIK, I just append a space and the digit "1" to enter single user mode.

    I've fitted a brand new shiny expensive Corsair 450W power supply so I really don't think it's a hardware issue. If it was, it wouldn't explain why the machine is happy when in single user mode. The BIOS would make a horrid noise before the thermal cutout was triggered - overheating isn't apparent.

    I'm wondering if something is happening with either "at" or "cron" OR that my problem co-incides with my recent update to kernel 2.6.27-25. I see from another machine that 2.6.27-29 is available.

  4. #4

    Default Re: Immediate shutdown following boot completion.

    From single user mode, I've been able to read /var/log/messages at my leisure.

    Sadly, I can't see how to copy-paste what I've found.

    I'm getting an ACPI induced thermal trip with messages similar to those documented on this thread

    Help needed to debug ACPI critical shutdown - openSUSE Forums

    The 2nd post in that thread is interesting.

    Just ahead of that event in the log, I see that there is an ACPI resource conflict between the w83627hf (the chip that does the sensors on my mobo) at 0x295-0x296 and something called ACPI region IP_, also at 0x295-0x296. I tried re-running sensors-detect and it finds the w83627hf at 0x290.

    So I'm beginning to suspect the kernel update has b0rked something.

  5. #5

    Default Re: Immediate shutdown following boot completion.

    Well, here I am typing from the repaired machine ... I used YaST to disable lm_sensors, after reading more about the ACPI conflict on Google.

    I do miss having lm_sensors though.

  6. #6
    goldie NNTP User

    Default Re: Immediate shutdown following boot completion.

    good for you!!!

    is there a bug report on the ACPI-to-lm_sensors conflict?

    since it sounds (to me) to be a kernel level problem, it sure seems
    there should be a kernel hacker looking at this..

    --
    goldie

  7. #7

    Default Re: Immediate shutdown following boot completion.

    Quote Originally Posted by goldie View Post
    is there a bug report on the ACPI-to-lm_sensors conflict?
    My apologies for not completing this thread by including the diagnostics, since that's what will show up on Google and lead people here.

    It looks like people are already aware of this.

    ACPI: I/O resource w83627hf - Google Search[0x295-0x296]+conflicts+with+ACPI+region+IP__+[0x295-0x296]

    An example from /var/log/messages on my machine from before I disabled lm_sensors:
    Code:
    Aug 21 18:01:13 gojira kernel: w83627hf: Found W83627HF chip at 0x290
    Aug 21 18:01:13 gojira kernel: ACPI: I/O resource w83627hf [0x295-0x296] conflicts with ACPI region IP__ [0x295-0x296]
    Aug 21 18:01:13 gojira kernel: ACPI: Device needs an ACPI driver
    ...
    Aug 21 18:01:30 gojira kernel: ACPI: Critical trip point
    Aug 21 18:01:30 gojira kernel: Critical temperature reached (121 C), shutting down.
    Aug 21 18:01:30 gojira shutdown[3593]: shutting down for system halt

  8. #8
    goldie NNTP User

    Default Re: Immediate shutdown following boot completion.

    good wrapup, thanks..
    ::SOLVED::
    --
    goldie

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •