Results 1 to 5 of 5

Thread: ATI 9.8 only wallpaper wrong solution

  1. #1
    Join Date
    Jun 2008
    Location
    Roesrath/Germany
    Posts
    21

    Question ATI 9.8 only wallpaper wrong solution

    Hi everybody..

    I have made an update of the fglrx-driver from ati. From version 9.3 to 9.8. First I have deinstalled the old driver...after an reboot I installed the new one.

    So far so good.....openSUSE is booting..I can log into my desktop...everything looks fine BUT the wallpaper who has definitely the right solution for my desktop (1280x1024) is bigger than normal and slightly moving to the right of my screen. It fit the screen...but more to the right.

    Move back to driver 9.3. and everything is normal...also the wallpaper fits the screen with the right resolution.

    What can I do?


    Something I recognize when I login to my desktop...when I move the cursor to the bottem or to the right or left...the whole desktop is moving to the opposite side.
    When the desktop has completely loaded the desktop is fix.
    Greetings from Ice

    "There is no beast without cruelty!"

  2. #2
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: ATI 9.8 only wallpaper wrong solution

    iced empire adjusted his/her AFDB on Friday 21 Aug 2009 19:36 to write:

    >
    > Hi everybody..
    >
    > I have made an update of the fglrx-driver from ati. From version 9.3 to
    > 9.8. First I have deinstalled the old driver...after an reboot I
    > installed the new one.
    >
    > So far so good.....openSUSE is booting..I can log into my
    > desktop...everything looks fine BUT the wallpaper who has definitely the
    > right solution for my desktop (1280x1024) is bigger than normal and
    > slightly moving to the right of my screen. It fit the screen...but more
    > to the right.
    >
    > Move back to driver 9.3. and everything is normal...also the wallpaper
    > fits the screen with the right resolution.
    >
    > What can I do?
    >
    >
    > Something I recognize when I login to my desktop...when I move the
    > cursor to the bottem or to the right or left...the whole desktop is
    > moving to the opposite side.
    > When the desktop has completely loaded the desktop is fix.
    >
    >


    Sounds like the resolution system wide is slightly off and is not correcting
    till the ATI config file in your user account is read.

    One thing to try is to drop to drop to runlevel 3, create a new default
    xorg.conf and then run the aticonfig command again.

    If you logout of your desktop and at the login screen in the menu there is a
    "console" option, select that and then do these commands ( I will explain
    them in []`s ) but first make a backup copy of your /etc/X11/xorg.conf just
    call the backup something like xorg.conf-bak or similar so that you can
    always get it back if something goes wrong.

    login as root and enter the root password

    init 3

    [stop the x server and go to runlevel 3]

    sax2 -r -m 0=vesa

    [ the -r tells sax2 not to read the current config and reprobe the hardware,
    -m tells sax2 to use the default basic vesa module, 0=vesa tells it which
    graphic card should use the vesa]

    Now follow through the config but you should not change anything unless
    there is something that is very wrong, then save, please do the test first
    to make sure everything is OK.

    after you are back at the prompt run:

    aticonfig --initial

    [this should create a new xorg.conf for your fglrx drivers, you will see a
    little message to that effect]

    now just type:

    init 5

    to get to runlevel 5 and your nice new desktop ( hopefully )

    What has probably happened is that when you do aticonfig it read the current
    xorg.conf and if it sees a default one or one that does not point to the
    fglrx driver it will add the new parts to it, however if it sees that it has
    already been configured it will leave the xorg.conf alone, this can
    sometimes cause conflicts and give unexpected results.

    Now when you are back at the desktop as your user then open a console and
    type:

    amdcccle and you can use the ATI catalyst GUI to configure your user
    preferences for that specific login.

    Hopefully that should sort you out.

    Any probs just holler.

    HTH
    --
    Mark
    Caveat emptor
    Nullus in verba
    Nil illegitimi carborundum

  3. #3
    Join Date
    Jun 2008
    Location
    Roesrath/Germany
    Posts
    21

    Default Re: ATI 9.8 only wallpaper wrong solution

    Because I use Gnome and there is no possibility I know, I went from my desktop with the consol to runlevel 3.

    Than I backed up the xorg.conf and do a new one with Sax2 -r -m 1=vesa (becaue 0 gives me errors I think it is the channel for the possible internal graphic which is not there).

    The Testscreen from Sax2 appeared everything was fine. Then I have done aticonfig --initial and after that an reboot (just for my one benefit and to get sure).

    But..nothing changes at all. Is it possible that I have to delete some configs bevor I will login again?
    Greetings from Ice

    "There is no beast without cruelty!"

  4. #4
    Join Date
    Jun 2008
    Location
    Roesrath/Germany
    Posts
    21

    Default Re: ATI 9.8 only wallpaper wrong solution

    Ok...I worked a little bit yesterday about this problem.

    And I realized, that SaX2 is scanning the highest resolution for my screen with 1600x1200. When I install the ATI driver and then configure this one the resolution for the background is staying to 1600x1200 even when I configure it in with ATI for 1280x1024.

    I recognize this when going to skins.be and all wallpapers shown to me with resolution 1600x1200.

    So today I will build an new xorg.conf...than configure it with 1280x1024...and after that installing the ATI driver.
    Greetings from Ice

    "There is no beast without cruelty!"

  5. #5
    Join Date
    Jun 2008
    Location
    Roesrath/Germany
    Posts
    21

    Default Re: ATI 9.8 only wallpaper wrong solution

    Nope..doesn't work.

    So I went back to 9.3 and everything is fine. Waiting for 11.2 because I have to rebuild my system and then I will switch to the new ATI Driver.
    Greetings from Ice

    "There is no beast without cruelty!"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •