Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: old ati drivers

  1. #1

    Default old ati drivers

    Is it me or are the ATI catalyst drivers in the official repository incredibly stale?

    I have catalyst 9.2 installed (the latest in the repo) but I'm pretty sure they've released 9.7 or 9.8

    Now I really don't want to uninstall the drivers and then reinstall them the hard way, but I guess that's where I'm headed.

    Any caveats with that?

  2. #2
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: old ati drivers

    incognito9 adjusted his/her AFDB on Friday 21 Aug 2009 15:46 to write:

    >
    > Is it me or are the ATI catalyst drivers in the official repository
    > incredibly stale?
    >
    > I have catalyst 9.2 installed (the latest in the repo) but I'm pretty
    > sure they've released 9.7 or 9.8
    >
    > Now I really don't want to uninstall the drivers and then reinstall
    > them the hard way, but I guess that's where I'm headed.
    >
    > Any caveats with that?
    >
    >



    What card have you got ?


    --
    Mark
    Caveat emptor
    Nullus in verba
    Nil illegitimi carborundum

  3. #3
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,191

    Default Re: old ati drivers

    I always download the drivers from ATI/NVidia website and install them - the repo drivers tend to be lower performance. The downside is that you have to recompile/reinstall them whenever you do a kernel update!

    I have a cheapie MSI R3450 radeon-based card with 11.1. I've always had trouble with video drivers - for instance, the non-laptop-specific NVidia drivers will actually work with laptops if you "mod" the .inf file. So video drivers seem to have a set of "problems" all their own.

  4. #4
    Join Date
    Jun 2008
    Location
    Prescott, AZ
    Posts
    1,191

    Default Re: old ati drivers

    I forgot to mention - with the NVidia drivers, after a kernel update, the boot process dumps you to a console logon because it "can't find any screens" - you can logon there as root and run the installer and then reboot and all is well. With the ATI drivers, you will probably get dumped at a black-screen-of-death after a kernel update. You will need to reboot into "failsafe mode" in order to get a desktop and run the ATI driver installer, reboot, and all will be well.



    PS: The emergency reboot is "Alt+SysReq" then individually, in order: R E I S U B (magic keys)

  5. #5

    Default Re: old ati drivers

    ok so I uninstalled the drivers from the repositories, and followed the directions under "ATI:the hard way"

    It didn't seem very hard when I read it over. However it also didn't work.

    I logged off, switched to a console login <ctl-alt-f1>, logged in as root, switched to init level 3, and ran the commands in the howto that generate a new xorg.conf and try out the driver with sax2.

    My SaX2 log said "No Screens Found".

    Anyone else found this?

    <Sigh>

    Back to searching.

    <Edit I have an HD 3200 embedded graphics in my motherboard, by the way>

  6. #6

    Default Re: old ati drivers

    as you have discovered, these newer drivers are a bit of a problem... which is probably why the repo doesn't have the latest versions.

    in my opinion, the 9.2 to 9.6 drivers were not worth the effort since they were not very stable (at least for me), but... the recent 9.8 driver is much better and i encourage you to give it a try (as i am doing, with both fingers crossed).

    if you managed to build a rpm and install it, then ran aticonfig, followed by sax2 -r -m 0=fglrx... it will break. To me it seems that the modifications that aticonfig makes to the xorg.conf file describing the monitor arrangement are not compatible with sax2 and it hangs. if you had not run sax2, and rebooted after aticonfig --initial, it would have worked fine (until you tried to run sax2 from yast, it won't work...refuses to write to the xorg.conf file).

    if you had a copy of your xorg.conf file from before upgrading somewhere to replace the current mangled one, this could be easy.... copy to /etc/X11 and overwrite it... then run aticonfig --initial again from init 3.

    if you don't have a copy, then it will be more involved, you will have to manually edit xorg.conf if you have the knowledge of what you need in there. Or you can do plan b....

    revert to the radeon (or radeonhd) driver which should be installed and present on your machine.

    rpm -e $(rpm -qa '*fglrx*') -- remove all fglrx

    then,

    sax2 -r -m 0=radeon --to install radeon driver

    reboot, set up your machine for desired resolution and fontsize (at least mine changes everytime) and mouse settings.

    After you think you have it the way you want it, then make a copy of your xorg.conf file just in case and install your fglrx rpm as you did before, then just run aticonfig without the sax2 setup.

    It works this way, although you are unable to use sax2 after this.... you must use amdcccle to change display properties.

    Hopefully this situation will be addressed soon, seems everyone is aware of it... if you look in the release notes/install pdf files from ATI, they specifically mention this problem.

    good luck.

  7. #7

    Default Re: old ati drivers

    Quote Originally Posted by j_xavier View Post

    if you managed to build a rpm and install it, then ran aticonfig, followed by sax2 -r -m 0=fglrx... it will break.
    Wow. I did, in fact, build an rpm and install it, and I did run aticonfig followed by sax2, and it did, in fact, break. Should have talked to you earlier

    What I did was, from init 3, uninstall the rpm from yast and reinstall the 9.2 drivers from the repository. Then I ran sax2 and everything worked. Except, of course, that I was using the older drivers that I started out with. I guess I should have figured that they would have been in the repo if they were better, but you know I expected some mention of installation problems on Phoronix or something.

    To me it seems that the modifications that aticonfig makes to the xorg.conf file describing the monitor arrangement are not compatible with sax2 and it hangs. if you had not run sax2, and rebooted after aticonfig --initial, it would have worked fine (until you tried to run sax2 from yast, it won't work...refuses to write to the xorg.conf file).

    if you had a copy of your xorg.conf file from before upgrading somewhere to replace the current mangled one, this could be easy.... copy to /etc/X11 and overwrite it... then run aticonfig --initial again from init 3.

    if you don't have a copy, then it will be more involved, you will have to manually edit xorg.conf if you have the knowledge of what you need in there. Or you can do plan b....

    revert to the radeon (or radeonhd) driver which should be installed and present on your machine.

    rpm -e $(rpm -qa '*fglrx*') -- remove all fglrx

    then,

    sax2 -r -m 0=radeon --to install radeon driver

    reboot, set up your machine for desired resolution and fontsize (at least mine changes everytime) and mouse settings.

    After you think you have it the way you want it, then make a copy of your xorg.conf file just in case and install your fglrx rpm as you did before, then just run aticonfig without the sax2 setup.

    It works this way, although you are unable to use sax2 after this.... you must use amdcccle to change display properties.

    Hopefully this situation will be addressed soon, seems everyone is aware of it... if you look in the release notes/install pdf files from ATI, they specifically mention this problem.

    good luck.
    Since I've reinstalled the drivers, my xorg.conf should be fine.

    I'll try again with

    Code:
    aticonfig --initial --input=/etc/X11/xorg.conf
    from init 3 after I install the rpm and no sax2 ever after that.

    Wish me luck.

    If this works, maybe we should try to get the ATI howto updated to reflect these problems?

    edit:forgot a /quote

  8. #8

    Default Re: old ati drivers

    yes, this is not an elegant solution, hopefully the "powers that be" will make the proper adjustments to sax2 and make life easier.

    i haven't tried the reverse of this, just using sax2 without aticonfig... but i suspect it would work. one of these days i might try it.

    on a different note, i have a HD3850 on one box and had been stuck using Catalyst 8.1X drivers which were gradually obsoleting themselves due to kernel upgrades. none of the 9.X drivers were stable until 9.8 (hopefully). So far it's been much better, hope you have the same experience.

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: old ati drivers

    Quote Originally Posted by j_xavier View Post
    if you managed to build a rpm and install it, then ran aticonfig, followed by sax2 -r -m 0=fglrx... it will break.
    Hmm... sometimes I scratch my head over why I get lucky with these installs and everyone else has problems.

    I had 9.7 ATI driver on our Dell Studio-1537 laptop (with a radeon HD3450) and the 2.6.27.25 kernel, and when the new 2.6.27.29 kernel came out, I decided to use that opportunity to update to the 9.8 ATI driver. I downloaded that driver to my laptop's hard drive.

    So I then rebooted to run level 3 (I can never be bothered with the init-3 stuff) and I backed up the Dell's /etc/X11/xorg.conf (sort of common sense). I then did an rpm search for any rpms with "fglrx" in them, found one, and I removed it.

    I then built the driver "the hardway" mostly using the advice here: ATI/The Hard Way - openSUSE except its not so hard ... ie I ran " sh ati*.run --listpkg " and then ran " sh ati*.run --buildpkg SuSE/SUSE111-IA32 " for my 32-bit openSUSE-11.1. That created an rpm that I then installed.

    Then while I noted the instructions say to run "sax2 -r -m 0=fglrx" I stopped and thought for a second. The old xorg.conf worked for me. What is likely to change with an updated driver, since I had the previous 9.7 version of the proprietary driver running ? I was curious to find out. So I skipped the "sax2 -r -m 0=fglrx " step, and simply typed 'exit' to get rid of root permissions, and typed 'startx', and it just worked with a nice boot to KDE-3.5.10.

    So I am scratching my head now. It was easy. Incredibly so. What did I do wrong to skip the hard stuff ? Or was I just lucky?

  10. #10

    Default Re: old ati drivers

    oldcpu thanks for that note, it seems to confirm my suspicion that you could run either to set up the new driver... but not both.... and you are committed to using amdcccle (if you used aticonfig) or sax2 (if you used sax2 for setup) for changes.

    Since aticonfig saves old backups of xorg.conf i can tell you the differences are:

    Sax2 compliant modifications by aticonfig in older drivers

    Section "ServerLayout"
    Screen "Screen[0]"

    Section "Monitor"
    Identifier "Monitor[0]

    Section "Device"
    Identifier "Device[0]"

    Section "Screen"
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"

    New driver xorg.conf modifications:

    Section "ServerLayout"
    Identifier "Layout[all]"
    Screen 0 "aticonfig-Screen[0]-0" 0 0

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]-0"

    Section "Device"
    Identifier "aticonfig-Device[0]-0"

    Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device "aticonfig-Device[0]-0"
    Monitor "aticonfig-Monitor[0]-0"


    my first thought now is that just using a sax2 command would be the most beneficial, contrary to my advice to incognito... because the new aticonfig modifications makes sax2 unusable. Sure you can change resolutions with amdcccle, but you can't change your mouse setup, etc.

    The proper solution is for sax2 to recognize either method imo.

    btw, your experience keeps you from stumbling into obstacles that baffle the rest of us.
    Last edited by j_xavier; 22-Aug-2009 at 16:16. Reason: clairification

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •