Results 1 to 8 of 8

Thread: KBasic

  1. #1

    Default KBasic

    Just wondering if anyone has tried, and has an opinion about KBasic.

  2. #2
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: KBasic

    Mind the license: Everything written with KBasic must be released under GPL3.

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: KBasic

    Speaking of kbasic, I created this entry, with a request for KBasic in 11.3: https://features.opensuse.org/308466

    If anyone agrees with this, then please vote for the request.

    In truth, I don't think for a second that we will see it in 11.3, but I figure we need to ask (and at least keep asking for a while) until a way forward is in place.

    (note you vote for it by pressing on the up arrow key on the right side of this url: https://features.opensuse.org/308466)

  4. #4
    Join Date
    Jul 2009
    Location
    Rockyford Alberta Canada
    Posts
    1,388

    Default Re: KBasic

    Quote Originally Posted by silenuz View Post
    Just wondering if anyone has tried, and has an opinion about KBasic.
    Yes I have installed and used kBasic. It is QT4 integrated but at present doesn't handle all the QT4 widgets. It's nice because it allows you to program in Basic and implement the QT stuff right in the midst. Output is pure c/c++ which links to the QT library.
    When your up to your a** in Alligators it's pretty hard to remember you intended to drain the swamp (author unknown)

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: KBasic

    Quote Originally Posted by techwiz03 View Post
    Yes I have installed and used kBasic. It is QT4 integrated but at present doesn't handle all the QT4 widgets. It's nice because it allows you to program in Basic and implement the QT stuff right in the midst. Output is pure c/c++ which links to the QT library.
    We have been languishing at only 7 votes for this, which I doubt will be enough to have this implemented. I note this post on the opensuse-kde mailing list:
    This is a message I have received from Bernd Noechester, the developer of KBasic.

    > > Илья Черных schrieb:
    >> > > Hi! I've just asked people at OpenSUSE KDE team mailing list to pack KBasic but they say the ling to the source codes here source_codes KBasic is broken.
    >> > >
    > >
    > > Yes, you are right, because I am in process to setup a new package of
    > > source codes for all platforms which uses qmake scripts only. Tested
    > > them on Mac yesterday.
    > >
    > > Today I will do it on openSuse and then I will upload and inform about
    > > the new available package.
    > >
    > > It would be nice if you could inform the opensuse kde team about the
    > > availibility then. Thanks in advance.
    > >
    > > Kind regards,
    > > Bernd
    So it does appear someone in the KDE side of things is looking at this, although it appears Murphy's Law may have struck, and just at the time some one on the KDE team decided to look at this, the developer pulled the tarball ( ? ) from their web site, while an update was implemented.

    Still, independent of that , some more votes would be nice in openFATE. Users just need to login (enter their existing user name and password (the one from our forum should work)) and then vote.

  6. #6
    Join Date
    Jul 2009
    Location
    Rockyford Alberta Canada
    Posts
    1,388

    Default Re: KBasic

    Quote Originally Posted by oldcpu View Post
    We have been languishing at only 7 votes for this, which I doubt will be enough to have this implemented. I note this post on the opensuse-kde mailing list:
    So it does appear someone in the KDE side of things is looking at this, although it appears Murphy's Law may have struck, and just at the time some one on the KDE team decided to look at this, the developer pulled the tarball ( ? ) from their web site, while an update was implemented.

    Still, independent of that , some more votes would be nice in openFATE. Users just need to login (enter their existing user name and password (the one from our forum should work)) and then vote.
    I already voted, but haven't tried to compile a kBasic program. Only went far enough to see it's output was pure 'c/c++' one step shy of compiling into a finished project. Looking at the link it appears that I need to upgrade my QT4.5 to at least QT4.6 and upgrade my kBasic to the new package.

    For me, this creates a problem not with kBasic but with the underlying QT4.5. My last attempt to un-install QT4.5 and re-install QT4.5 on 11.1 un-installed most of my system leaving it badly broken. While I now know some of what caused this it still leaves me scared to do anything with QT.

    What I need to resolve before jumping down that road is:
    1) With my 11.1 / KDE4.3.1 / QT4.5, I had QtDevelop, QTAssistant, QTDesigner, QTLibraries4.5.1
    2) With my new 11.2 / KDE4.3.1 / QT4.5, I have QTCreator, QTAssist, QTTranslator, QTDebug, QTDesigner, QTLib4.5.6
    ** Note the difference in programs and versions

    It was said I created my own problem by installing from the wrong repo when I did the original 11.1 QT install, so I used a different repo when I re-installed 11.1 and retested install / remove QT4.5 with the same results as before. 11.2 came with QT4.5 already installed by default with the noted package differences. Do I really want to un-install QT4.5 and take a gamble of QT4.6? I really don't want to hose the 11.2 install like 11.1 was. I see this as a problem with QT which unfortunately is a dependency of kBasic.
    I wonder if the packagers of openSUSE QT are aware of the upgrade issue of QT so are withholding implementing a kBasic packagement.
    When your up to your a** in Alligators it's pretty hard to remember you intended to drain the swamp (author unknown)

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: KBasic

    Quote Originally Posted by techwiz03 View Post
    I see this as a problem with QT which unfortunately is a dependency of kBasic.
    I wonder if the packagers of openSUSE QT are aware of the upgrade issue of QT so are withholding implementing a kBasic packagement.
    That could be. I'll keep watching the openSUSE KDE mailing list, and if I see any relevant posts, I'll try to copy them here.

  8. #8
    Join Date
    Feb 2010
    Location
    South Dakota, USA
    Posts
    171

    Default Re: KBasic

    What I love about KBasic is so much coding that is familiar to me, e.g. QuickBasic 4.5 which I used back in the DOS days. This century I was using Visual Basic Express 2005, so KBasic has some similiar usages there as well.

    Oh. Note: KBasic 2 will become Q7Basic this year, which at this point, is scheduled to be released 05/23/2010;

    More info, downloads, etc. can be found at:

    Q7Basic

    If KBasic/Q7Basic will be included in openSUSE 11.3, one can still downloaded and install it manually (very easy) - mine is installed in the ~/Programs/kbasic Directory.

    Q7Basic is going to be a different beast of sorts.

    Regards,

    Clifton

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •