Hi,
I have a small build service project with 4 distributions, openSUSE_10.3, 11.0, 11.1, & Factory.
Two of my OBS repos have disappeared from rsync yet are still visible via http.
I have just noticed that my rsync mirror update script was failing because the 10.3 and Factory versions of my OBS project repos are no longer present via rsync from rsync.opensuse.org.

Is this expected behavior or an error or perhaps just a transient issue related to server maintenance? Should I arrange some other way to keep my local copies of those repos up to date?

See below, all 4 repos appear via http, but only 11.0 and 11.1 appear via rsync.

HTTP
Code:
bkw@ender:~$ html2text http://download.opensuse.org/repositories/home:/aljex/
****** Index of /repositories/home:/aljex ******
[Icon ] Name                    Last modified      Size
===============================================================================
[[DIR]] Parent Directory                             -
[[DIR]] openSUSE_10.3/          20-Aug-2009 13:58    -
[[DIR]] openSUSE_11.0/          20-Aug-2009 06:45    -
[[DIR]] openSUSE_11.1/          20-Aug-2009 12:02    -
[[DIR]] openSUSE_Factory/       20-Aug-2009 12:25    -
===============================================================================
     Apache/2.2.13 (Linux/SUSE) Server at download.opensuse.org Port 80

     MirrorBrain powered by Apache
bkw@ender:~$
RSYNC
Code:
bkw@ender:~$ rsync
 rsync://rsync.opensuse.org/buildservice-repos/home:/aljex/

This is rsync.opensuse.org, public rsync server of openSUSE.org,
limited to 50 connections.

If you run a public mirror, please get in contact so we can give you 
access to the stage rsync server.
You'll find conditions for access and further information at
http://www.opensuse.org/Mirror_Infrastructure

Thanks!
admin@opensuse.org


drwxr-xr-x         144 2009/07/27 04:38:17 .
drwxr-xr-x         200 2009/08/20 00:45:59 openSUSE_11.0
drwxr-xr-x         200 2009/08/20 06:02:09 openSUSE_11.1
bkw@ender:~$