Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: kdenlive - Rendered video shows as just black with audio!

  1. #1

    Default kdenlive - Rendered video shows as just black with audio!

    I created a project using a title (for 5 seconds) and an imported mpeg clip that has video and audio. While in kdenlive, the "project monitor" properly shows the title for 5 seconds and then plays the clip.

    However, when I render the video as an mpeg, it's just a black screen with audio starting after 5 seconds! What might be wrong?

    My rendering options:

    Destination: File Rendering
    MPEG-2 (200K)
    NTSC
    Scanning: auto
    Export Audio
    Full Project

    Please, any help is greatly appreciated!

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: kdenlive - Rendered video shows as just black with audio

    Quote Originally Posted by 6tr6tr View Post
    However, when I render the video as an mpeg, it's just a black screen with audio starting after 5 seconds! What might be wrong?
    Go to project > project settings, and ensure you have an appropriate setting applied.

    Also try different renderings than the one you applied.

  3. #3

    Default Re: kdenlive - Rendered video shows as just black with audio

    Quote Originally Posted by oldcpu View Post
    Go to project > project settings, and ensure you have an appropriate setting applied.

    Also try different renderings than the one you applied.
    How do I know I have the appropriate settings? (It is playing in the project monitor...)

    I did try a few diff. mpeg settings but have not yet gotten it to work.

    Does it matter that my profile is HDV 1440x1080 50i?

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: kdenlive - Rendered video shows as just black with audio

    Quote Originally Posted by 6tr6tr View Post
    Does it matter that my profile is HDV 1440x1080 50i?
    It probably does if the input video is not HDV 1440x1080 50i ... or the output video desired is not HDV 1440x1080 50i (I cant recall if it is input or output that is specified) ?

  5. #5

    Default Re: kdenlive - Rendered video shows as just black with audio

    Quote Originally Posted by oldcpu View Post
    It probably does if the input video is not HDV 1440x1080 50i ... or the output video desired is not HDV 1440x1080 50i (I cant recall if it is input or output that is specified) ?
    Which profile would I use if I just want to make mpegs? I have no idea how to choose one!

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: kdenlive - Rendered video shows as just black with audio

    Quote Originally Posted by 6tr6tr View Post
    Which profile would I use if I just want to make mpegs? I have no idea how to choose one!
    mpegs for what? create a custom DVD ? Did you have a specific output resolution in mind? Did you have a specific bit rate in mind?

  7. #7

    Default Re: kdenlive - Rendered video shows as just black with audio

    Quote Originally Posted by oldcpu View Post
    mpegs for what? create a custom DVD ? Did you have a specific output resolution in mind? Did you have a specific bit rate in mind?
    Just videos to show on a computer monitor. It will live on the hard drive not a DVD and doesn't need to be amazing resolution.

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: kdenlive - Rendered video shows as just black with audio

    Quote Originally Posted by 6tr6tr View Post
    Just videos to show on a computer monitor. It will live on the hard drive not a DVD and doesn't need to be amazing resolution.
    What quality are the originals in terms of resolution, bit rate, and frame rate?

  9. #9

    Default Re: kdenlive - Rendered video shows as just black with audio

    Quote Originally Posted by oldcpu View Post
    What quality are the originals in terms of resolution, bit rate, and frame rate?
    Well, that doesn't matter because even if I create a video without any clips imported and simply add a title clip only, it's still black.

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: kdenlive - Rendered video shows as just black with audio

    Quote Originally Posted by 6tr6tr View Post
    Well, that doesn't matter because even if I create a video without any clips imported and simply add a title clip only, it's still black.
    That does not read like much of a test to me.

    Try a low quality initially. Setting the project settings to DV/DVD NTSC.

    Then when rendering a video, put the settings to MPEG2 2000K

    Note it is important that you have not mixed videolan packaged rpms with packman packaged rpms, as IMHO that could have broken your kdenlive's rendering.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •