Results 1 to 4 of 4

Thread: Kernel up-grade.

  1. #1
    Join Date
    Jun 2008
    Location
    Portugal
    Posts
    234

    Default Kernel up-grade.

    Hi,

    OpenSuSE Team already reacted to upgrade the new found vulnerability (the null pointer dereference ... ) but ...

    I downloaded all kernel modules for this upgrade, and made:


    Code:
    rpm -ivh  kernel-default-2.6.27.29-0.1.1.x86_64.rpm 
    kernel-default-base-2.6.27.29-0.1.1.x86_64.rpm 
    kernel-default-extra-2.6.27.29-0.1.1.x86_64.rpm 
    kernel-source-2.6.27.29-0.1.1.x86_64.rpm 
    kernel-syms-2.6.27.29-0.1.1.x86_64.rpm 
    kernel-xen-2.6.27.29-0.1.1.x86_64.rpm 
    kernel-xen-base-2.6.27.29-0.1.1.x86_64.rpm 
    kernel-xen-extra-2.6.27.29-0.1.1.x86_64.rpm
    but I get the error :

    Code:
    Preparing...                ########################################### [100%]
            file /usr/lib/rpm/kernel-module-subpackage from install of kernel-source-2.6.27.29-0.1.1.x86_64 conflicts with file from package kernel-source-2.6.27.25-0.1.1.x86_64
    Has anyone installed the upgrade manually got this same problem?


    Regards,
    Pedro

  2. #2
    Join Date
    Jun 2008
    Location
    /dev/swat
    Posts
    1,181

    Default Re: Kernel up-grade.

    I got the update notification just now. Going to upgrade now.
    Linux[openSUSE, KDE], PHP, MySQL, Wordpress, Tech News, etc :
    http://anl4u.com

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,235
    Blog Entries
    15

    Default Re: Kernel up-grade.

    Quote Originally Posted by keyb user
    Hi,

    OpenSuSE Team already reacted to upgrade the new found vulnerability
    (the null pointer dereference ... ) but ...

    I downloaded all kernel modules for this upgrade, and made:



    Code:
    --------------------
    rpm -ivh kernel-default-2.6.27.29-0.1.1.x86_64.rpm
    kernel-default-base-2.6.27.29-0.1.1.x86_64.rpm
    kernel-default-extra-2.6.27.29-0.1.1.x86_64.rpm
    kernel-source-2.6.27.29-0.1.1.x86_64.rpm
    kernel-syms-2.6.27.29-0.1.1.x86_64.rpm
    kernel-xen-2.6.27.29-0.1.1.x86_64.rpm
    kernel-xen-base-2.6.27.29-0.1.1.x86_64.rpm
    kernel-xen-extra-2.6.27.29-0.1.1.x86_64.rpm

    --------------------


    but I get the error :


    Code:
    --------------------

    Preparing...
    ########################################### [100%]
    file /usr/lib/rpm/kernel-module-subpackage from install of
    kernel-source-2.6.27.29-0.1.1.x86_64 conflicts with file from package
    kernel-source-2.6.27.25-0.1.1.x86_64 --------------------


    Has anyone installed the upgrade manually got this same problem?


    Regards,
    Pedro

    Hi
    You need to use the U option to upgrade eg rpm -Uhv

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.2 Milestone 5 (i586) Kernel 2.6.31-rc6-3-desktop
    up 0:46, 2 users, load average: 0.78, 0.33, 0.12
    ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME


  4. #4
    Join Date
    Jun 2008
    Location
    Portugal
    Posts
    234

    Default Re: Kernel up-grade.

    Hi,


    I know.
    But in previous upgrades (the ones I did not mess it up) I used to also install the new kernel Maintaining the old one.
    Hence the -i option.


    Quote Originally Posted by malcolmlewis View Post
    Hi
    You need to use the U option to upgrade eg rpm -Uhv
    It used to work with no problem in the previous kernels ...

    And for a matter of caution I would like to keep first the previous kernel ..

    Regards

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •