If you're using eclipse 3.4 along with Firefox you might run into a nice error when trying to start eclipse asking you to check the log.

Check the log file as it asks you to and search for '-2147467262' as stated on
IRC FAQ - Eclipsepedia
(There will be tons of 'Widget disposed too early!' errors as well)

If you got an xp-com error on the same line open up YaST software management and search for 'xulrunner' and make sure you got both 190 and 191 installed.
Now you can successfully start eclipse by using this command
Code:
eclipse -vmargs -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib64/xulrunner-1.9
Hope it helps someone as this had me beat for several hours and it's hottest day of the year so far.. so not a good day to get frustrated

Other relevant links:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=213194
The SWT FAQ