Results 1 to 6 of 6

Thread: hot to transfer a large file

  1. #1
    Join Date
    Aug 2009

    Default hot to transfer a large file


    Sorry for the newbee question, but I'm lost in Linux.
    So, I want to transfer to Windows a large file (about 5 GB).
    I can't use a USB memory key because it's with FAT 32. I can't use a FAT32 partition on the HDD either.
    The reason is that FAT32 is limited to maximum 4 GB files.
    I can't use my NTFS partitions mounted under Linux because I have only read access on them from Linux and I'm afraid to not mess them up if I give write access.
    So, I was thinking to split the file in smaller pieces but I don't know what tool to use in Linux that permit to retrive the file in Windows.
    I was using compression programs before, like WinRAR or WinZIP that permit to store a file (no compression) and split the archive.

    I'm using OpenSUSE 11.0 64bit version with Gnome desktop.

    I've tried the program called File Roller but is very limited.
    In the file repository ( /sbin/yast2 --install ) I find nothing.

    Thank you for any suggestions.

  2. #2

    Default Re: hot to transfer a large file

    Just use rar I doubt it is installed so zypper in rar.

    It's on the packman repo which of course you have already

    As for the how try man rar after its installed I think its -v but not sure. Though to add many do use read/write with no problems but if you're concerned why not create a read/write share as ntfs.
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

  3. #3

    Default Re: hot to transfer a large file

    a simple solution , although not the best it worked for me this morning:

    - boot into your windows and format the drive ntfs (can be done under linux although I never got that working 100% with mkfs.ntfs)
    - boot into linux, insert the usb stick, when the popup comes select to do nothing.
    - open terminal, df -k will show you what the usb stick is, for this example lets /dev/sdd1
    - cd $home/Desktop
    - mkdir usb
    - su
    - ntfs-3g /dev/sdd1 usb
    - might need to set rights/users privileges (chmod/chown) on the usb directory you made and now holds the usb drive
    - when done umount the normal way

    ntfs-3g will mount the ntfs drive with write access IF you removed it properly in windows, so not yank it out as it might be marked dirty


    on another note, you could look for a windows based file splitter run it via wine in linux to make < 4gb blocks and glue them together with the same program in windows.

  4. #4
    Join Date
    Aug 2009

    Default Re: hot to transfer a large file

    OK, before I will install a file splitter I started the hard way: making the ****' USB key working with NTFS under Linux (OpenSUSE, of course).
    So, I manage to format the key in Windows XP with NTFS, I unplugged it with Remove USB from Windows, but ... in OpenSUSE I have big problems:
    - when I inserted it I got an error message ("impossible to mount volume", "error opening 'dev/sdd1/' ... see the picture)

    - I type df-k, but the memory key is not there (of course, I had an error message when I plugged it)
    - But it's there under YaST -> Partionner
    So, I don't know what else to try.

    I mention that the same memory key was working fine with FAT32 under OpenSUSE

    Thank you for your quick replies, I will try now with rar.
    Last edited by robertgf; 20-Aug-2009 at 09:21. Reason: mistype

  5. #5
    Join Date
    Aug 2009

    Default problem solved

    So I reply to myself, maybe that will help others.
    The easiest way to split a file was to use 7z in command-line. Well it's not so easy but I manage to split the file.
    There is another packing tool called peazip, but it's not installing ! Maybe it's because I use 64 bit version of OpenSUSE and I must install some additional libraries.

    Also for Windows there is a program called Ext2IFS (that allows to see EXT partitions under Windows) but it's not working for partitions created under OpenSUSE for some strange reason, maybe it's because
    Ext2FS 1.11 is not able to access Ext3 file systems with inodes of 256 bytes
    Anyway, thanks for those who toke the time to help me.
    Windows veteran now trying OpenSUSE 11.2 32-bit version

  6. #6

    Default Re: hot to transfer a large file

    the error I would guess comes from the desktop automount feature, it failed so df -k wont show it, fdisk -l will, just like yast partitioner. but strange that ntfs-3g gives a problem, could try to reinstall it via yast and would be interesting to see how it responds to the commandline.

    I wrote a filespliter under delphi years ago and this made me search for it, just tested it and runs fine with wine, it splits and merges with the click of a button. I uploaded both the exe and the source code RapidShare: 1-CLICK Web hosting - Easy Filehosting under linux run with 'wine akmsplitter.exe' and under windows just double click it

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts