Results 1 to 7 of 7

Thread: I broke VirtualBox :(

  1. #1

    Default I broke VirtualBox :(

    Everytime I launched VirtualBox it kept telling me there was a newer version available so today I decided to take the plunge. To make a long story short I upgraded to 2.0.4 but if I try to open VirtualBox (Applications>System>Emulator>VirtualBox OSE) nothing happens.

    I opened up a command line and issued the "whereis virtualbox" which showed the following:

    steve@linux-or59:/usr/lib/virtualbox> whereis virtualbox
    virtualbox: /usr/lib/virtualbox /usr/share/virtualbox
    I CD'd over to /usr/lib/virtualbox and tried to start it from there but got the following error:

    steve@linux-or59:/usr/lib/virtualbox> VirtualBox
    /usr/bin/VirtualBox: line 1: /usr/lib/virtualbox/VirtualBox: Permission denied
    If I SU to root I can run VirtualBox so I'm thinking I just need to change permissions somewhere?

    Any help would be appreciated

  2. #2
    Join Date
    Jun 2008

    Default Re: I broke VirtualBox :(

    chmod 755 /usr/lib/virtualbox/VirtualBox

  3. #3

    Default Re: I broke VirtualBox :(

    Well I ran that command and now I'm getting this error

    I also made sure I was a member of the VboxUsers group.

  4. #4

    Default Re: I broke VirtualBox :(

    I reinstalled virtualbox-ose (2.0.4) from Webpin

    and all is well. Thanks for the 1 response microchip8

  5. #5
    eberkers NNTP User

    Default Re: I broke VirtualBox :(

    Somehow I ran into the same problem, but I managed to fix the file permissions. After the following command it started again:

    sudo chmod o+x /usr/lib/virtualbox/VirtualBox

    in this way it preserves the set-user-on-execution bit. I have no clue what made it change, there was no update as far as I know.

  6. #6
    btont NNTP User

    Smile Re: I broke VirtualBox :(


    I had today the same problem.

    The reason:
    If SuSEconfig runs it resets the permissions of the files defined in /etc/permissions*.

    The solution:
    Open the file > /etc/permissions.easy < with vi, goto the end and change the lines of VirtualBox from permission 4750 to 4755.
    Save, Quit.
    Now run SuSEconfig and VirtualBox is working.

    You could also change the permissions of the file by hand but then you have to do it every time you made some changes with yast....

  7. #7
    Join Date
    Jan 2009
    The Netherlands

    Default Re: I broke VirtualBox :(

    Are you sure it has nothing to do with the kernel module? When I reinstall virtualbox or update to a newer version, it won't load either. But it tells me to do this:
    /etc/init.d/vboxdrv setup
    After executing this command as a root, virtualbox will load again.

    But then I'm using the non ose version, because of the USB-support, that I downloaded from Downloads - VirtualBox. Perhaps you are using the open source edition?

    Other tips might be found at
    Or did you already check this website?

    Good luck!
    Last edited by akaper; 20-Aug-2009 at 02:54. Reason: wan't to use tags for commandcode
    How vivid is the letting go of knowledge, where experience ends.

    Desktop AMD A6-3650 APU with Radeon(tm) HD Graphics, Leap 42.1
    Laptop HP Compaq 6710b, 64-bit, openSUSE Tumbleweed

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts