Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: OK, I admit it, I'm stupid. I can't get giver to work!

  1. #1

    Default OK, I admit it, I'm stupid. I can't get giver to work!

    I have an old Dell computer running openSuSE 10.3 (32 bit) and a newer computer (dual opteron) running openSuSE 11.1 (64 bit) with both computers connected to the Internet via a D-Link DGL 4100 router. I have installed Giver on both . . . and it is dead on both. When I start it up I get the "Giver recipients" window on both computers, but it is blank except for the "User Specified" tag on both computers. I have left and right clicked all over the window and the icon to try and get a "preferences" or similar window to come up, but nothing.

    I know it's supposed to "just work" but it doesn't for me! What stupid simple dumb thing am I doing wrong?

    Thanks!

    BillyDoc

  2. #2

    Default Re: OK, I admit it, I'm stupid. I can't get giver to work!

    OK, I found the preferences, click on a little gray window on the tool bar . . . but I still can't get it to work.

    Help!

  3. #3
    goldie NNTP User

    Default Re: OK, I admit it, I'm stupid. I can't get giver to work!

    BillyDoc wrote:
    > I still can't get it to work.


    this help?
    http://thelinuxmovement.blogspot.com...ng-review.html

    or, how about the documentaion that came with it??

    --
    goldie
    Give a hacker a fish and you feed him for a day.
    Teach man and you feed him for a lifetime.

  4. #4

    Default Re: OK, I admit it, I'm stupid. I can't get giver to work!

    Hi Goldie, thanks for the response!

    Actually I saw that site when I was searching, but didn't think it was relevant as it doesn't say anything about what to do after Giver is installed (because it "just works"). And I didn't have any trouble at all installing. I did the install for both computers directly from the openSuSE repository. I was under the impression that YAST would take care of all the dependencies.

    There is documentation?!! Where is it?

    BillyDoc

  5. #5
    Join Date
    Aug 2008
    Location
    Winnipeg, Canada
    Posts
    203

    Default Re: OK, I admit it, I'm stupid. I can't get giver to work!

    Giver uses random Port numbers, so in order to use it you have to go into YaST and stop the Firewall and make sure you select the radio button to not have the firewall to start on boot. I just installed it on my network and got it working that way.

    You can see for yourself that random ports if you start Giver in a terminal by typing giver, then exiting out of the program. Then starting it again.

    It is up to you, if the program is worth disabling your firewall.

    Cheers!

  6. #6
    goldie NNTP User

    Default Re: OK, I admit it, I'm stupid. I can't get giver to work!

    > There is documentation?!! Where is it?

    don't ask me, instead ask the Giver maker, distributor, community!!
    try: http://groups.google.com/group/giver-list/topics

    if there are no docs, start writing--and GIVE BACK to the open source
    community...free software is only free AND useful if folks do more
    than just *take*..

    on the other hand, if it requires you to turn off your firewall as
    etech97 writes, i'd suggest you look at other, more secure, file
    sharing options...there are PLENTY!!

    easy ain't so easy once you start cleaning up after a crack, identity
    theft, etc etc etc

    --
    goldie

  7. #7

    Default Re: OK, I admit it, I'm stupid. I can't get giver to work!

    That was it etech97, I disabled the firewalls on both machines temporarily and Giver worked.

    I can only hope that the developers find a way around this little feature, because I really hate the idea of leaving the firewalls open, and in fact have already closed them both back up. And I have another firewall in the router, so I guess it's just paranoid behavior on my part.

    Still, this issue makes the "it just works" claim a little bit of an exaggeration. I'm disappointed, because Giver would have been very useful for me, but it's "screens up" and back to the flash drive to transfer things for me.

    Thanks everyone for your help!

    BillyDoc

  8. #8

    Default Re: OK, I admit it, I'm stupid. I can't get giver to work!

    Hi Goldie,

    I just saw your post. It looks like we were both writing at the same time, more or less.

    Anyway, I would love to help and to give back as you say, but this is definitely not my area of expertise. You may remember that I couldn't even figure out how to bring up the "preferences" screen. Where I DO "give back" is on another blog (boatdesign.net) with circuit designs and similar things, which you may even find useful yourself if you like being on the water.

    "From each according to his ability, to each according to his needs." as Mr. Marx once paraphrased from the Bible (Acts 4:32-35).

    Thank you again for your help. I will definitely look into other file sharing options, as you suggest.

    BillyDoc

  9. #9
    goldie NNTP User

    Default Re: OK, I admit it, I'm stupid. I can't get giver to work!

    > I'm disappointed, because Giver would have been very
    > useful for me, but it's "screens up" and back to the flash drive to
    > transfer things for me.


    have you thought about rsync?

    it is really pretty simple..

    --
    goldie
    Give a hacker a fish and you feed him for a day.
    Teach man and you feed him for a lifetime.

  10. #10

    Default Re: OK, I admit it, I'm stupid. I can't get giver to work!

    Hi Goldie,

    Thanks! I'll check it out.

    BillyDoc

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •