Results 1 to 3 of 3

Thread: Zypper problem on Suse 11.0

  1. #1
    Join Date
    Sep 2008
    Location
    Porto Alegre, RS, Brazil
    Posts
    72

    Exclamation Zypper problem on Suse 11.0

    Hi all!

    I'm having a strange problem in one of my Suse 11.0 machines.

    There is a strange problem, affecting ALL repositories here. For all them when zypper or yast tries to access any of the repositories, I get messages like this:

    Code:
    O repositório 'openSUSE BuildService - OpenOffice.org' está atualizado.
    Construindo cache do repositório 'openSUSE BuildService - OpenOffice.org' [concluído]
    Erro ao construir o banco de dados:
    'repo2solv.sh' '-o' '/var/cache/zypp/solv/http:__download.opensuse.org_repositories_OpenOffice.org:_STABLE_openSUSE_11.0_/solv' '/var/cache/zypp/raw/http:__download.opensuse.org_repositories_OpenOffice.org:_STABLE_openSUSE_11.0_'
    /usr/bin/repo2solv.sh: line 30: cd: -o: invalid option
    cd: usage: cd [-L|-P] [dir]
    
    Ignorando o repositório 'openSUSE BuildService - OpenOffice.org' devido ao erro acima.
    Btw, sorry for the portuguese version.

    I don't know what it can be, but affects all them, making both zypper and yast resources managers useless. More interesting, when I try to place any files to substitute the failures, be it a mkdir for the solv plus a touch for the cookie, or the contents taken from a different machine where everything is working fine, in both cases it I use yast of zypper it CLEANS all the directories contents of each of the repository directories inside /var/cache/zypp/solv !!!

    Does anybody has a clue on it? After recovering almost the whole machine with the help of zypper, end up with this problem is a shame.

    Btw, when I was recovering the system the only affected repository was the mozilla one, but then when I was trying to solve the problem I issued a zypper clean -a which in turn just SPREAD the whole problem.

    Any help would be really appreciated!

    Thanks a lot in advance!

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: Zypper problem on Suse 11.0

    Line 30 in that shell script on my system doesn't look anything like your error message. Have you applied all updates? Well I suppose with zypper out of action, that might be a bit of a problem. Anyway, the version of the package that script comes from is:

    satsolver-tools-0.13.7-0.1.1

    See if you can update this manually.

    Hmm, just realised you are are writing about 11.0 and I have 11.1. However the same principle applies, you should apply any updates to the package from which the script comes from. Probably there was a corresponding update to satsolver-tools for 11.0 too.

  3. #3
    Join Date
    Sep 2008
    Location
    Porto Alegre, RS, Brazil
    Posts
    72

    Default Re: Zypper problem on Suse 11.0

    Ok, solved here. Just copied the repo2solv.sh script from one of the other machines. Somehow it got dammaged.

    Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •