Results 1 to 7 of 7

Thread: clock widgets in panel

  1. #1
    MissSvensson NNTP User

    Default clock widgets in panel

    My panel widgets refuse to show date or time. Nothing wrong with the time in the system settings, but the panel only displays 00:00 or nothing at all.

    It started after a failed upgrade. I have retraced all changed, but apparently something is still missing. My problem is that I can't figure out what package the widgets belong to, what's missing or how they are supposed to access date/time info.

    Anyone have a clue?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,738
    Blog Entries
    20

    Default Re: clock widgets in panel

    Sounds odd. I would check in software management that you don't have a load of red packages.
    it would be helpful if you post the result of this from a terminal:

    Code:
    zypper lr -d
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    MissSvensson NNTP User

    Default Re: clock widgets in panel

    Yes, it's a curious problem.

    Here's my zypper lr -d:


    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+-----------------+---------------------------+---------+---------+----------+--------+-------------------------------------------------------------------------------------------+--------
    1 | KDE4-desktop | KDE4-desktop | No | No | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.1 |
    2 | openSUSE 11.1-0 | openSUSE 11.1-0 | No | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
    3 | repo | NVIDIA Repository | Yes | Yes | 99 | rpm-md | http://download.nvidia.com/opensuse/11.1 |
    4 | repo-debug | openSUSE-11.1-Debug | No | No | 100 | yast2 | Index of /debug/distribution/11.1/repo/oss |
    5 | repo-source | openSUSE-11.1-Source | No | No | 100 | yast2 | Index of /source/distribution/11.1/repo/oss |
    6 | repo-update | openSUSE-11.1-Update | Yes | Yes | 20 | rpm-md | Index of /update/11.1 |
    7 | repo_1 | Main Repository (NON-OSS) | Yes | Yes | 80 | yast2 | Index of /distribution/11.1/repo/non-oss |
    8 | repo_2 | Main Repository (OSS) | Yes | Yes | 80 | yast2 | Index of /distribution/11.1/repo/oss |
    9 | repo_7 | VideoLan Repository | Yes | Yes | 99 | rpm-md | Index of /pub/videolan/vlc/SuSE/11.1/ |
    10 | repo_8 | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/packman/suse/11.1 |

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,738
    Blog Entries
    20

    Default Re: clock widgets in panel

    Quote Originally Posted by MissSvensson View Post
    Yes, it's a curious problem.

    Here's my zypper lr -d:


    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+-----------------+---------------------------+---------+---------+----------+--------+-------------------------------------------------------------------------------------------+--------
    1 | KDE4-desktop | KDE4-desktop | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.1 |
    2 | openSUSE 11.1-0 | openSUSE 11.1-0 | No | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
    3 | repo | NVIDIA Repository | Yes | Yes | 99 | rpm-md | http://download.nvidia.com/opensuse/11.1 |
    4 | repo-debug | openSUSE-11.1-Debug | No | No | 100 | yast2 | Index of /debug/distribution/11.1/repo/oss |
    5 | repo-source | openSUSE-11.1-Source | No | No | 100 | yast2 | Index of /source/distribution/11.1/repo/oss |
    6 | repo-update | openSUSE-11.1-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.1 |
    7 | repo_1 | Main Repository (NON-OSS) | Yes | Yes | 120 | yast2 | Index of /distribution/11.1/repo/non-oss |
    8 | repo_2 | Main Repository (OSS) | Yes | Yes | 120 | yast2 | Index of /distribution/11.1/repo/oss |
    9 | repo_7 | VideoLan Repository | No | No | 99 | rpm-md | Index of /pub/videolan/vlc/SuSE/11.1/ |
    10 | repo_8 | Packman Repository | Yes | Yes | 99 | rpm-md | Index of /pub/packman/suse/11.1 |
    Change your repos as above. I have disabled Videolan as that is the best policy for multi-media, but not related to your issue.

    The other changes are however related, and once done you should do an update.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    MissSvensson NNTP User

    Default Re: clock widgets in panel

    Excellent!
    That did it. Thanks a lot!

    Btw, why do you suggest different priority on the main repositories? Is it a general recommendation or just common sense? Have I been an idiot always prefering the main repository to other sources?

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,738
    Blog Entries
    20

    Default Re: clock widgets in panel

    Quote Originally Posted by MissSvensson View Post
    Excellent!
    That did it. Thanks a lot!

    Btw, why do you suggest different priority on the main repositories? Is it a general recommendation or just common sense? Have I been an idiot always prefering the main repository to other sources?
    happy it works now

    When you install openSUSE the OSS and NON-OSS would have been 120, Updates would be 20. (20) Is a higher priority than 120.
    But once you add build service repo's it tends to work better if the Update and Build service priority match. Always have OSS and NON-OSS lower priority (That's a higher number!!)

    You've not been an idiot, just a NooB
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    MissSvensson NNTP User

    Default Re: clock widgets in panel

    cheers! great to learn something new!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •