Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Still can't use zypper

  1. #1

    Default Still can't use zypper

    I'm running Suse 11.1. Some time ago, something happened which means I can't use zypper. Here's what I did today:

    cd /etc/zypp
    rm -rf repos.d
    zypper ar -f Index of /distribution/11.1/repo/oss openSUSE-11.1

    zypper in zypper

    and the usual error:

    Retrieving repository 'openSUSE-11.1' metadata [error]
    Repository 'openSUSE-11.1' is invalid.
    File /var/tmp/TmpFile.SVYs9S doesn't contain public key data
    Please check if the URIs defined for this repository are pointing to a valid repository.

    Does anyone know what's going on, and how I can fix it?

    Thanks,
    -A.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,788

    Default Re: Still can't use zypper

    It says:
    Code:
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Did you do that? A simple typing error, or a part of the path missing in the definition of the repo will make it invalid of course.
    Henk van Velden

  3. #3

    Default Re: Still can't use zypper

    Thanks - yes I've checked and double-checked; the URI is fine. It must be something else...

    Thanks again.

  4. #4

    Default Re: Still can't use zypper

    I even reinstalled zypper, and gpg in case it was a gpg fault, and I'm still getting the same error.

    -A.

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,788

    Default Re: Still can't use zypper

    I can not see any errors in your URL (as you already confirmed).

    Reinstalling will not help in most cases. That is more of a M$ sort of reaction to a problem .

    I can only suggest a few things:
    1) what when using YaST > Sogtware Repositories? I know YaST does in the end the same as you using zipper, but a test may be worthwhile.
    2) try the URL of a mirror, e.g.:
    Code:
    http://ftp5.gwdg.de/pub/opensuse/distribution/11.1/repo/oss/
    HTH
    Henk van Velden

  6. #6
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: Still can't use zypper

    Do you have any kind of proxy or nanny filter in the path that might corrupt downloads?

  7. #7

    Default Re: Still can't use zypper

    Right, added a fresh repository:

    zypper ar Index of /pub/opensuse/distribution/11.1/repo/oss gwdg_suse11.1

    Then "zypper in zypper" produced:

    "Error building the cache:
    File /var/tmp/TmpFile.Rinc8U doesn't contain public key data
    Warning: Disabling repository 'gwdg_suse11.1' because of the above error."

    Still confused!

    When attempting to use YaST, clicking on "Software Repositories" brought up the following error:

    "There were errors while restoring the repository configuration.
    Parse error"

    If I then hit "Continue" anyway and tried to install some software I get this error:

    "There was an error in the repository initialization.
    'gwdg_suse11.1': [|] Valid metadata not found at specified URL(s)
    History:
    - File /var/tmp/TmpFile.TPhxXb doesn't contain public key data"

    So it seems that my system is resolutely forbidding me to use zypper, or to install a repository!

    Still confused....

    Thanks,
    -A.

  8. #8
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: Still can't use zypper

    Is that public key file in /var/tmp still available to examine to see if it really is valid?

  9. #9

    Default Re: Still can't use zypper

    No, I've just checked and the public key isn't there - there's no such file in /var/tmp.

    -A.

  10. #10
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: Still can't use zypper

    Probably deleted on program exit. Only way to solve the problem that I can see is to somehow trace and verify each stage of repo registration. Any debug options you can use on zypper?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •