Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Help on how to debug an application

  1. #1
    Join Date
    Jan 2009
    Location
    Queens
    Posts
    126

    Default Help on how to debug an application

    Hello Everyone. I have an email application that crashes very often and after it crashes I cant restarted unless I log off. I tried to find the PID with the help of ps -ef and top but it was not listed. Does any one knows how to debug the program as I run it. or is there a command to see what is going on?
    Hmmmm I wonder how long before im good at this????????????

  2. #2
    Niclas Ekstedt NNTP User

    Default Re: Help on how to debug an application

    hgallo,

    First of all I would look into the log files to see if there's any info
    thee that may shed a light as to what is going on. If there's nothing
    in there you may try debugging using GDB (The GNU Debugger).
    Just google for 'gdb' there's a whole lot of info on how to use it.


    --
    _________________________________________
    Niclas Ekstedt, CNA/CNE/CNS/CLS
    Systems Engineer
    Atea Sverige AB


  3. #3
    goldie NNTP User

    Default Re: Help on how to debug an application

    what is the email application?
    did it suddenly begin to crash (like after an upgrade, or?)

    if you installed it with YaST: have you tried uninstalling and then
    reinstalling just that program with YaST??

    --
    goldie

  4. #4
    Join Date
    Jan 2009
    Location
    Queens
    Posts
    126

    Default Re: Help on how to debug an application

    Quote Originally Posted by Niclas Ekstedt View Post
    hgallo,

    First of all I would look into the log files to see if there's any info
    thee that may shed a light as to what is going on. If there's nothing
    in there you may try debugging using GDB (The GNU Debugger).
    Just google for 'gdb' there's a whole lot of info on how to use it.


    --
    _________________________________________
    Niclas Ekstedt, CNA/CNE/CNS/CLS
    Systems Engineer
    Atea Sverige AB
    Yeah I checked the /var/log/messages but there is nothing there, and the gdb program brings me to a (GDB) prompt I havent been able to figure out how to use it.
    Hmmmm I wonder how long before im good at this????????????

  5. #5
    Join Date
    Jan 2009
    Location
    Queens
    Posts
    126

    Default Re: Help on how to debug an application

    Quote Originally Posted by goldie View Post
    what is the email application?
    did it suddenly begin to crash (like after an upgrade, or?)

    if you installed it with YaST: have you tried uninstalling and then
    reinstalling just that program with YaST??

    --
    goldie
    The application is lotus notes. and no there was no upgrade, it seems that every time I get an email that redirects me to a website it makes it go down. i wont start after that, it doesnt happen all the time though...
    Hmmmm I wonder how long before im good at this????????????

  6. #6
    goldie NNTP User

    Default Re: Help on how to debug an application

    i may be wrong, but it sounds more like a Lotus Notes problem than an
    openSUSE problem...have you tried any of the IBM sites?

    like, maybe:
    http://www-10.lotus.com/ldd/dominowiki.nsf/
    http://www-01.ibm.com/software/lotus...s/support.html
    https://www.ibm.com/developerworks/lotus/community/

    one thing you might try is launching the app in a terminal and then
    when it crashes look at the terminal and see if there are any
    interesting output...

    and, is notes logging to /var/log something? have you looked at the
    logs to see if there are any error messages??

    --
    goldie

  7. #7
    Niclas Ekstedt NNTP User

    Default Re: Help on how to debug an application

    hgallo,

    > The application is lotus notes. and no there was no upgrade, it seems
    > that every time I get an email that redirects me to a website it makes
    > it go down. i wont start after that, it doesnt happen all the time
    > though...


    Lotus 'Notes you say, have you checked if there are any patches available?
    So this is something you build yourself, AFAIK, there's no special opensuse
    builds available, or was this a prebuilt rpm package you installed?


    --
    _________________________________________
    Niclas Ekstedt, CNA/CNE/CNS/CLS
    Systems Engineer
    Atea Sverige AB


  8. #8
    Niclas Ekstedt NNTP User

    Default Re: Help on how to debug an application

    hgallo,

    > Yeah I checked the /var/log/messages but there is nothing there, and
    > the gdb program brings me to a (GDB) prompt I havent been able to figure
    > out how to use it.


    http://linux.bytesex.org/gdb.html is a good place to start for using gdb.
    However I seriously doubt it will give you much. You'd better ask in the
    Lotus Notes forums if there are any.


    --
    _________________________________________
    Niclas Ekstedt, CNA/CNE/CNS/CLS
    Systems Engineer
    Atea Sverige AB


  9. #9
    Join Date
    Jan 2009
    Location
    Queens
    Posts
    126

    Default Re: Help on how to debug an application

    Quote Originally Posted by Niclas Ekstedt View Post
    hgallo,

    > Yeah I checked the /var/log/messages but there is nothing there, and
    > the gdb program brings me to a (GDB) prompt I havent been able to figure
    > out how to use it.


    gdb mini intro is a good place to start for using gdb.
    However I seriously doubt it will give you much. You'd better ask in the
    Lotus Notes forums if there are any.


    --
    _________________________________________
    Niclas Ekstedt, CNA/CNE/CNS/CLS
    Systems Engineer
    Atea Sverige AB
    Thank you i will give that a try and see what happens, so far I found out that the application crashes for sure when you click on a link that redirects you to a website.
    Hmmmm I wonder how long before im good at this????????????

  10. #10
    Join Date
    Jan 2009
    Location
    Queens
    Posts
    126

    Default Re: Help on how to debug an application

    Hmmm so I was able to catch the error on the terminal, this is what i got:

    /opt/ibm/lotus/notes/framework/rcp/eclipse/plugins/com.ibm.rcp.xulrunner.runtime.linux.x86_6.2.0.200811140851/xulrunner/libmozjs.so [0x9965314d]
    /opt/ibm/lotus/notes/framework/rcp/eclipse/plugins/com.ibm.rcp.xulrunner.runtime.linux.x86_6.2.0.200811140851/xulrunner/libmozjs.so [0x99659d11]
    /opt/ibm/lotus/notes/framework/rcp/eclipse/plugins/com.ibm.rcp.xulrunner.runtime.linux.x86_6.2.0.200811140851/xulrunner/libmozjs.so [0x9965b5c6]
    /opt/ibm/lotus/notes/framework/rcp/eclipse/plugins/com.ibm.rcp.xulrunner.runtime.linux.x86_6.2.0.200811140851/xulrunner/libmozjs.so [0x9964b2ca]
    ---------------------------------------
    JVMDUMP006I Processing dump event "gpf", detail "" - please wait.
    JVMDUMP007I JVM Requesting System dump using '/home/hgallo/lotus/notes/data/workspace/logs/core.20090822.151047.4241.0001.dmp'
    JVMDUMP010I System dump written to /home/hgallo/lotus/notes/data/workspace/logs/core.20090822.151047.4241.0001.dmp
    JVMDUMP007I JVM Requesting Snap dump using '/home/hgallo/lotus/notes/data/workspace/logs/Snap.20090822.151047.4241.0002.trc'
    JVMDUMP012E Error in Snap dump: {no trace engine}
    JVMDUMP007I JVM Requesting Java dump using '/home/hgallo/lotus/notes/data/workspace/logs/javacore.20090822.151047.4241.0003.txt'
    JVMDUMP010I Java dump written to /home/hgallo/lotus/notes/data/workspace/logs/javacore.20090822.151047.4241.0003.txt
    JVMDUMP013I Processed dump event "gpf", detail "".
    chamix/gdi/screen/chamscreendc.cpp 85 Error gdk_drawable_get_colormap returns NULL, use system colormap instead
    chamix/gdi/screen/chamscreendc.cpp 85 Error gdk_drawable_get_colormap returns NULL, use system colormap instead
    chamix/gdi/screen/chamscreendc.cpp 85 Error gdk_drawable_get_colormap returns NULL, use system colormap instead
    chamix/gdi/screen/chamscreendc.cpp 85 Error gdk_drawable_get_colormap returns NULL, use system colormap instead
    chamix/gdi/screen/chamscreendc.cpp 85 Error gdk_drawable_get_colormap returns NULL, use system colormap instead
    chamix/gdi/screen/chamscreendc.cpp 85 Error gdk_drawable_get_colormap returns NULL, use system colormap instead
    Stack base = 0x00001086, Stack size = 1080894630 bytes
    Fatal Error signal = 0x0000000b PID/TID = 4230/-1272473744
    Segmentation fault
    Hmmmm I wonder how long before im good at this????????????

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •