Results 1 to 8 of 8

Thread: Using at command

  1. #1

    Default Using at command

    I tried the following and saw nothing on my konsole.

    at 11:12
    warning: commands will be executed using /bin/sh
    at> echo "Hello World"
    at> <EOT>
    job 8 at 2009-08-17 11:12
    dhr@kermit:~>

    I checked system services and "atd" is enabled, What should I look at next or see my example wrong. All I want to do is just display a reminder on my konsole.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,240

    Default Re: Using at command

    Because you do an echo and the ouput is going to stdout (as allways and as there is no terminal and no statement to read it, it is lost), not to your console.

    When you just want to test if at works make it
    Code:
    echo "Hello World" >/tmp/at-test
    and afterwards look if /tmp/at-test is created and what is in there.

    In any case, as a normal user you are not allowed to write to the console.
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,240

    Default Re: Using at command

    Adding. You may write as root (you did understand that allready from my earlier post, I think). In that case you use /dev/console as output device:
    Code:
    echo "Hello World" >/dev/console
    But /dev/console is the current console. Mostly one uses the console at logical screen #1 (to be reached with Ctrl-Alt-F1 when you are running the GUI which is normaly on logical screen #7 and above). Other consoles are at logical screen #2-6. The output goes to the console at the current console on the then active logical screen (which is what you want I think), but when you are at the GUI when the job runs, there will be no output (iow, you will see nothing of it when you go to a console screen to late).
    Henk van Velden

  4. #4

    Default Re: Using at command

    I am new to SUSE so I am using KDE 3.5 with some konsoles. I also tried and couldn't get working
    dhr@kermit:~> at 16:53
    warning: commands will be executed using /bin/sh
    at> kdialog --msgbox "Hello" >/dev/console
    at> <EOT>

    But kdialog --msgbox "hello"

    Does work from my konsole, a dialog message box does show up on my screen. Which is all I am after from 'at'.

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,070
    Blog Entries
    15

    Default Re: Using at command

    Quote Originally Posted by drogers8
    I am new to SUSE so I am using KDE 3.5 with some konsoles. I also tried
    and couldn't get working
    dhr@kermit:~> at 16:53
    warning: commands will be executed using /bin/sh
    at> kdialog --msgbox "Hello" >/dev/console
    at> <EOT>

    But kdialog --msgbox "hello"

    Does work from my konsole, a dialog message box does show up on my
    screen. Which is all I am after from 'at'.
    Hi
    The atd service might be enabled, but is it running?
    Code:
    sudo /etc/init.d/atd status
    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.25-0.1-default
    up 13 days 1:00, 2 users, load average: 0.18, 0.19, 0.35
    GPU GeForce 8600 GTS Silent - Driver Version: 190.18


  6. #6

    Default Re: Using at command

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    After starting atd:

    sudo /etc/init.d/atd start #one-time... should make it permanent probably

    I then had the following in /var/log/messages as I tried to setup the job
    as shown above:

    Aug 17 15:32:00 mybox0 atd[6706]: PAM audit_log_acct_message() failed:
    Operation not permitted

    So, having had permissions errors with GUI nonsense from another
    user/service I exported my DISPLAY variable after setting it when setting
    up my job:

    export DISPLAY=:0.0 && kdialog --msgbox "Hello"

    and then it worked.

    Good luck.





    Malcolm wrote:
    >
    Quote Originally Posted by drogers8
    > I am new to SUSE so I am using KDE 3.5 with some konsoles. I also tried
    > and couldn't get working
    > dhr@kermit:~> at 16:53
    > warning: commands will be executed using /bin/sh
    > at> kdialog --msgbox "Hello" >/dev/console
    > at> <EOT>
    >
    > But kdialog --msgbox "hello"
    >
    > Does work from my konsole, a dialog message box does show up on my
    > screen. Which is all I am after from 'at'.
    >
    > Hi
    > The atd service might be enabled, but is it running?
    >
    Code:
    > sudo /etc/init.d/atd status
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.9 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJKic0nAAoJEF+XTK08PnB5fngQAJBzzFZX8aiG0FPGt9CV7hP5
    KjKMP/4d7bBkK9B6+lPGFXoph9622XmYTQBijEt/sHoEUAnil45cm1QDS9kG//VZ
    Wp++SSrpFJtYMuT9UMo63DLsb3OovQNSQq48USZ0KV44poL9SWQWaKx9LePU2BkA
    u6CrjhX28m4H3tgSZEVBujckLT9Awii78S6IWvDwF3ina3EgGhduOdKRv/bBQx48
    XkRfupCZu/AtRjHRGC9qAz+POm5Xo+Ve211ks6qq0vGmNzznfMmGrqH4eh4DX8lS
    ohAz8jQhCrvvuOJ+/EGQ7L/AAJ9Xg3HGpKkgDNjCyRFYhmkeZZKBrQYfGA5m3esY
    BlW5MW2OtQV46r/aiWA0DnzKmKZrV32/BRfXexzn56gfLRuBTgV0j80cBLmwXzlv
    1bp3u05iwz5ZOzx5N2ip4I2NcIfd2Ik2o7dbWwtYx54vADIyOLcXdLtWvDCQbN0E
    4ekot1cFwyV/oJ2dqYcshDAm4JyrA6qVLmmBrDAjFthuWmTFuJ1W+Bt+AO8nii+K
    /I11vF7fmVW6AxorWCV4zWNc7QrLskm9aXuo+D8q08Zn0uRDkcBzA9At/eepcBw0
    7H+yzbQ6xPM4yupDG1FO8JiLyHaa4i4Bh2b8RNXKd7YGbQ+m6vxP41Gaf7BGlkFK
    1cyizY6frWGEtQke7Zaj
    =tysp
    -----END PGP SIGNATURE-----

  7. #7

    Default Re: Using at command

    I echo $DISPLAY and got
    export DISPLAY=:0.0

    The daemon was running

    dhr@kermit:~> sudo /etc/init.d/atd status
    root's password:
    Checking for at daemon: running

    Why should I set the $DISPLAY var to the message I want to display. Isn't that what kdialog is for? Thank you for your help.

  8. #8

    Default Re: Using at command

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Um......... that's (set DISPLAY to the message you want to display) not
    what I typed at all. Give it a shot.

    Good luck.






    drogers8 wrote:
    > I echo $DISPLAY and got
    > export DISPLAY=:0.0
    >
    > The daemon was running
    >
    > dhr@kermit:~> sudo /etc/init.d/atd status
    > root's password:
    > Checking for at daemon: running
    >
    > Why should I set the $DISPLAY var to the message I want to display.
    > Isn't that what kdialog is for? Thank you for your help.
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.9 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJKipZfAAoJEF+XTK08PnB51GUQAJrL1IyF5fCbL/FrNf+xewIo
    aqLHPqkgxThsLytTc/3yslDmzRFe2dMMarrxVDExMpTMAZYa4FSKSeDMbdFFgEZS
    IS87MKCnE/XTn8sXKxNwVjBJY9jr7yz04Ven1+wDbIeyu+Pv0n8ZLsgntWOgfR/I
    Ih9DVN+r93Bg9kCMyhLQiFCjxrsxTz+FAXVw8XNb2W07Q6VMWsFn4qVKN6/3nx0g
    VMQcBxmX8NtGbi1SbUmIvi4X2j2LX1+c7aw/+pvJrFOPaYVhoRlDVTIfUT122fkx
    D2Ydap6z/FVmMmxXW0N5HGBtrWnmY35ON0VuOL+lgNMR/zPI4Vd7sxVQYH/lTi30
    i4TnTexjkzS8ByxtouJoVUB9c60sMfOmpS8SkMs7rH0TK8fFNU2UjKqJFPyLT35Y
    9o49IWd44N3zkbxLGivQCW1seq/mHb19iEx/5ig0do8HFN4of6gNfRJDOPKSzL23
    VqnZzWqjQjTM34jJVZ6K4meQCyZ+cF+V7krYN5lSOsypcfHacPxP/7+y7nvpecBw
    kmZTVkq/4uqtObOLyFAjLMPKODWPKfHm8JDW+tpr5ptW/Wqp/PzcYgXlle/PgOJb
    CCSPHQBPC4qTkI0OzmXO4gFzr1bPfUDvpMfDfZV9/FC4HWqCzY+7ySyNppQ+oPBh
    jJF0jZT4gTnwCk+MGWak
    =QftL
    -----END PGP SIGNATURE-----

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •