Results 1 to 9 of 9

Thread: TightVNC not using login screen

  1. #1

    Default TightVNC not using login screen

    I have my VNC set up like so.

    vncservice.sh
    Code:
    #!/bin/sh
    rm /tmp/.X11-unix/X*
    dbus-launch vncserver
    xstartup
    Code:
    #!/bin/sh
    /usr/bin/startkde
    And i'm using crontab to automatically run the script.

    What it is doing now is that when you sign into the VNC, it goes straight into the desktop of a user and not to the login screen even though no one has signed in yet.

    What I would like to do is for it to go into the login screen when you initiate the VNC. I tried using /usr/bin/kdm but it just goes to a gray screen.

  2. #2

    Default Re: TightVNC not using login screen

    bump
    Is this even possible?

  3. #3
    JosephKK NNTP User

    Default Re: TightVNC not using login screen

    On Tue, 25 Aug 2009 17:16:02 GMT, stanc
    <stanc@no-mx.forums.opensuse.org> wrote:

    >
    >bump
    >Is this even possible?


    This may be a dumb question, but: Did you logout on the previous
    session?

  4. #4

    Default Re: TightVNC not using login screen

    This is at startup. With no one logged in, tightvnc creates a logged in session. What I was it to do is create a session at a login screen instead of a desktop.

  5. #5
    JosephKK NNTP User

    Default Re: TightVNC not using login screen

    On Thu, 27 Aug 2009 03:06:02 GMT, stanc
    <stanc@no-mx.forums.opensuse.org> wrote:

    >
    >This is at startup. With no one logged in, tightvnc creates a logged in
    >session. What I was it to do is create a session at a login screen
    >instead of a desktop.


    OK. When and where and how does tightvnc get started? What options
    are used?

  6. #6
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,728
    Blog Entries
    2

    Default Re: TightVNC not using login screen

    Quote Originally Posted by JosephKK View Post
    On Thu, 27 Aug 2009 03:06:02 GMT, stanc
    <stanc@no-mx.forums.opensuse.org> wrote:

    >
    >This is at startup. With no one logged in, tightvnc creates a logged in
    >session. What I was it to do is create a session at a login screen
    >instead of a desktop.


    OK. When and where and how does tightvnc get started? What options
    are used?
    It's in OP's opening post. A cron job, probably a crontable entry like this:
    Code:
    @reboot /path_to/vncservice.sh
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  7. #7
    JosephKK NNTP User

    Default Re: TightVNC not using login screen

    On Fri, 28 Aug 2009 13:16:01 GMT, swerdna
    <swerdna@no-mx.forums.opensuse.org> wrote:

    >
    >JosephKK;2032482 Wrote:
    >> On Thu, 27 Aug 2009 03:06:02 GMT, stanc
    >> <stanc@no-mx.forums.opensuse.org> wrote:
    >>
    >> >
    >> >This is at startup. With no one logged in, tightvnc creates a logged

    >> in
    >> >session. What I was it to do is create a session at a login screen
    >> >instead of a desktop.

    >>
    >> OK. When and where and how does tightvnc get started? What options
    >> are used?

    >
    >It's in OP's opening post. A cron job, probably a crontable entry like
    >this:
    >Code:
    >--------------------
    > @reboot /path_to/vncservice.sh
    >--------------------


    That is a small fraction of the information that i asked for. What
    file and at what init? Whole filenames (FQFN), what is calling those
    files and when (in relation to the bootup sequence)?

  8. #8
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,728
    Blog Entries
    2

    Default Re: TightVNC not using login screen

    That is a small fraction of the information that i asked for. What
    file and at what init? Whole filenames (FQFN), what is calling those
    files and when (in relation to the bootup sequence)?
    Probably the OP couldn't understand what you just said -- I have trouble. Let me try:
    What file and at what init?
    the file is most likely vncservice.sh which was written down by the OP as follows:
    #!/bin/sh
    rm /tmp/.X11-unix/X*
    dbus-launch vncserver
    It's appears to be called from the crontable at boot time by the cron table entry as follows:
    @reboot /path_to/vncservice.sh
    Check man cron for more on cron and @reboot

    Seems to me that the OP is using a shell script to cancel old lock files that would prevent vnc from starting.

    The other file, xstartup, is installed by the tightvnc RPMs at instalaltion time. The OP has edited the standard file (which opens a console and not a GUI desktop) to be this:
    #!/bin/sh
    /usr/bin/startkde
    so that a KDE window will open when the vncserver (which is set to listen) gets the nod from a client coming in thru the firewall with the correct username and password.

    Is that what you were asking? -- you could use some more words perhaps, to clarify your question, it's a bit cryptic.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  9. #9
    JosephKK NNTP User

    Default Re: TightVNC not using login screen

    On Sat, 29 Aug 2009 05:06:02 GMT, swerdna
    <swerdna@no-mx.forums.opensuse.org> wrote:

    >
    >> That is a small fraction of the information that i asked for. What
    >> file and at what init? Whole filenames (FQFN), what is calling those
    >> files and when (in relation to the bootup sequence)?

    >
    >Probably the OP couldn't understand what you just said -- I have
    >trouble. Let me try:
    >> What file and at what init?the file is most likely vncservice.sh whichwas written down by the OP

    >as follows:
    >> #!/bin/sh
    >> rm /tmp/.X11-unix/X*
    >> dbus-launch vncserver

    >It's appears to be called from the crontable at boot time by the cron
    >table entry as follows:
    >> @reboot /path_to/vncservice.sh

    >Check man cron for more on cron and @reboot
    >
    >Seems to me that the OP is using a shell script to cancel old lock
    >files that would prevent vnc from starting.
    >
    >The other file, xstartup, is installed by the tightvnc RPMs at
    >instalaltion time. The OP has edited the standard file (which opens a
    >console and not a GUI desktop) to be this:
    >> #!/bin/sh
    >> /usr/bin/startkde

    >so that a KDE window will open when the vncserver (which is set to
    >listen) gets the nod from a client coming in thru the firewall with the
    >correct username and password.
    >
    >Is that what you were asking? -- you could use some more words perhaps,
    >to clarify your question, it's a bit cryptic.


    That is along the lines i was interested in. That autologin thing is
    really scary. It is not normal. I wanted the setup information to
    find that property, per OP request.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •