Results 1 to 3 of 3

Thread: Changing screensaver causes gnome to reboot/jump to login

  1. #1

    Default Changing screensaver causes gnome to reboot/jump to login

    OpenSuSE 11.0

    I noticed that my server if left long enough would end up at the login screen.

    After some tracking down I found it was the screensaver being on random so I figured that I just had a screensaver that was causing problems. I tabbed down through the screensavers and any that caused gnome to crash and end up at the login screen I removed from .../screensavers.

    However, I then went through the list again and it crashed on screensavers that it was fine on previously. Also, I noticed that it remembered the screensaver that was set when it crashed upon reopening the screeensaver screen and didn't crash.

    The conclusion is that it is not specific screensavers causing a problem but the changing through screensavers multiple times that is causing the crashing and sure enough if I don't use the Random setting, things work fine on any screensaver.

    Can anyone enlighten me as to why this would be happening and more importantly, how to fix it?

    I do not have desktop effects on but I am using NVIDIA drivers driving an 8600 GTS video card.

    Below is my xorg file which perhaps has something to do with it.

    Any help appreciated.
    Reggie.

    Code:
    # Modeline parameters:
    #
    #Modeline	
    #	# Label
    #	"1680x1050"
    #	# dot (pixel) clock
    #	146.00
    #	# Horz. timings
    #	1680	hdisp
    #	1800	hsyncstart
    #	1968	hsyncend
    #	2224	htotal
    #	# Vert. timings
    #	1050	vdisp
    #	1051	vsyncstart
    #	1054	vsyncend
    #	1117	vtotal
    
    Section "Files"
        InputDevices      "/dev/gpmdata"
        InputDevices      "/dev/input/mice"
        ... lots of fonts ...
    EndSection
    
    Section "Module"
        Load           "freetype"
        Load           "type1"
        Load           "dbe"
        Load           "glx"
        Load           "extmod"
    EndSection
    
    Section "ServerLayout"
        Identifier     "Layout[all]"
        Screen      0  "Screen0" 0 0
        Screen      1  "Screen1" Below "Screen0"
        InputDevice    "Keyboard[0]" "CoreKeyboard"
        InputDevice    "Mouse[1]" "CorePointer"
    EndSection
    
    Section "ServerFlags"
        Option         "AllowMouseOpenFail" "on"
        Option         "ZapWarning" "on"
        Option         "Clone" "off"
        Option         "Xinerama" "on"
    EndSection
    
    Section "Extensions"
        Option         "Composite" "Enabled"
    EndSection
    
    Section "InputDevice"
        Identifier     "Keyboard[0]"
        Driver         "kbd"
        Option         "Protocol" "Standard"
        Option         "XkbLayout" "us"
        Option         "XkbModel" "microsoftpro"
        Option         "XkbRules" "xfree86"
    EndSection
    
    Section "InputDevice"
        Identifier     "Mouse[1]"
        Driver         "mouse"
        Option         "Buttons" "7"
        Option         "Device" "/dev/input/mice"
        Option         "Name" "Holtek USB Mouse"
        Option         "Protocol" "explorerps/2"
        Option         "Vendor" "Sysp"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "LG"
        ModelName      "L227WTG"
        HorizSync      30-83
        VertRefresh    56-75
        DisplaySize    465 291  # Aspect ratio 1.600:1
        # Custom modes, http://www.tkk.fi/Misc/Electronics/faq/vga2rgb/calc.html Using settings showing in NVIDIA in WinXP
        Modeline "1680x1050"  146.25  1680 1784 1960 2240  1050 1053 1059 1089  -hsync +vsync
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor1"
        VendorName     "LG"
        ModelName      "L227WTG"
        HorizSync      30-83
        VertRefresh    56-75
        DisplaySize    490 642  # Aspect ratio 1.600:1
        # Custom modes, http://www.tkk.fi/Misc/Electronics/faq/vga2rgb/calc.html Using settings showing in NVIDIA in WinXP
        Modeline "1680x1050"     146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync
    
    #   DVI Only, sigh.
        # Shows up on analog but very dark
    #   Modeline "1680x1050" 153.78 1680 1712 2296 2328 1050 1071 1081 1103 -hsync +vsync
        # Monitor just shows "Out of range" error in analog on the following 2
    #   Modeline "1680x2100" 153.88 1680 1712 2296 2328 2100 2148 2159 2207 interlace -hsync +vsync
    #   Modeline "1680x2100" 153.88 1680 1712 2296 2328 2100 2148 2159 2207 interlace -hsync +vsync
    #   Modeline "1680x2100" 153.88 1680 1712 2296 2328 2100 2148 2159 2207 interlace
    EndSection
    
    Section "Device"
        Identifier     "Videocard0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8600 GTS"
        BusID          "PCI:1:0:0"
        Screen          0
    EndSection
    
    Section "Device"
        Identifier     "Videocard1"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8600 GTS"
        BusID          "PCI:1:0:0"
        Screen          1
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Videocard0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "TwinViewXineramaInfoOrder" "CRT-0"
        Option         "metamodes" "CRT-0: 1680x1050; CRT-0: 1280x1024; CRT-0: 1152x864; CRT-0: 1024x768; CRT-0: 800x600; CRT-0: 640x480; CRT-0: 720x400"
        SubSection     "Display"
            Depth       24
        EndSubSection
       Option         "AllowGLXWithComposite" "True"
    #  Option         "MultisampleCompatibility" "True"
    #  Option         "TripleBuffer" "True"
    #  Option         "OnDemandVBlankInterrupts" "True" # Expermental option
    EndSection
    
    Section "Screen"
        Identifier     "Screen1"
        Device         "Videocard1"
        Monitor        "Monitor1"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "MetaModes" "CRT-1: 1680x1050; CRT-1: 1400x900; CRT-1: 1280x1024; CRT-1: 1024x768; CRT-1: 800x600; CRT-1: 640x480"
        SubSection     "Display"
            Depth      24
        EndSubSection
       Option         "AllowGLXWithComposite" "True"
    #  Option         "MultisampleCompatibility" "True"
    #  Option         "TripleBuffer" "True"
    #  Option         "OnDemandVBlankInterrupts" "True" # Expermental option
    EndSection

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Changing screensaver causes gnome to reboot/jump to logi

    Personally I just disable screensavers, more trouble than they are worth. May be not what you wanted, but the best I can offer is - Try ONE screensaver or Blank Screen. Otherwise disable.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Changing screensaver causes gnome to reboot/jump to logi

    Installed SuSE 11.2 three days ago and have the same problem as Reggie. Changed from GDM to KDM trying to fix it. No dice. Configuring screensaver causes system crash. Does restart. When it was installed in GDM, the monitor was turned off after the time for screensaver was reached (20 min). I would like to cycle through some images as part of work, not only for pleasure. (Does that change this?) So, it would be good to know if anyone could suggest a fix or a place to get some info re this.

    In fact, the display properties all act rather peculiarly though randomly.


    Zenostar

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •