Results 1 to 10 of 10

Thread: External HDD won't auto-mount

  1. #1

    Default External HDD won't auto-mount

    I put a line in fstab,
    Code:
    sdb1                 /media/fantomext     auto       auto                  0 0
    edited the PolicyKit rule, and even set sdb1 to mount to /media/fantomext in YaST ("Do Not Mount at System Start-up" is unchecked). But despite all this, it's still not automatically mounting. What's going on here?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,818

    Default Re: External HDD won't auto-mount

    Because sdb1 does not exist on your system (except when your working directory happens to be /dev, which is not the case during the usage of /etc/fstab). Most probably /dev/sdb1 does.

    This may give you more info on the subject: SDB:Basics of partitions, filesystems, mount points - openSUSE

    And reading man fstab might also tell you the use of the fields in /etc/fstab. The third field (the first auto you have) must be the fstype. Now the man fstab page refers to man mount for this. There it says that when auto it tries to guess ... Better fill in what it is, so there is no guessing. And when you know what it is, you also know better what mount options (the fourth field) are valid for this fstype.
    Henk van Velden

  3. #3

    Default Re: External HDD won't auto-mount

    Huh. Now it mounts, but it's only accessible to root. Guess I've gotta look at the manual. What fun.

  4. #4

    Default Re: External HDD won't auto-mount

    I did it! I've never really used man before. I've known about it, but... It's actually useful and thorough.

    As it turns out, ntfs by default is only accessible by root, for whatever reason. So I had to use the option uid=1000 (my UID). (Root would be uid=0)

  5. #5

    Default Re: External HDD won't auto-mount

    Man, I really wish I could edit posts... Or at least for an hour after the posting. Oh well.

    Anyway, here's my problem now. Though I have access to the drive... Dolphin can open it and I can view files, but I can't, say, copy a file from my desktop to the external, I get a permission error. So it's read-only...
    Code:
    uid=value, gid=value and umask=value
           Set  the  file  permission on the filesystem.  The umask value is given in octal.  By default, the files are owned by root and not readable by somebody else.
    Let's see...

  6. #6

    Default Re: External HDD won't auto-mount

    Well, this is odd. YaST won't let me add rw to the fstab options... I get error code -3039, which I can't find any useful info on. Any ideas? I'm stumped. External is still not writable other than by root.

  7. #7
    goldie NNTP User

    Default Re: External HDD won't auto-mount

    YAOMTC wrote:
    > I did it! I've never really used man before. I've known about it, but...
    > It's actually useful and thorough.


    congratualtions, you are on your way to Linux Greatness!

    --
    goldie
    Give a hacker a fish and you feed him for a day.
    Teach man and you feed him for a lifetime.

  8. #8

    Default Re: External HDD won't auto-mount

    Quote Originally Posted by goldie View Post
    YAOMTC wrote:
    > I did it! I've never really used man before. I've known about it, but...
    > It's actually useful and thorough.


    congratualtions, you are on your way to Linux Greatness!

    --
    goldie
    Give a hacker a fish and you feed him for a day.
    Teach man and you feed him for a lifetime.
    Didn't notice my more recent posts, eh? Stopped at that one?

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: External HDD won't auto-mount

    AFAIK for NTFS it's better to use 'ntfs-3g' instead of 'auto'. See what happens if you make this line in /etc/fstab

    /dev/sdb1 /media/fantomext ntfs-3g rw, uid=1000 0 0

    Please 'man ntfs-3g' for more options.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  10. #10

    Default Re: External HDD won't auto-mount

    Ah, that did it. I had put the same line in there yesterday (before trying YaST), except I used ntfs instead of ntfs-3g. It works great now, thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •