Results 1 to 4 of 4

Thread: No Sound with VT1708S with OpenSuse11.1

  1. #1

    Default No Sound with VT1708S with OpenSuse11.1

    Hi,

    I just installed OpenSuse11.1 on my new laptop. Everything seems to be working fine with with the exception of the sound card.My notebook is completely silent.

    The codec of the audio card:
    Code:
    head -n 1 /proc/asound/card0/codec*
    Codec: VIA VIA VT1708S
    Searching the internet I found a few sites mentioning a driver for this codec but none that applied to OpenSuse11.1.
    Then I found a thread about a new Linux kernel version 2.6.28 which stated that this version added (among many other things) support for VT1708S.

    Now I have the following questions:
    • Did I understand the thread correctly that I have to get a Linux kernel of at least version 2.6.28 to get my sound card to work?
    • If I switch to a new kernel version, which version should I take? It seems that there is already version 2.6.31 available.
    • Would it be sensible to install milestone 5 of OpenSuse11.2 instead?


    Many thanks in Advance!

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: No Sound with VT1708S with OpenSuse11.1

    Quote Originally Posted by Sherman68 View Post
    I just installed OpenSuse11.1 on my new laptop. Everything seems to be working fine with with the exception of the sound card.My notebook is completely silent.

    The codec of the audio card:
    Code:
    head -n 1 /proc/asound/card0/codec*
    Codec: VIA VIA VT1708S
    If I go to the alsa web site, it notes support for this was added in 1.0.18 of alsa. Search results for VT1708S - AlsaProject

    openSUSE-11.1 has a mix of 1.0.17/1.0.18 of alsa and may not yet as packaged support that sound card. But there are new alsa rpms available that one can install (up to 1.0.20 of alsa).

    Quote Originally Posted by Sherman68 View Post
    Then I found a thread about a new Linux kernel version 2.6.28 which stated that this version added (among many other things) support for VT1708S.
    The kernel contains a version of alsa, but my understanding is one can also install alsa rpms that the kernel will use instead, if these rpms are installed.

    Quote Originally Posted by Sherman68 View Post
    Now I have the following questions:
    • Did I understand the thread correctly that I have to get a Linux kernel of at least version 2.6.28 to get my sound card to work?
    I don't know. I seriously doubt that is necessary. IMHO its not necessary. Just update alsa.

    Quote Originally Posted by Sherman68 View Post
    • If I switch to a new kernel version, which version should I take? It seems that there is already version 2.6.31 available.
    Don't update your kernel for sound, without trying an alsa update.

    Quote Originally Posted by Sherman68 View Post
    • Would it be sensible to install milestone 5 of OpenSuse11.2 instead?
    Yes. That is possible. That is also NOT recommended, unless you wish to do it for TESTING ONLY and not for day to day activities.

    Just update your alsa.

    There is guidance here for sound problems: SDB:AudioTroubleshooting - openSUSE
    ... now assuming you have checked all the nominal stuff (mixer, yast, alsaconf, etc ... ) then to update your alsa go here for user space alsa update commands: Alsa-update - openSUSE

    If the user-space alsa updates suggested above do not work, one can also try installing even more cutting edge (essentially daily (or momentary) snapshot packages from the upstream GIT trees) going here: Alsa-update-snapshot - openSUSE

    In each of those URLs, you must send 6 commands (an amazing number of users only send 3 commands ... I can NOT figure out how to stop them from making that mistake).

    Note a reboot is needed after each set of 6 zypper commands, in order to unload old alsa modules and load the new.

    If the above does not work, then write a bug report on openSUSE, as the packagers for openSUSE alsa are also alsa developers, and they definitely will be able to comment on the ability to get sound working without updating the kernel. Submitting Bug Reports - openSUSE

  3. #3

    Default Re: No Sound with VT1708S with OpenSuse11.1

    Hi oldcpu,

    Quote Originally Posted by oldcpu View Post
    openSUSE-11.1 has a mix of 1.0.17/1.0.18 of alsa and may not yet as packaged support that sound card. But there are new alsa rpms available that one can install (up to 1.0.20 of alsa).

    The kernel contains a version of alsa, but my understanding is one can also install alsa rpms that the kernel will use instead, if these rpms are installed.
    ...
    There is guidance here for sound problems: SDB:AudioTroubleshooting - openSUSE
    Many thanks for your suggestion! Switching to 1.0.20 indeed did the trick!

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: No Sound with VT1708S with OpenSuse11.1

    Quote Originally Posted by Sherman68 View Post
    Many thanks for your suggestion! Switching to 1.0.20 indeed did the trick!
    Superb ! Glad to read its working for you now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •