Results 1 to 10 of 10

Thread: "Undefined video mode 346"

  1. #1
    Join Date
    Aug 2009
    Location
    Wales
    Posts
    49

    Question "Undefined video mode 346"

    While booting SUSE 11.1 64-bit I get these messages:
    Code:
    Probing EDD (edd off to disable)
    Undefined video mode 346
    Press Enter to see video modes available
    And then a 30-second wait.

    Is it advisable to set edd off? If so, how?

    Would that get rid of the 30-second wait?

    The video card (NVidia GeForce 6150 LE) and the monitor (ViewSonic VA2216W-4) seem to work fine with SUSE, so I don't understand the "Undefined video mode" message.

    Having said that, I've seen much better text-rendering than, for instance, this messageboard. See attached image. Could that be a card/monitor problem? It looks better in Vista with the same hardware. So does Firefox in general.

    [I just realised that I can't post attachments. Is that the general rule here?]

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: "Undefined video mode 346"

    You can add the edd=off to the boot arguments in /boot/grub/menu.lst

    To edit that file depending if you use kde or gnome:

    kdesu kwrite /boot/grub/menu.lst

    gnomesu gedit /boot/grub/menu.lst

    But actually, if you try the failsafe boot option First.. because that has edd=off in the boot arguments already.

    Add pictures using a hosting service like imagebam
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Aug 2009
    Location
    Wales
    Posts
    49

    Default Re: "Undefined video mode 346"

    Thank you, Caf. Here's the image at Imagebam . . . screenshot

    [See post #1 for question about screen quality in Linux.]

  4. #4
    Niclas Ekstedt NNTP User

    Default Re: "Undefined video mode 346"

    Weyland-Yutani,

    I too am running 64-bit 11.1 on a laptop with an NVidia 570M adapter,
    having an external ViewSonic VA903b monitor.

    The message about EDD is standard AFAIK, and nothing to be alarmed
    of. The Undefined Video Mode however is. This tells that the value of the
    VGA boot parameter is wrongly set for your configuration.
    I'm running with a resolution of 1280x1024 and thus I have the VGA parameter
    set to 0x31A (you may find out the VGA modes and codes at
    http://wiki.antlinux.com/pmwiki.php?n=HowTos.VgaModes)

    Make sure that the VGA mode parameter is set to the desired resolution and
    that your adapter/monitor can handle this.


    --
    _________________________________________
    Niclas Ekstedt, CNA/CNE/CNS/CLS
    Systems Engineer
    Atea Sverige AB


  5. #5
    Join Date
    Aug 2009
    Location
    Wales
    Posts
    49

    Default Re: "Undefined video mode 346"

    Quote Originally Posted by Niclas Ekstedt View Post
    (you may find out the VGA modes and codes at
    AntLinux Wiki - HowTos/VgaModes)

    Make sure that the VGA mode parameter is set to the desired resolution and
    that your adapter/monitor can handle this.
    Thank you, Niclas.

    This monitor is 1680x1050, WSXGA+, 24-bit colour. There is no code for that on the page you mentioned. Is it safe to pick another code which is mentioned there? (The one in my menu.lst file -- vga=0x346 -- is not there either.)

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: "Undefined video mode 346"

    I don't pretend to understand the nature of your problem - But did you try Failsafe?

    Re; Rendering
    I can't say I have anything to compare it with and then it's just a screen shot! Have you tried adjusting the fonts in the desktop settings and using Anti-Aliasing?
    My settings
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Niclas Ekstedt NNTP User

    Default Re: "Undefined video mode 346"

    Weyland-Yutani,

    > This monitor is -1680x1050, WSXGA+, 24-bit colour-. There is no code
    > for that on the page you mentioned. Is it safe to pick another code
    > which *is* mentioned there? (The one in my -menu.lst- file --
    > -vga=0x346- -- is not there either.)


    And that's the reason for the message during boot. Sure you try another mode.
    Best bet is to check what modes your adapter can handle, most often 'hwinfo'
    will give that info. But I've seen cases where NVidia adapters not always
    reporting this to hwinfo. In such a case 'vbetest' out of the vbespy package
    can be of help. It can be downloaded from
    www.phoronix.net/downloads/vbespy.tar.bz2.

    Anyhow, for 1680*1050 at 24 bit, the VGA mode should probably be set to 0x0369
    you can give that a try.


    --
    _________________________________________
    Niclas Ekstedt, CNA/CNE/CNS/CLS
    Systems Engineer
    Atea Sverige AB


  8. #8

    Default Re: "Undefined video mode 346"

    I also have this problem on Suse 11.2 using NVidia GEForce 8500 adapters and a pair of Viewsonic VX2250WM monitors set to their native resolution --1920 x 1080. It makes boot a little more hassle having to hit the space bar where indicated. However the machine --and monitors seem to run fine.

    As a note I am using the NVidia configuration utility to set the monitor parameters for X. The Viewsonics replaced a pair of Samsung Syncmaster 206's that failed due to sub standard capacitors on the power supply board. When I connected the Viewsonics, the NVidia utility recognized them and made the native resolution available as an option. Apparently the NVidia utility doesnt report this correctly to VGA mode. I was curious to see after things were running, whether Yast HWInfo would pick up the monitors correctly. The utility would not run to completion, hanging for an hour on probing the monitors. I finally killed -9 to get rid of it.

    Were it possible to enter the correct code per Niclas Ekstedt's post (thanks Nick for this information) I would do so but apparently the VGA table has not kept up with monitor resolution.

    This has been my experience with this problem after changing to the new wide view monitors.

  9. #9
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    3,234

    Default Re: "Undefined video mode 346"

    AFAIK there are three video "modes" during boot: the bios vga driver (vesa or something equally basic, I think), used from start to grub menu, the prior-to-X-start sequence (no idea what's the driver), that uses the vga=0xNNN parameter if specified, and of course, the final video driver that X loads. So any vga=0xNNN issue has nothing to do with the nvidia driver or utilities, for example, as those haven't even started yet. That's why some monitors might blank out after grub starts but work OK when X loads. I had this happen to me more than once, the most recent with an intel pineview atom cpu running 11.3 32 bits.

  10. #10
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    3,234

    Default Re: "Undefined video mode 346"

    Forgot to say, if there's no vga code for your resolution just use one your monitor supports - 1024 x 768 certainly, 1280 x 1024 probably. Also note that there are different codes for the same resolution but different color levels (8 bit, 16 bit, etc.). In three 1920 x 1200 monitors I use openSUSE defaults to 1280x1024, 16 bits (modo 0x31a).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •