Results 1 to 8 of 8

Thread: Driver missing in YOU on-line update, where is it?

  1. #1

    Unhappy Driver missing in YOU on-line update, where is it?

    I ran a YOU update and got a message about an alsa driver that is not found.

    Anybody know
    1) Where this driver can be found
    2) might this be why I have sound in KDE3 but not KDE4 ?

    Thanks for the info,
    Bruce


    File './x86_64/alsa-driver-unstable-kmp-default-1.0.20.20090529_2.6.27.21_0.1-1.1.x86_64.rpm' not found on medium 'http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.1_Update/'

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Driver missing in YOU on-line update, where is it?

    Quote Originally Posted by mbmcf View Post
    I ran a YOU update and got a message about an alsa driver that is not found.

    Anybody know
    1) Where this driver can be found
    2) might this be why I have sound in KDE3 but not KDE4 ?

    Thanks for the info,
    Bruce

    File './x86_64/alsa-driver-unstable-kmp-default-1.0.20.20090529_2.6.27.21_0.1-1.1.x86_64.rpm' not found on medium 'http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_11.1_Update/'
    Rather than speculate, you could you answer some questions and provide more information?

    Do your KDE3 and KDE4 use the same root ( / ) partition on this PC, or do they have separate root ( / ) partitions ?

    Can you provide the output for your KDE3 and KDE4 of:
    rpm -qa | grep alsa
    rpm -qa | grep pulse
    rpm -q libasound2
    uname -a
    cat /etc/modprobe.d/sound

    If they are the same, then only post the one from either KDE3 or KDE4. If they are different, post both from each of KDE3 and KDE4.

  3. #3

    Default Re: Driver missing in YOU on-line update, where is it?

    Same root partition AFAIK. Below are the entries from KDE4, I can't test or give the KDE3 entries to you because I told KDE3 to use Compiz, not all I get is a pure white screen and I can't seem to find where I have to undo the Compiz entry to get KDE3 to present a readable display again... OK, I'll restart KDE3 & use a script to capture the output, will post following...
    -KDE4--------------
    bruce@homebox:/tmp> rpm -qa | grep alsa
    tsalsa-20080914-0.pm.1
    alsa-oss-1.0.17-1.43
    alsa-driver-kmp-default-1.0.20.20090709_2.6.27.23_0.1-1.1
    alsa-firmware-1.0.17-1.42
    alsamixergui-0.9.0rc1-584.91
    alsa-docs-1.0.18-8.9
    alsa-devel-1.0.18-8.9
    alsa-oss-32bit-1.0.17-1.37
    alsa-plugins-1.0.18-6.13
    alsaplayer-0.99.80-1
    alsa-tools-gui-1.0.18-1.16
    alsa-tools-1.0.18-1.16
    alsa-plugins-pulse-1.0.18-6.13
    alsa-tools-devel-1.0.18-1.16
    alsa-1.0.18-8.9
    alsa-utils-1.0.18-6.4
    kalsatools-1.5.0-499.110

    ------------------------
    bruce@homebox:/tmp> rpm -qa | grep pulse
    pulseaudio-0.9.14-2.2.1
    pulseaudio-module-x11-0.9.14-2.2.1
    pulseaudio-module-jack-0.9.14-2.2.1
    vlc-aout-pulse-0.9.8a-1.4
    pulseaudio-esound-compat-0.9.14-2.2.1
    pulseaudio-lang-0.9.14-2.2.1
    libpulse-browse0-0.9.14-2.2.1
    pulseaudio-module-zeroconf-0.9.14-2.2.1
    pulseaudio-utils-0.9.14-2.2.1
    libpulse-mainloop-glib0-0.9.14-2.2.1
    alsa-plugins-pulse-1.0.18-6.13
    libpulse0-32bit-0.9.14-2.2.1
    pulseaudio-module-lirc-0.9.14-2.2.1
    libpulse0-0.9.14-2.2.1
    libxine1-pulse-1.1.15-23.3.3
    pulseaudio-module-bluetooth-0.9.14-2.2.1

    ----------------------------
    bruce@homebox:/tmp> rpm -q libasound2
    libasound2-1.0.18-8.9

    ----------------------------
    uname -a
    Linux homebox 2.6.27.25-0.1-default #1 SMP 2009-07-01 15:37:09 +0200 x86_64 x86_64 x86_64 GNU/Linux

    ----------------------------
    # u1Nb.Cq3sSwCsn7B:82801G (ICH7 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel

  4. #4

    Default Re: Driver missing in YOU on-line update, where is it?

    OK I ran the script on KDE3 and KDE4 and got the same results, no differences noted with DIFF. Curious as to why sound would work in KDE3 but not KDE4...

    Thanks for any tips or help to point me in the right direction!

  5. #5

    Default Re: Driver missing in YOU on-line update, where is it?

    OK, ripped out ~/.kde from the home directory & KDE3 comes up again, still no sound though...

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Driver missing in YOU on-line update, where is it?

    Quote Originally Posted by mbmcf View Post
    .......
    alsa-driver-kmp-default-1.0.20.20090709_2.6.27.23_0.1-1.1
    .........
    Linux homebox 2.6.27.25-0.1-default #1 SMP 2009-07-01 15:37:09 +0200 x86_64 x86_64 x86_64 GNU/Linux
    What does that tell you ?

    It tells me you have a version of alsa-driver-kmp-default specifically built for the 2.6.27.23 kernel, and you are trying (unsuccessfully) to use it on the 2.6.27.25 kernel.

    You probably need to update your alsa version to work with the 2.6.27.25 kernel.

    I note your kernel is the 2.6.27.25-0.1-default. So please go here and update your alsa. Please note, you MUST send 6 zypper commands. 6 commmands! Many users only send 3, and I can not figure out how to improve that guide to stop them from NOT reading the guide and only sending 3 commands. So send the proper 6 zypper commands: Alsa-update - openSUSE ... send the 3 generic commands for 11.1 and then the 3 specific to your kernel version.

    Reboot and test your audio.

    If the user-space alsa updates suggested above do not work, try installing even more cutting edge (essentially daily (or momentary) snapshot packages from the upstream GIT trees). Again, read the guide! You must send 6 zypper commands. 3 for openSUSE-11.1 in general, and 3 specific to your kernel. There is guidance here for that: Alsa-update-snapshot - openSUSE You may be told that some of those apps are already installed. Even if you get that, keep sending the next command.

    Reboot and test your sound.

  7. #7

    Smile Re: Driver missing in YOU on-line update, where is it?

    Thanks for the help OLDCPU. I had forced an Alsa update a few days ago & that seemed to fix my sound problem. There were some issues an update or two ago with the 64bit version & I seem to remember having to force some ZYPPER updates to get the sound to work. Maybe the latest kernel update along with other YOU updates upset the proverbial applecart. I've got that Sound page bookmarked now so if I blunder again I'll be able to quickly find it.

    Again, thanks for the help !

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Driver missing in YOU on-line update, where is it?

    Quote Originally Posted by mbmcf View Post
    I had forced an Alsa update a few days ago & that seemed to fix my sound problem.
    Well done in sorting it.

    No sooner had I typed that previous post, when SuSE-GmbH put an update out to the kernel from 2.6.27.25 to 2.6.27.29, and I immediately started to wonder how all the users I had helped with kernel specific alsa versions were going to survive.

    I updated the two wiki as soon as I could (which provide guidance) but I had visions of lots of breakage and complaining posts of no sound from many users. Fortunately it has not been too bad thus far.

    Quote Originally Posted by mbmcf View Post
    Maybe the latest kernel update along with other YOU updates upset the proverbial applecart. I've got that Sound page bookmarked now so if I blunder again I'll be able to quickly find it.
    I've puzzled over how to improve the current situation (where kernel updates can break the sound) and I confess people smarter than I will need to sort it.

    I do note that one thing that has been done, is alsa is now included with the kernel (although the alsa version in the kernel does tend to lag the kernel version one can get from an rpm). For example with 2.6.27, the kernel's audio drivers maintained by the Alsa Project (Advanced Linux Sound Architecture) have approximately reached the level of version 1.0.17 of the Alsa driver (and are included in the kernel). But a lot of the new hardware need the 1.0.18, or 1.0.19, or the 1.0.20 alsa.

    openSUSE-11.2 with its 2.6.31 kernel will come with the 1.0.20 alsa inside the kernel.

    The advantage here being: if alsa is inside the kernel, then alsa is not broken by a kernel update.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •