Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Upgrading from Kde 4.1 to Kde 4.3... a little help pls

  1. #1

    Default Upgrading from Kde 4.1 to Kde 4.3... a little help pls

    Hi all.... I usually download and install the latest remix of Opensuse with the latest Kde version as I've been too lazy in the past to sort out dependancy errors... but I want to get my head around Yast....

    Ok... So I installed the official Opensuse 11.1 Dvd with Kde 4.1x and so far, I used the 1 click install to upgrade to Kde 4.3....(Yes I know its better to add the repo manually and update rather than use 1 click install.... but I don't see the difference... as the 1 click install adds the same repo automatically and updates from it as it would if you added it manually and update from it) But Anyways..... To my suprise Kde 4.3 successfully installed to the nice looking Air Desktop...(after deleting the .kde4.3 folder and re loging in)....

    so... im happy with that.... But I noticed I still have older Programs.... such as the kde 3 version of k3b, digikam etc etc... so....

    I thought the next thing to do was filter the repo in yast... select the kde4 factory repo, and update packages unconditionally.... But I got a million dependancy errors....
    I'll post it some of it....( its way too long to post it in full)



    #### YaST2 conflicts list - generated 2009-08-16 11:18:23 ####

    kdebase3-3.5.10-17.4.i586 obsoletes kdialog provided by kdialog-4.3.0-105.1.i586

    [ ] do not install kdialog-4.3.0-105.1.i586

    [ ] do not install kdebase3-3.5.10-17.4.i586



    digikamimageplugins-0.9.4-51.18.i586 requires libdigikam.so.0, but this requirement cannot be provided

    [ ] do not install digikam-0.10.0-18.20.i586

    [ ] Following actions will be done:
    do not install digikamimageplugins-0.9.4-51.18.i586
    deinstallation of digikamimageplugins-0.9.4-51.18.i586
    [ ] Ignore some dependencies of digikamimageplugins



    pulseaudio-0.9.14-2.2.1.i586 obsoletes libpulsecore4 <= 0.9.12 provided by libpulsecore4-0.9.12-9.6.i586

    [ ] Following actions will be done:
    do not install pulseaudio-0.9.14-2.2.1.i586
    do not install pulseaudio-module-zeroconf-0.9.14-2.2.1.i586
    do not install pulseaudio-module-lirc-0.9.14-2.2.1.i586
    do not install pulseaudio-esound-compat-0.9.14-2.2.1.i586
    do not install pulseaudio-module-jack-0.9.14-2.2.1.i586
    do not install pulseaudio-module-x11-0.9.14-2.2.1.i586
    do not install pulseaudio-module-bluetooth-0.9.14-2.2.1.i586
    [ ] do not install libpulsecore4-0.9.12-9.6.i586



    kdepim4-4.1.3-3.14.9.i586 requires libkabcommon.so.4, but this requirement cannot be provided
    uninstallable providers: kde4-kaddressbook-4.1.3-3.13.i586[openSUSE 11.1-0]
    kde4-kaddressbook-4.1.3-3.13.i586[repo-oss]
    kde4-kaddressbook-4.1.3-3.14.9.i586[repo-update]
    [ ] Following actions will be done:
    do not install kaddressbook-4.3.0-154.1.i586
    do not install ksudoku-4.3.0-76.7.i586
    do not install kopete-protocol-facebook-0.1.3-2.2.i586
    do not install krdc-4.3.0-98.1.i586
    do not install ktorrent-3.2.3-36.1.i586
    do not install konsole-4.3.0-105.1.i586
    do not install kmix-4.3.0-74.1.i586
    do not install konqueror-plugins-4.3.0-5.8.i586
    do not install kio_audiocd-4.3.0-74.1.i586
    do not install kpat-4.3.0-76.7.i586
    do not install kopete-4.3.0-98.1.i586
    do not install kreversi-4.3.0-76.7.i586
    do not install kmail-4.3.0-154.1.i586
    do not install kontact-4.3.0-154.1.i586
    do not install kio_kamera-4.3.0-114.7.i586
    do not install keditbookmarks-4.3.0-105.1.i586
    do not install kdnssd-4.3.0-98.1.i586
    do not install kmines-4.3.0-76.7.i586
    do not install kmahjongg-4.3.0-76.7.i586
    do not install kfind-4.3.0-105.1.i586
    do not install kgpg-4.3.0-84.6.i586
    do not install kget-4.3.0-98.1.i586
    do not install kerry-0.2.90.svn1005337-6.2.i586
    do not install kio_sysinfo-11.1.2-72.1.i586
    do not install kgamma-4.3.0-114.7.i586
    do not install kdenetwork4-filesharing-4.3.0-98.1.i586
    do not install kdeartwork4-screensaver-4.3.0-55.2.i586
    do not install kdemultimedia4-4.3.0-74.1.i586
    do not install kdepasswd-4.3.0-105.1.i586
    do not install kde4-webkitpart-4.3.0.svn1010659-37.1.i586
    do not install kdegames4-4.3.0-76.7.i586
    do not install kcolorchooser-4.3.0-114.7.i586
    do not install kcalc-4.3.0-84.6.i586
    do not install kaffeine-0.9+1.0pre2-3.1.i586
    do not install k3b-1.66.0.svn1009369-4.4.i586
    do not install ark-4.3.0-84.6.i586
    do not install akregator-4.3.0-154.1.i586
    do not install PolicyKit-kde-0.2-20.102.i586
    do not install gwenview-4.3.0-114.7.i586
    downgrade of gwenview-4.3.0-114.7.i586 to gwenview-1.4.2-116.49.i586
    downgrade of PolicyKit-kde-0.2-20.102.i586 to PolicyKit-kde-0.2-6.3.i586
    deinstallation of ark-4.3.0-84.6.i586
    deinstallation of kcalc-4.3.0-84.6.i586
    deinstallation of kcolorchooser-4.3.0-114.7.i586
    deinstallation of kdegames4-4.3.0-76.7.i586
    downgrade of kde4-webkitpart-4.3.0.svn1010659-37.1.i586 to kde4-webkitpart-4.1.1.svn856106-2.48.i586
    deinstallation of kdepasswd-4.3.0-105.1.i586
    downgrade of kdemultimedia4-4.3.0-74.1.i586 to kdemultimedia4-4.1.3-4.14.i586
    downgrade of kdeartwork4-screensaver-4.3.0-55.2.i586 to kdeartwork4-screensaver-4.1.3-1.26.i586
    downgrade of kdenetwork4-filesharing-4.3.0-98.1.i586 to kdenetwork4-filesharing-4.1.3-4.13.i586
    downgrade of kio_sysinfo-11.1.2-72.1.i586 to kio_sysinfo-11.1-65.3.i586
    downgrade of kerry-0.2.90.svn1005337-6.2.i586 to kerry-0.2.2-136.149.i586
    deinstallation of kget-4.3.0-98.1.i586
    deinstallation of kfind-4.3.0-105.1.i586
    deinstallation of kmahjongg-4.3.0-76.7.i586
    deinstallation of kmines-4.3.0-76.7.i586
    deinstallation of kdnssd-4.3.0-98.1.i586
    deinstallation of keditbookmarks-4.3.0-105.1.i586
    deinstallation of kio_kamera-4.3.0-114.7.i586
    deinstallation of kontact-4.3.0-154.1.i586
    deinstallation of kmail-4.3.0-154.1.i586
    deinstallation of kreversi-4.3.0-76.7.i586
    deinstallation of kopete-4.3.0-98.1.i586
    deinstallation of kpat-4.3.0-76.7.i586
    deinstallation of kio_audiocd-4.3.0-74.1.i586
    do not install konqueror-plugins-lang-4.3.0-5.8.i586
    deinstallation of konqueror-plugins-4.3.0-5.8.i586
    deinstallation of kmix-4.3.0-74.1.i586
    deinstallation of konsole-4.3.0-105.1.i586
    do not install ktorrent-lang-3.2.3-36.1.i586
    downgrade of ktorrent-3.2.3-36.1.i586 to ktorrent-3.1.5-1.19.i586
    deinstallation of krdc-4.3.0-98.1.i586
    deinstallation of kopete-protocol-facebook-0.1.3-2.2.i586
    deinstallation of ksudoku-4.3.0-76.7.i586
    deinstallation of kaddressbook-4.3.0-154.1.i586
    deinstallation of konqueror-plugins-lang-4.3.0-5.8.i586
    downgrade of ktorrent-lang-3.2.3-36.1.i586 to ktorrent-lang-3.1.5-1.19.i586
    do not install konversation-1.2alpha6-6.4.i586
    [ ] do not install kdepim4-4.1.3-3.14.9.i586

    [ ] Ignore some dependencies of kdepim4



    skanlite-0.3.kde4.3.0-21.11.i586 requires libqt4 >= 4.5.2, but this requirement cannot be provided

    [ ] Following actions will be done:
    do not install skanlite-0.3.kde4.3.0-21.11.i586
    do not install ksudoku-4.3.0-76.7.i586
    do not install kopete-protocol-facebook-0.1.3-2.2.i586
    do not install krdc-4.3.0-98.1.i586
    do not install ktorrent-3.2.3-36.1.i586
    do not install konsole-4.3.0-105.1.i586
    do not install kmix-4.3.0-74.1.i586
    do not install konqueror-plugins-4.3.0-5.8.i586
    do not install kio_audiocd-4.3.0-74.1.i586
    do not install kpat-4.3.0-76.7.i586
    do not install kopete-4.3.0-98.1.i586
    do not install kreversi-4.3.0-76.7.i586
    do not install kmail-4.3.0-154.1.i586
    do not install kontact-4.3.0-154.1.i586
    do not install kio_kamera-4.3.0-114.7.i586
    do not install keditbookmarks-4.3.0-105.1.i586
    do not install kdnssd-4.3.0-98.1.i586
    do not install kmines-4.3.0-76.7.i586
    do not install kmahjongg-4.3.0-76.7.i586
    do not install kfind-4.3.0-105.1.i586
    do not install kgpg-4.3.0-84.6.i586
    do not install kget-4.3.0-98.1.i586
    do not install kerry-0.2.90.svn1005337-6.2.i586


    Thats only about a tenth of it!
    So my question is.... How do I complete the upgrade??? Its so much easier in debian based distro's, but i want to know how to do it in suse.... Where am I going wrong? is this normal? how do I fix it?


    thanx in advance.....
    kaddy

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,738
    Blog Entries
    20

    Default Re: Upgrading from Kde 4.1 to Kde 4.3... a little help pls

    Post the terminal output of

    Code:
    zypper lr -d
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Upgrading from Kde 4.1 to Kde 4.3... a little help pls

    kaddy@linux-u35y:~> zypper lr -d
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    --+--------------------------+---------------------------------------+---------+---------+----------+--------+--------------------------------------------------------------------------------------+--------
    1 | KDE:KDE4:Factoryesktop | KDE:KDE4:Factoryesktop | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.1 |
    2 | devel:tools:building | devel:tools:building | Yes | Yes | 99 | rpm-md | Index of /repositories/devel:/tools:/building/openSUSE_11.1 |
    3 | openSUSE 11.1-0 | openSUSE 11.1-0 | Yes | No | 99 | yast2 | cd:///?devices=/dev/sr0 |
    4 | repo | openSUSE BuildService - KDE:Community | Yes | Yes | 99 | rpm-md | Index of /repositories/KDE:/Community/openSUSE_11.1 |
    5 | repo-debug | openSUSE-11.1-Debug | No | Yes | 100 | NONE | Index of /debug/distribution/11.1/repo/oss |
    6 | repo-non-oss | openSUSE-11.1-Non-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.1/repo/non-oss |
    7 | repo-oss | openSUSE-11.1-Oss | Yes | Yes | 100 | yast2 | Index of /distribution/11.1/repo/oss |
    8 | repo-source | openSUSE-11.1-Source | No | Yes | 100 | NONE | Index of /source/distribution/11.1/repo/oss |
    9 | repo-update | openSUSE-11.1-Update | Yes | Yes | 20 | rpm-md | Index of /update/11.1 |
    kaddy@linux-u35y:~>


    The only repo I have enabled since my fresh install is kde community... I tried upgrading packages before I added kde community aswell and got the same errors....

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,738
    Blog Entries
    20

    Default Re: Upgrading from Kde 4.1 to Kde 4.3... a little help pls

    Change the priority of update repo to 99
    KDE4.3.* Upgrade - HowTo - openSUSE Forums
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Upgrading from Kde 4.1 to Kde 4.3... a little help pls

    ok...
    did you mean set the priority of the repo "kde 4 factory" or just the plain old update repo?

    cheers for your help by the way.....

    edit:
    ahh, factory is already 99 so I assume you meant the update repo.
    Done..... now what? try updating packages unconditionally again?

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,738
    Blog Entries
    20

    Default Re: Upgrading from Kde 4.1 to Kde 4.3... a little help pls

    Yes Update repo!!
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: Upgrading from Kde 4.1 to Kde 4.3... a little help pls

    ok.... I set the priority
    tried updating unconditionally after filtering to the factory repo... and i get same dependancy errors.......???

  8. #8
    Join Date
    Jun 2008
    Location
    near SUSE Headquarter
    Posts
    237

    Default Re: Upgrading from Kde 4.1 to Kde 4.3... a little help pls

    Quote Originally Posted by kaddy View Post
    kdebase3-3.5.10-17.4.i586 obsoletes kdialog provided by kdialog-4.3.0-105.1.i586
    Start with registering the KDE:KDE3 repository as told on KDE/Upgrade - openSUSE

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,738
    Blog Entries
    20

    Default Re: Upgrading from Kde 4.1 to Kde 4.3... a little help pls

    Select this from one of the error sections you posted and click try again and see if it clear it up a bit

    [ ] do not install kdepim4-4.1.3-3.14.9.i586

    You can see you wouldn't want that, it's 4.1.3
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10

    Default Re: Upgrading from Kde 4.1 to Kde 4.3... a little help pls

    oki....
    I've updated packages unconditionally again....
    I chose to not install kde 3.5 base or something..... plus there was a few other things that I don't think I needed... and it is now upgrading with no problems so far.... But its got 2 gigs of updates to do.... so it will be a while. lol.

    let ya know how I go

    cheers for your help so far guys

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •