Results 1 to 2 of 2

Thread: Screen(s) found but none have a usable configuration

  1. #1
    matandrory NNTP User

    Default Screen(s) found but none have a usable configuration

    Hello
    i have the sony Vaio vgn-fw465j

    i installed opensuse 11.1
    after installing i downloaded the latest ati driver a built it to the kernel by the instructions in the ATI guide in this site ("The hard mode")

    when im trying to operate the sax2 line i get a few flashes and the screen stays blank
    i checked the errors in /var/log/SaX.log
    i get this error
    Code:
    (EE) fglrx(0): Output LCD enabled but has no modes
    (EE) fglrx(0): Display Infrastructure Failed
    (EE) fglrx(0): PreInit failed
    (EE) fglrx(0): PPLIB is not initialized
    (EE) Screen(s) found, but none have a usable configuration
    
    fattel server error:
    no screens found
    i checked my xorg.conf file and the driver is stated as fglrx and i my screen data and modes appear to be allright (even thu he has preffered mode 800x600)

    has any one bumped this issue?

  2. #2
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: Screen(s) found but none have a usable configuration

    matandrory adjusted his/her AFDB on Saturday 15 Aug 2009 01:46 to write:

    >
    > Hello
    > i have the sony Vaio vgn-fw465j
    >
    > i installed opensuse 11.1
    > after installing i downloaded the latest ati driver a built it to the
    > kernel by the instructions in the ATI guide in this site ("The hard
    > mode")



    Where you went wrong is using sax2 to configure the drivers.

    Propriety ATI and Nvidia drivers do not use the xorg.conf as much and have
    their own config file, they use xorg.conf as a base.

    If you look at the instructions/release notes it does state not to use sax2
    to configure.

    You need to drop to a root console in runlevel 3 and create a new xorg.conf
    and then run the aticonfig script again.

    Easy peasy, here are the commands with comments in {}

    First reboot* and at the grub boot screen just type the number 3 you should
    see it echoed on the kernel parameter line, this will boot you to a terminal
    login with no Xserver running.

    Login as root and enter root password then:

    sax2 -r -m 0=vesa
    {this will recreate a default xorg.conf with the vesa driver, follow the
    setup but do not change anything, save and let it test then save}

    aticonfig --initial
    { this will adapt the xorg.config for the fglrx driver }

    init 5
    {go to runlevel 5 with KDE/Gnome login}

    While in GUI open console and run:

    amdcccle


    This will give you the Catalyst GUI configuration window to set individual
    preferences.

    If you find you cannot enable effects or they are slow and hogging your CPU
    then you need to add:

    Section "Extensions"
    Option "Composite" "on"
    EndSection


    At the bottom of your xorg.conf to enable the hardware accel for the
    effects.

    That should be it, looks a lot but is only 4 commands :-)


    *Note it is not exactly required to reboot, all this can be done from a
    running linux with no reboot as long as you can get to a terminal screen and
    drop to runlevel 3 with init 3 and you do not need to reboot once the
    drivers are installed.

    The only problem with the hard way is that you have to do this if you change
    kernel or there is a kernel patch from the SuSE updates, all that is needed
    is to run the install again:

    sh ./<version-of-the-driver>.sh or .bin

    again, no need for the aticonfig --initial or anything else just the one
    command in runlevel 3 then go back to runlevel 5.

    HTH
    --
    Mark
    Caveat emptor
    Nullus in verba
    Nil illegitimi carborundum

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •