I'm having a problem that Yast hangs when trying to install an rpm (I'm trying to install 'meld').

It sits there and does nothing after download (I've tried leaving it for a couple of hours). Checking ps -x gives me a 'D' in the stat column for the rpm -i command of the package yast is trying to install.

I end up having to kill -9 the pid and then aborting within yast (I can't just abort in yast because I'm unable to click any of the buttons while it's waiting)

I've tried rpm -qa which does provide a list of my installed packages and I've also tried rm -f /var/lib/rpm/__* ; rpm -vv --rebuilddb which does successfully rebuild my db.

However, after these, I do run into the same problems.

I've also tried db_verify Packages which doesn't give any errors.

I know my first port of call should possibly have been to restart my computer, but I can't do that until later on this evening because I've had it doing things. I just wanted to see if anyone had any other thoughts?

I'll restart when my computer is free from what it's doing and if that resolves I'll close this



(btw, I'm running 11.1 in KDE)