Results 1 to 9 of 9

Thread: heyy..

  1. #1

    Default heyy..

    I got just one question... ive been looking around to enabling POSIX shared memory on the opensuse 11.1 64 bit. ive read ATIs release notes and because i am new i dont have the foggiest.

    could someone tell me a simpler way of doing this
    "The display driver requires POSIX Shared Memory to be enabled on the system in order to run these applications correctly. This feature should be enabled by default on most current Linux distributions, but may be disabled intentionally by some system administrators or not included in older distributions.

    To enable POSIX Shared Memory on your system, perform the following as root:

    1. Add the following line to /etc/fstab (if it isn't there already): tmpfs /dev/shm tmpfs defaults 0 0
    2. Mount shared memory as follows: mount /dev/shm
    3. Issue the following command to check that it mounted properly: mount | grep "shm"

    If the mount was successful, then the following output (or similar) should appear:
    tmpfs on /dev/shm type tmpfs (rw)

    At this point, POSIX Shared Memory is enabled. Your 3D applications should run properly and the error message above should no longer occur.

    If the output from this command is blank, then the mount failed. "

    if someone could answer asap really this would be really helpful!

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,743
    Blog Entries
    20

    Default Re: heyy..

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: heyy..

    heh thanks!!!

    ive been searching for hours lol

    =]

  4. #4
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: heyy..

    Parka2k adjusted his/her AFDB on Friday 14 Aug 2009 19:56 to write:

    >
    > I got just one question... ive been looking around to enabling POSIX
    > shared memory on the opensuse 11.1 64 bit. ive read ATIs release notes
    > and because i am new i dont have the foggiest.
    >



    You should not have to do this it is enabled by default and has been for
    years on SuSE.

    You appear to be taking the documents a bit too literally ( which is a
    pleasant change ) but can lead to more problems than it fixes.

    HTH

    --
    Mark
    Caveat emptor
    Nullus in verba
    Nil illegitimi carborundum

  5. #5

    Default Re: heyy..

    hmm.. but like when i typed in the command to check if it was enabled... nothing was there and the notes said that its not be enabled :S ..

    lol i always read the instructions first! =] shame im no good with linux hah

  6. #6
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: heyy..

    Parka2k adjusted his/her AFDB on Saturday 15 Aug 2009 12:26 to write:

    >
    > hmm.. but like when i typed in the command to check if it was enabled...
    > nothing was there and the notes said that its not be enabled :S ..
    >
    > lol i always read the instructions first! =] shame im no good with
    > linux hah
    >
    >



    If you type in at a console the command mount

    you should see an entry like this somewhere:

    tmpfs on /dev/shm type tmpfs (rw)

    and if you do this:

    cat /etc/fstab

    you should see:

    tmpfs /dev/shm tmpfs defaults 0 0

    somewhere, probably the last or near the last entry.

    HTH

    --
    Mark
    Caveat emptor
    Nullus in verba
    Nil illegitimi carborundum

  7. #7

    Default Re: heyy..

    /dev/sda6 on / type ext3 (rw,acl,user_xattr)
    /proc on /proc type proc (rw)
    sysfs on /sys type sysfs (rw)
    debugfs on /sys/kernel/debug type debugfs (rw)
    udev on /dev type tmpfs (rw)
    devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
    /dev/sda1 on /windows/C type fuseblk (rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096)
    /dev/sda3 on /windows/D type fuseblk (rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096)
    none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)

    this is all i see when i type mount


    also, i have done aticonfig --initial -f and its wiped away the section where it had radeonhd.
    but i am still getting judderyness lol.

    i cant edit xconf because when i type it in the console it says it cannot connect to the x server
    Last edited by Parka2k; 15-Aug-2009 at 07:29. Reason: forgot something

  8. #8
    Join Date
    Nov 2008
    Location
    N. Wales
    Posts
    1,028

    Default Re: heyy..

    Parka2k adjusted his/her AFDB on Saturday 15 Aug 2009 15:36 to write:

    > i cant edit xconf because when i type it in the console it says it
    > cannot connect to the x server
    >
    >


    just bear with me here to see if I have got this right.

    When editing the fstab you are doing it as root in a console like this:

    from the Desktop open a terminal/console in KDE press Alt+F2 a little box
    will pop up and in there type konsole

    You will then get a console/commandline interface pop up, in that type:

    su

    Then enter your root password.

    Next type:

    edit /etc/fstab

    If you get any errors about a swp then ignore them and continue to edit and
    add the:

    tmpfs /dev/shm tmpfs defaults 0 0

    At the bottom, do not forget to add at least one blank line under it ( just
    press enter/return twice )

    Then save your new fstab

    Now do the mount

    mount /dev/shm
    mount | grep "shm"


    And you will see:

    tmpfs on /dev/shm type tmpfs (rw)

    That works for me.

    Now lets see if it works for you.

    Post back your results please.



    --
    Mark
    Caveat emptor
    Nullus in verba
    Nil illegitimi carborundum

  9. #9

    Default Re: heyy..

    - Solved Thanks for everyone that helped!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •