Results 1 to 3 of 3

Thread: Disable device-mapper

  1. #1
    Ausweider NNTP User

    Default Disable device-mapper

    Right then.

    First Linux I installed was 6.2

    For the last 5 hours I'm trying to install 11.1 and I just can't hack it. I am an IT pro working in the field for more than 10 years now, installed 100 of Linux's but this is just taking the wee mick.

    How can I disabled device-mapper?
    How can I stop it proposing rather stupid partions, that when I don't want them, delete them, and then when the installer comes to delete them, says, they aint there?

    rant
    What's with this "user friendly" stuff here?
    /rant

    Anybody able to point me in the right direction?

  2. #2
    goldie NNTP User

    Default Re: Disable device-mapper

    > Anybody able to point me in the right direction?

    well...you have more experience than i do, and that might be working
    against you now....(imo "user friendly" mostly means "friendly to
    Redmond users")

    first: lets make sure it is openSUSE 11.1 and not SUSE Linux
    Enterprise Desktop or Server v 11

    second: i don't know anything about disabling "device-mapper" but i DO
    know if you are installing from a DVD (if you are installing from a
    CD, i recommend you cease that) purchased from or downloaded from
    opensuse.org and you are using the GUI installer, then your install
    should go kinda like these pretty, user friendly :-) pictures:
    http://en.opensuse.org/INSTALL_Local

    and, when you get down to
    http://en.opensuse.org/INSTALL_Local...ktop_selection if you
    are installing a server without the need for X you need to choose the
    last on that page, "Minimal Server Selection"

    and then, on the next page
    http://en.opensuse.org/INSTALL_Local...g_up_your_disk
    let the install script ("device-mapper") do its magic and then just
    ignore it and click "Edit Partition Setup" and have it your way..

    now (listen) when you are "editing the partitions" in that step
    nothing is really happening YET...that is i'm looking at your line
    "How can I stop it proposing rather stupid partions, that when I don't
    want them, delete them, and then when the installer comes to delete
    them, says, they aint there?" so, you are not actually deleting a
    partition, you are simply CHANGING the plan to your liking....so, the
    script can't be saying it won't delete something that is not there
    (because it ain't)...

    on the other hand, once you have set the partitioning plan the way you
    want it, then the next page (scroll your browser) you create a user,
    then pick the software mix you want, then when you finally get to the
    "Install" button, it WILL adjust all your partitions in accordance
    with YOUR wishes..

    even though this partitioning guide is written for new folks, it
    _might_ be helpful to others not used to such "user friendly" helps as
    'automatic' partitioning schemes:

    http://forums.opensuse.org/how-faq-r...all-guide.html

    welcome to the sometimes over friendly world of openSUSE..

    when you get'er going, drop in and help out some fielding the more
    technical Qs....we need your kind of experience often..

    --
    goldie
    Note: Accuracy, completeness, legality, or usefulness of this posting
    may be illusive.

  3. #3

    Default Re: Disable device-mapper

    Just had the same problem and this was the first thread that came up, so...

    I found the solution here: Disable Raid During Installation? - openSUSE Forums

    To sum it up: either through the installation DVD's Rescue System, either through whatever live or boot CD/flash, remove any fakeraid metadata from the disks:
    Code:
    dmraid -rE
    That's all.

    How can I stop it proposing rather stupid partions [...]?
    Create Partition Setup -> Custom Partitioning (for experts)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •