Results 1 to 3 of 3

Thread: Amarok 2- continuous play on random?

  1. #1

    Default Amarok 2- continuous play on random?

    Running Amarok 2.1.1 from the KDE 4.2 repository for OpenSUSE 11.1

    I'm having problems getting it to play continuously, especially for the case where I load a a bunch of tracks from the collection into the playlist, turn on random (by track) play mode and set it playing. Basically, it plays one track, picks the next- but then doesn't play it, going into paused/stopped mode instead. It'll start the next track if I manually switch to the Amarok window and hit the "play" button, or via global shortcuts, but obviously I'd rather just leave it and let it play. Does anyone know how to switch it to play through the playlist continuously rather than manually? :S It's probably a simple case of me having misunderstood the "flow" of Amarok 2 compared to iTunes, Winamp or Foobar which are the players I'm more used to, but I can't find any options to do with this.

    It works fine in the case of playing through a whole album in the right order.
    EDIT: Scrub that, now it seems not to want to do that either, same problem of switching to next track OK but also stopping rather than keeping in play mode. But it was working, so maybe I changed some option without realising. I'll look into it, but if anyone knows what might affect this it'd be very welcome.

    Thanks

  2. #2

    Default Re: Amarok 2- continuous play on random?

    OK... I checked for all updates, and amarok was among those updated. It seems to play sequentially as desired when loading an album with "replace playlist", but the same issue as before stands for the random play, and maybe in some other cases too (?)

    This is baffling

  3. #3

    Default Re: Amarok 2- continuous play on random?

    Did some more searching and found this: https://bugs.launchpad.net/ubuntu/+s...ok/+bug/359542

    The thread includes a solution, which, in case anyone else has this problem involves going to the amarok configuration, Playback>Configure>Backend, changing the backend to GStreamer (from xine), then quitting and restarting amarok. For whatever reason, it reverts to xine, and the playback seems to work properly :S

    So this is resolved, I hope, or rather, there is a working work-around for it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •