Results 1 to 10 of 10

Thread: I Broke the Software Installer.

  1. #1
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,474

    Default I Broke the Software Installer.

    trying to get the Software Updater Applet to work right on a new install I managed to break the software installer in Yast2 here are two screen caps of the error message. one of the packages I package I updated was yast2-qt-pkg. I hope this can be fixed without a reinstall.




  2. #2

    Question Re: I Broke the Software Installer.

    Did you checked the log files for further information?
    /var/log/YaST2/y2log
    /var/log/YaST2/y2start.log

    and maybe also:
    /var/log/messages

  3. #3
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,474

    Default Re: I Broke the Software Installer.

    Since this is a new install would it be wise to just reinstall it? (for the fourth time First time today though it's just about 1AM)

  4. #4

    Default Re: I Broke the Software Installer.

    Maybe you just have to reinstall the package yast2-qt-pkg
    or try to downgrade it, if a reinstall doesn't work.

  5. #5
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,474

    Default DVD is handy

    DVD is handy. I think I'll just reinstall and try and get the software updater applet to work right, messing up QT in KDE is a bad move massing it up in Yast2 is really bad.

  6. #6
    goldie NNTP User

    Default Re: I Broke the Software Installer.

    > DVD is handy.

    what version of openSUSE are you installing?
    did it come from http://software.opensuse.org/ or some other source?

    are you certain the DVD is perfect? did you media check it prior to
    THIS install?

    the point being that you might reinstall from a bad DVD until the cows
    come home--and never get sweet milk..

    --
    goldie

  7. #7
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,474

    Default Re: I Broke the Software Installer.

    Running openSUSE 11.1 and KDE 3.5

    I checked Media and checked memory after the second install and replaced the install media. I had some hardware issues on my first two installs. This last install seems to have done the trick. This machine is memory poor and I will fix that next month. It seems to be playing OK now and it's going through all the software updates slowly.

  8. #8
    goldie NNTP User

    Default Re: I Broke the Software Installer.

    > It seems to be playing OK
    > now and it's going through all the software updates slowly.


    updating slowly is a VERY good idea!!

    --
    goldie

  9. #9
    Join Date
    Jan 2009
    Location
    Taft, Republic of California. UTC -8
    Posts
    1,474

    Default Re: I Broke the Software Installer.

    LOL I went to Repositories, OpenSUSE-11.1-Update, and did an update unconditionally. Just over a gigs worth of updates.
    System is back up. .mozilla, .thunderbird and doccuments folder transfered over from previous install.

  10. #10
    Join Date
    Jun 2008
    Location
    Charleston, SC, USA
    Posts
    192

    Default Re: I Broke the Software Installer.

    Just as a point of reference, I've seen those errors before and were the result of corrupt qt packages from a borked update.

    If you need to get in to Yast, you can use the command line version. Just open a terminal, log in as root, and type "yast2". This will open up a menu-driven interface that should be close to the same as the GUI version of YaST.

    Anyways, glad you got it working.
    My personal philosophy:
    The only way you won't find something is if you stop looking.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •