Results 1 to 7 of 7

Thread: PHP 5.3 for OpenSUSE 11.1

  1. #1
    docx NNTP User

    Arrow PHP 5.3 for OpenSUSE 11.1

    Hi,

    knows anybody if somewhere is packages/repository with php 5.3 for OpenSUSE 11.1? I couldn't found anythink on google nor this forum
    Or some regular "simple" way to compile it?

    Thank you very much.

  2. #2
    docx NNTP User

    Default Re: PHP 5.3 for OpenSUSE 11.1

    So, I tried build php 5.3 from source, but I'm partialy useful. CLI php work fine, I built even apache module, but when I try start apache with it, show this error:


    Code:
    httpd2-prefork: Syntax error on line 116 of /etc/apache2/httpd.conf: Syntax error on line 31 of /etc/apache2/sysconfig.d/loadmodule.conf: Cannot load /usr/lib/apache2-prefork/libphp5.so into server: /usr/lib/apache2-prefork/libphp5.so: undefined symbol: zend_parse_parameters

    Can anybody help me? Please

  3. #3
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,611

    Default Re: PHP 5.3 for OpenSUSE 11.1

    There are PHP 5.3 packages in Software.openSUSE.org

  4. #4
    docx NNTP User

    Default Re: PHP 5.3 for OpenSUSE 11.1

    Quote Originally Posted by john_hudson View Post
    There are PHP 5.3 packages in Software.openSUSE.org
    Oh, it looks like I am stupid I searched there yesterday, but didn't find them (imho I'm missing some "advanced search" option there)
    But thank you very much.

    And for others who are lost as I, try to search "apache2-mod_php5" or direct use Index of /repositories/server:/php/server_apache_openSUSE_11.1

  5. #5

    Default Re: PHP 5.3 for OpenSUSE 11.1

    Today, I've updated from this repo but now I can't access my local php pages like phpMyAdmin and MythWeb.
    Nothing happend in the browser, it only says finished and I got a complete white and empty page.
    When I access phpMyAdmin or MythWeb this message apears in /var/log/apache2/error.log:

    /usr/sbin/httpd2-prefork: symbol lookup error: /usr/lib64/php5/extensions/mysqli.so: undefined symbol: _mysqlnd_palloc_rinit

    It repeats every time when I reload the page.

    I hope you can help to solve this problem.

    Thanks.

  6. #6
    Join Date
    Feb 2009
    Location
    Hamburg, Germany
    Posts
    17

    Default Re: PHP 5.3 for OpenSUSE 11.1

    Same problem here since upgrading yesterday.
    Actually when starting the server I get a warning in the apache error log which claims that the mysql module cannot be loaded due to the absence of the new mysqlnd driver.
    I'd say those packages are broken, they rely on the new native driver but don't provide it ! Great !

  7. #7
    cataztrophe NNTP User

    Default Re: PHP 5.3 for OpenSUSE 11.1

    hmmm..nice info, gotta try asap then!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •