Trying to configure apache on my opensuse11 box here and have run into some issues.

I previously tried installing apache2/php/mysql from source and had some issues getting getting php to compile correclty with all the options I wanted. So, I deleted my installs of apache php mysql and went back and did a fresh install with yast to see how well that would work.

The install goes ok but when trying to save a config in yast-http I get a 'cannot adjust apache2 service' error. Trying from the console I get:

apache2ctl start
Syntax error on line 11 of /etc/apache2/mod_log_config.conf:
Invalid command 'LogFormat', perhaps misspelled or defined by a module not included in the #server configuration
Reading through posts here I have gone through my /etc/sysconfig/apache2 to track down errors in the APACHE_MODULES value and subsequently /etc/apache2/sysconfig.d/loadmodule.conf and /etc/apache2/mod/mod_log_format.conf

Everything 'looks fine' to me and I have tried a few methods of reinstalling apache itself. Via yast, via zyyper as well as manually removing anything left behind by those methods.

Any ideas on this?