Results 1 to 5 of 5

Thread: Black Screen When X starts!SaX2 Doesn't Help!

  1. #1
    vgerov93 NNTP User

    Exclamation Black Screen When X starts!SaX2 Doesn't Help!

    Hey, guys!Little Help Here?
    Before a few days i tried to install OpenSuSE 11.1 via GNOME Live CD.So when live CD tried to run X my monitor turned off.I entered text mode and used "SaX2 -r".It worked!I installed OpenSuSE and after restart same thing happened!Now SaX2 doesn't help.This is how my xorg.conf looks like now:
    # /.../
    # SaX generated X11 config file
    # Created on: 2009-08-12T21:11:39+0300.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #
    Section "Files"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    EndSection

    Section "ServerFlags"
    Option "AllowMouseOpenFail" "on"
    Option "ZapWarning" "on"
    EndSection

    Section "Module"
    Load "glx"
    Load "dbe"
    Load "extmod"
    Load "freetype"
    Load "dri"
    EndSection

    Section "InputDevice"
    Driver "kbd"
    Identifier "Keyboard[0]"
    Option "Protocol" "Standard"
    Option "XkbLayout" "us,bg"
    Option "XkbModel" "microsoftpro"
    Option "XkbOptions" "grp:alt_shift_toggle"
    Option "XkbRules" "xfree86"
    Option "XkbVariant" "basic,basic"
    EndSection

    Section "InputDevice"
    Driver "mouse"
    Identifier "Mouse[1]"
    Option "Buttons" "9"
    Option "Device" "/dev/input/mice"
    Option "Name" "ImExPS/2 Generic Explorer Mouse"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "Monitor"
    DisplaySize 340 270
    HorizSync 30-83
    Identifier "Monitor[0]"
    ModelName "B17-2"
    Option "DPMS"
    Option "PreferredMode" "1280x1024"
    VendorName "FUS"
    VertRefresh 43-76
    UseModes "Modes[0]"
    EndSection

    Section "Modes"
    Identifier "Modes[0]"
    Modeline "1280x1024" 108.00 1280 1328 1440 1688 1024 1025 1028 1066
    EndSection

    Section "Screen"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    Virtual 3840 1200
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    Virtual 3840 1200
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    Virtual 3840 1200
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    Virtual 3840 1200
    EndSubSection
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"
    EndSection

    Section "Device"
    BoardName "RV350 AS"
    Driver "radeon"
    Identifier "Device[0]"
    Option "AGPFastWrite" "true"
    Option "AGPMode" "4"
    Screen 0
    VendorName "ATI"
    EndSection

    Section "ServerLayout"
    Identifier "Layout[all]"
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    Option "Clone" "off"
    Option "Xinerama" "off"
    Screen "Screen[0]"
    EndSection

    Section "DRI"
    Group "video"
    Mode 0660
    EndSection

    Section "Extensions"
    EndSection
    In Section "Device" Option looked different before, i edit it and now when X starts my PC restarts
    btw I'm with ATI RADEON 9550 256mb VRAM
    Please, tell me how to edin xorg.conf!

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Black Screen When X starts!SaX2 Doesn't Help!

    Follow this:

    Pause the boot by moving the down arrow, then back up to the default boot. But now press backspace, it should delete any text where you can see VGA=...etc


    Remove all text and now type just the number:
    3
    and hit enter




    at the login type your user name and then password
    now type:
    su
    then the root password




    now type this:
    sax2 -r -m 0=vesa
    (N.B. the 0 is a zero not a letter)


    now reboot: type: reboot

    if you don't get a gui login
    login as user at cli and try this at the cli
    startx
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    vgerov93 NNTP User

    Default Re: Black Screen When X starts!SaX2 Doesn't Help!

    awesome, dude!Thanks for the fast reply

  4. #4
    vgerov93 NNTP User

    Unhappy Re: Black Screen When X starts!SaX2 Doesn't Help!

    Ops another problem so far!
    I did what caf4926 said and started x with vesa.Than i tried to install ATI Radeon Driver (fglrx) and followed the instructions on the Suse web site. So i typed SaX2 -r -m 0=fglrx and than it shows me black screen but monitor still on...
    I tried to go back to vesa (SaX2 -r -m 0=vesa) but nothing happens :S Can anyone please help me?How to make fglrx driver or go back to vesa?

  5. #5

    Default Re: Black Screen When X starts!SaX2 Doesn't Help!

    Couple of comments:
    ATI's fglrx setup docs suggest not running sax2, just aticonfig or amdcccle

    The use of xorg.conf is diminishing these days. ATI in particular is relying more on /etc/ati/amdpcsdb. And sax2 adds a lot of extraneous entries, things like module names, font paths and mode lines, that are generated automatically anyway. Check out /var/log/Xorg.0.log for details.

    There is a longrunning discussion of xorg.conf settings on the compiz forums; it is worth a look: Setup an ATI card with the new FGLRX drivers for Compiz-Fusion - Compiz Community Forums

    Try reloading ATI's fglrx driver. Just download the blahblah.run file, make it executable. Stop X, run the .run file, accepting all defaults. The do
    Code:
    aticonfig --initial
    , and reboot. No sax2. Take a look at /usr/share/ati/fglrx-install.log, see if any problems.

    HTH

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •