Results 1 to 2 of 2

Thread: Xen - Login to GNOME freezes in Dom0

  1. #1
    erik_fuller NNTP User

    Question Xen - Login to GNOME freezes in Dom0

    Hi.

    I'm running openSUSE 11.1 with a number of updates from the openSUSE-11.1-Update packages. I ran the Xen install through the "Install Hypervisor and Tools" option, and everything's working on Xen boot up until I log into GNOME. It works for a second then freezes everything (including the mouse animation) and I can only power off the machine. The desktop does not load (i.e. no taskbar or desktop icons). On a side note I can log into IceWM just fine.

    Looking at the messages log file, I found some discrepancies between my normal boot and my Xen boot.

    Normal boot:
    Aug 13 11:22:35 tartarus kernel: [drm:i915_getparam] *ERROR* Unknown parameter 5
    Aug 13 11:22:43 tartarus gnome-session[5132]: WARNING: Application 'gnome-wm.desktop' failed to register before timeout
    Aug 13 11:22:45 tartarus pulseaudio[5415]: pid.c: Stale PID file, overwriting.
    Aug 13 11:22:46 tartarus nm-system-settings: Loaded plugin ifcfg-suse: (C) 2008 Novell, Inc. To report bugs please use the NetworkManager mailing list.
    Aug 13 11:22:46 tartarus nm-system-settings: Loaded plugin keyfile: (c) 2007 - 2008 Red Hat, Inc. To report bugs please use the NetworkManager mailing list.
    Aug 13 11:22:48 tartarus kernel: CPU0 attaching NULL sched-domain.
    Aug 13 11:22:48 tartarus kernel: CPU1 attaching NULL sched-domain.
    Aug 13 11:22:48 tartarus kernel: CPU0 attaching sched-domain:
    Aug 13 11:22:48 tartarus kernel: domain 0: span 0-1 level MC
    Aug 13 11:22:48 tartarus kernel: groups: 0 1
    Aug 13 11:22:48 tartarus kernel: CPU1 attaching sched-domain:
    Aug 13 11:22:48 tartarus kernel: domain 0: span 0-1 level MC
    Aug 13 11:22:48 tartarus kernel: groups: 1 0

    Xen boot:
    Aug 13 11:06:58 tartarus kernel: [drm:i915_getparam] *ERROR* Unknown parameter 5
    Aug 13 11:07:04 tartarus gnome-session[4468]: WARNING: Application 'gnome-wm.desktop' failed to register before timeout
    Aug 13 11:07:07 tartarus pulseaudio[4722]: pid.c: Stale PID file, overwriting.
    Aug 13 11:07:08 tartarus nm-system-settings: Loaded plugin ifcfg-suse: (C) 2008 Novell, Inc. To report bugs please use the NetworkManager mailing list.
    Aug 13 11:07:08 tartarus nm-system-settings: Loaded plugin keyfile: (c) 2007 - 2008 Red Hat, Inc. To report bugs please use the NetworkManager mailing list.
    Aug 13 11:07:08 tartarus pulseaudio[4722]: module-alsa-sink.c: Disabling timer-based scheduling because high-resolution timers are not available from the kernel.
    Aug 13 11:07:09 tartarus pulseaudio[4722]: module-alsa-source.c: Disabling timer-based scheduling because high-resolution timers are not available from the kernel.
    Aug 13 11:07:11 tartarus kernel: hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.

    Suggesting that maybe there's a problem with the sound hardware, but only when running under Xen? Or possibly it's on the following step where cpus get attached?

    I'm running
    • kernel 2.6.27.25-0.1.1 (i586)
    • xen 3.3.1_18546_16-0.1.1 (i586)
    • ALSA 1.0.20


    My machine is a HP 6703b laptop. Yes, I know Xen is more for servers, but I'd prefer to try it out locally before I put it on a server.

    On a side note, I'm fairly new to Linux, so don't be afraid to suggest something basic.

    Anyone have any suggestions? Is there a way to boot in a verbose logging mode so I can have a full record of what's happening? Any suggestions to Xen configuration to try and work around the potential hardware problem?

    Thanks.

  2. #2
    erik_fuller NNTP User

    Default Re: Xen - Login to GNOME freezes in Dom0

    Typo, that's a 6730b, if it makes a difference.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •