Results 1 to 7 of 7

Thread: SOLVED: Laptop sound is soft in openSUSE

  1. #1
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default SOLVED: Laptop sound is soft in openSUSE

    Hi my problem is that system sounds and multimedia playback sounds are quite soft from my laptop, even at max volume. The lappy has a multiboot to windows -- the sounds are normal there, quite loud if I turn them up.

    Current configuration data:

    I have an HP Probook 4710s laptop running openSUSE 11.1 Gnome. The software is fully updated via Yast Online Update and Yast's Software Management (Gnome version) --> Upgrade Existing Software

    Here are some diags I saw in another posting on a similar issue:
    john@linux-8065:~> rpm -qa | egrep "alsa|pulse" returns this
    Code:
    pulseaudio-module-lirc-0.9.14-2.2.1
    libpulse0-0.9.14-2.2.1
    alsa-1.0.18-8.9
    alsa-plugins-1.0.18-6.13
    pulseaudio-module-zeroconf-0.9.14-2.2.1
    pulseaudio-module-gconf-0.9.14-2.2.1
    libxine1-pulse-1.1.16.3-0.pm.3
    alsa-oss-32bit-1.0.17-1.37
    alsa-utils-1.0.18-6.4
    pulseaudio-utils-0.9.14-2.2.1
    pulseaudio-0.9.14-2.2.1
    pulseaudio-lang-0.9.14-2.2.1
    libpulse-mainloop-glib0-0.9.14-2.2.1
    libpulse-browse0-0.9.14-2.2.1
    pulseaudio-module-bluetooth-0.9.14-2.2.1
    alsa-plugins-pulse-1.0.18-6.13
    alsa-oss-1.0.17-1.43
    libpulse0-32bit-0.9.14-2.2.1
    pulseaudio-module-x11-0.9.14-2.2.1
    pulseaudio-esound-compat-0.9.14-2.2.1
    rpm -q libsound2 returns this: "package libsound2 is not installed"

    cat /etc/modprobe.d/sound returns this:
    Code:
    options snd slots=snd-hda-intel,snd-hda-intel
    # u1Nb.L1YU1sHH6F5:82801I (ICH9 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    # NXNs.pwzlOPh9eO9:RV730XT Audio device [Radeon HD 4670]
    alias snd-card-1 snd-hda-intel
    There's a Master Volume Control in my Gnome panel/systray -- it's 100% on the simple left-click access. If I right-click it I get the more complex "Pulse Audio Volume Control". The "Output Devices" volume controls (stereo) are both at 100%. The "Playback System Sounds" volume control (mono) is at 50%. I can adjust the slider to 100%, but when I close and reopen the GUI, it's back at 50%.

    If I look into Yast --> Hardware --> Sound I see two cards:
    828011 ICH9 Family HD Audio Controller
    and
    RV730XT Audio Device [Radeon HD 4670]

    Any advice?

    Thanks
    swerdna

    PS I don't know what a PCM is or how to adjust it
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default re: SOLVED: Laptop sound is soft in openSUSE

    One more useful piece of information, would be the output provided by running a diagnostic script for one's audio hardware/software.

    Put your settings in what you believe to be the optimal manner to get maximum audio.

    Then run the script twice with your Laptop PC connected to the internet. The first time with root permissions (in order for it to update itself). The second time run with regular user permissions. The script is:
    /usr/sbin/alsa-info.sh

    Select the "share option" the second time you run it. It will upload the diagnostic info to the alsa site and give you a URL. Please post the URL here.

  3. #3
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default re: SOLVED: Laptop sound is soft in openSUSE

    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default re: SOLVED: Laptop sound is soft in openSUSE

    Quote Originally Posted by swerdna View Post
    OK,I note an AD1984 hardware audio codec. Before we try anything else, its important you find all your mixer controls. As you "hinted" in a previous post, your PCM control is not setup right. I note this:

    !!Amixer output
    !!-------------
    !!-------Mixer controls for card 0 [Intel]
    Card hw:0 'Intel'/'HDA Intel at 0xd8500000 irq 17'
    Mixer name : 'Analog Devices AD1984A'
    Simple mixer control 'Master',0
    Front Left: Playback 31 [100%] [0.00dB] [on]
    Front Right: Playback 31 [100%] [0.00dB] [on]
    Simple mixer control 'PCM',0
    Front Left: Playback 9 [39%] [-21.00dB] [on]
    Front Right: Playback 9 [39%] [-21.00dB] [on]
    PCM is at 39% playback. Thats way too low. Try moving that up to a higher value with your desktop's mixer.

    In gnome, the mixer is called : alsamixer

    Run alsamixer to adjust the value. I can't help with alsamixer control keys, but you can do a web search on it to learn.

    One can also use amixer, although the syntax is maddening with amixer. One can learn more about amixer by typing "man amixer". One can get an ascii list of mixer settings in amixer by typing:
    amixer > amixer.txt
    and open amixer.txt in a text editor. Note the diagnostic script already gave us the same amixer listing.

  5. #5
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default re: SOLVED: Laptop sound is soft in openSUSE

    That created progress. I ran this:
    Code:
    alsamixer -c 0 -V playback
    to look at the playback of the default card and found:
    Card: HDA Intel
    Chip: Analog Devices AD1984A
    Master = 100
    PCM = 39
    Beep = 0

    So I adjusted PCM to 100 and Beep to 57

    Now files play back through the in-built speakers in similar volumes to what I get in windows. So I'm very happy with that. And I noted a bunch of other controls in there related to Mic, Capture and Internal. I can play with those later (now that I know they exist).

    So thankyou for that. But can you now comment on what I might do to lift the volume of "system sounds", you might recall I said this in my first post:
    If I right-click it I get the more complex "Pulse Audio Volume Control". The "Output Devices" volume controls (stereo) are both at 100%. The "Playback System Sounds" volume control (mono) is at 50%. I can adjust the slider to 100%, but when I close and reopen the GUI, it's back at 50%.
    And anything else you might like to comment on, of course.

    Thanks

    PS I find that libsound2 is now installed (I must have done that in my sleep).
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default re: SOLVED: Laptop sound is soft in openSUSE

    Quote Originally Posted by swerdna View Post
    Now files play back through the in-built speakers in similar volumes to what I get in windows.
    Thats good to read.


    Quote Originally Posted by swerdna View Post
    But can you now comment on what I might do to lift the volume of "system sounds", you might recall I said this in my first post:
    If I right-click it I get the more complex "Pulse Audio Volume Control". The "Output Devices" volume controls (stereo) are both at 100%. The "Playback System Sounds" volume control (mono) is at 50%. I can adjust the slider to 100%, but when I close and reopen the GUI, it's back at 50%.
    System sounds tend to be desktop specific, and I do not know the gnome desktop. I do note that for KDE3 and KDE4, there is a problem with sound constantly being muted when one restarts their desktop during a boot.

    The mute problem appears to be due to a bug with pulse audio setup in openSUSE, where the speculation is that pulse mutes the sound device when shutting down (to avoid inappropriate static/noise during shutdown), and unfortunately when starting up, it checks the last known configuration during shut down (which was mute) and applies that. Clearly something is wrong with pulse there, and the openSUSE Pulse packager (and alsa packager) have been looking at it. There is a bug report on openSUSE-11.2 milestone-x ( ? ) that is tracking this problem, although the problem is not restricted to just openSUSE-11.2 (but also impacts 11.1).

    Quote Originally Posted by swerdna View Post
    I find that libsound2 is now installed (I must have done that in my sleep).
    lol ! I think libasound2 provides a number of alsa libraries.

  7. #7
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default re: SOLVED: Laptop sound is soft in openSUSE

    Well iot's the old story: give a kid a gadget to play with......

    I've been playing with alsamixer -- and the system sounds are quite a bit louder now -- but I'm not sure how.

    I'm maybe going to annotate the HCL for this model re possible need to adjust sound levels, but first I'll install another Gnome DE and a KDE version as multiboot, so I can get a full grip on the potential problem, if indeed there really is a problem, maybe there isn't one at all -- we'll see.

    Thanks oldcpu -- SOLVED
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •