Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Lost user login and user home directories

  1. #1
    Join Date
    Jun 2008
    Location
    UK; deep south, far below Watford.
    Posts
    275

    Default Lost user login and user home directories

    I have lost the ability to login into my OS 11.1 system with any of my defined user logins. The system returns:

    "Cannot enter home directory. Using /"

    If I 'OK' this, the next message (in a sort of DOS box) is:

    "kstartupconfig4 does not exist or fails; the error code is 3. Check your installation"

    If I OK this then I am represented with the original user logon panel.

    This sequence is the same for all the users defined on the system

    I can login as root. When I do so I notice that there are no user directories under /home

    Is this recoverable? If so, how?
    They said I wasn't fit to live with a pig; my brother stood up for me and said I was.

  2. #2
    Join Date
    Mar 2008
    Location
    San Diego (California)
    Posts
    475

    Default Re: Lost user login and user home directories

    what changes were made to the system recently? For instance, did you change partition layout, encrypted partitions, installed another OS, updated kernel etc.. ?
    ~ There are 10 types of people. Those who understand binary, and those who don't. ~

  3. #3
    Join Date
    Jun 2008
    Location
    UK; deep south, far below Watford.
    Posts
    275

    Default Re: Lost user login and user home directories

    Quote Originally Posted by G0NZ0 View Post
    what changes were made to the system recently? For instance, did you change partition layout, encrypted partitions, installed another OS, updated kernel etc.. ?
    No, no changes of that sort; I did apply some changes which were claimed to improve performance, but the only ones that I can think would be in any involved were:

    Used Yast to edit /etc/sysconfig to ensure that DMA was on for my hard drives. I specified this using /dev/hda, (i.e I used /dev/hda:udma5) when it should have been /dev/sda

    I edited /etc/fstab to add 'noatime, nodiratime' to the ext3 declarations

    I changed 'swappiness' from 60 to 10 via 'sudo sysctl -w vm.swappiness=10' and then added this line (stupidly, exactly that line) at the end of /etc/sysctl.conf

    I disabled some services with Yast, none of which seemed to be relevant to this problem (for example, disabling support for Bluetooth)

    Other changes were to options in OpenOffice, and removing screen-saver


    btw, you say "~ There are 10 types of people. Those who understand binary, and those who don't. ~" - what happened to the other 14 ?
    They said I wasn't fit to live with a pig; my brother stood up for me and said I was.

  4. #4
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: Lost user login and user home directories

    You should boot without the splash screen to see why it fails to mount /home.

    I bet you broke /etc/fstab with your edit. You could have a look through to see if something is obviously wrong. For one thing there should be no whitespace inside the options list. So it should be noatime,nodiratime, not noatime, nodiratime.

  5. #5
    Join Date
    Jun 2008
    Location
    UK; deep south, far below Watford.
    Posts
    275

    Default Re: Lost user login and user home directories

    Quote Originally Posted by ken_yap View Post
    You should boot without the splash screen to see why it fails to mount /home.

    I bet you broke /etc/fstab with your edit. You could have a look through to see if something is obviously wrong. For one thing there should be no whitespace inside the options list. So it should be noatime,nodiratime, not noatime, nodiratime.
    You are absolutely right -I know I put a space after the comma.

    How do I boot without the splash screen?
    They said I wasn't fit to live with a pig; my brother stood up for me and said I was.

  6. #6
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: Lost user login and user home directories

    Don't worry about that now, just go to one of the virtual consoles with Ctrl-Alt-Fn where n is 1 to 6 and edit /etc/fstab with a CLI editor if you can use one. Or login as root at the GUI and do the required.

  7. #7
    Join Date
    Jun 2008
    Location
    UK; deep south, far below Watford.
    Posts
    275

    Default Re: Lost user login and user home directories

    AS I observed about an hour ago in another thread, it's the quality of the people and the support they provide that makes this forum and this distribution stand out....

    So, thank so much. I'm up and running agaiin, so now I can go to bed early and sleep instead of panic.
    They said I wasn't fit to live with a pig; my brother stood up for me and said I was.

  8. #8
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: Lost user login and user home directories

    Quote Originally Posted by XEyedBear View Post
    So, thank so much. I'm up and running agaiin, so now I can go to bed early and sleep instead of panic.
    A pleasure, mate. Have a good sleep.

    One thing I learnt is not to do anything critical close to bedtime. Unless one is insomniac and needs the distraction.

  9. #9
    goldie NNTP User

    Default Re: Lost user login and user home directories

    > Or login as root at the GUI and do the required.

    never required.

    --
    goldie

  10. #10
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: Lost user login and user home directories

    Except if you can't login as yourself because /home is not mounted so the GUI won't start for you, and don't know how to use the CLI, which is really something fixable.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •