Results 1 to 6 of 6

Thread: CPU Stepping

  1. #1
    c7aig NNTP User

    Question CPU Stepping

    This may be the wrong section of the forum, i am currently running an AMD 7750 black edition, it is clocked to 3.1 ghz and runs sweet, but when you open the CPU frequency monitor, it keeps stepping it to 1.3 (or somthing similar) and i know it is dynamic and changes under load to 3.1 but i cannot change any of the settings, even as root. i would like to change it to 3.1 all the time, is there anyway to do this?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: CPU Stepping

    Change the setting from Dynamic to performance.
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    Mallow, Ireland
    Posts
    1,031
    Blog Entries
    1

    Default Re: CPU Stepping

    Or change your BIOS setting to not use powersaving methods. Be carefull with your temperatures as this will generate a constant heat even if you're not using it.

    I'm not formiliar with the names of these options for AMD but in order for my Core 2 Duo E4300 to run at 3ghz instead of 1.8ghz all the time I had to disable these options in my BIOS. Changing the profile to performance didn't help for some reason.

    I would personally leave it the way it is since you are not going to gain any more performance and will only use more electricity and generate more heat when it's not required.

    P.S. Yes, this question is more hardware so maybe the hardware section of the forum would be a better place for this post. And welcome to the OpenSUSE forums!
    Last edited by Dexter1979; 12-Aug-2009 at 05:28. Reason: Added PS.
    "To err is human... to really foul up requires the root password."

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,587
    Blog Entries
    14

    Default Re: CPU Stepping

    For AMD's this can be set in Power Managment, like Carl says. Just put it to Performance. But....the Thurion X2 in my laptop seems to have a feature of it's own: even if I set the profile to Performance it goes from 1.6GHz to 800MHz...
    I would also leave it like it is. It might even make your CPU last a bit longer. These days car drivers don't push the throttle in front of a red light anymore, but that's about the same.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: CPU Stepping

    Yep, my AMD is set to Dynamic in suse and BIOS setting is for quiet running. It ticks along nicely and steps up to full whack when it's required. I dumped my GPU fan for a heatsink which is just as effective and considerably quieter
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    c7aig NNTP User

    Default Re: CPU Stepping

    well when i try and change from dynamic, the option isn't there, i know what you mean because my laptop supports it, but the option is just not there on the desktop, and i have disabled it in the BIOS, (atleast i think i have!) o well, as already said, i dont think it will make to much difference to the perfomance...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •