Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: port 25

  1. #1
    leiflende NNTP User

    Thumbs down port 25

    Im new to suse, but used to postfix on trustix (redhat based)
    tryin to get postfix to receive email from network.
    is receiving internal mail.
    test declares that port 25 is closed on system and that auth should be run under inetd (which is a OBSD way)
    can send email to internet.
    what can be the block? Firewall is not running
    system is suse 10. what can be done?
    Leif

  2. #2
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: port 25

    Quote Originally Posted by leiflende View Post
    Im new to suse, but used to postfix on trustix (redhat based)
    tryin to get postfix to receive email from network.
    is receiving internal mail.
    test declares that port 25 is closed on system and that auth should be run under inetd (which is a OBSD way)
    can send email to internet.
    what can be the block? Firewall is not running
    system is suse 10. what can be done?
    Leif
    SLES 10 or openSUSE 10? There are SLES forums elsewhere.

    No matter. Edit /etc/sysconfig/mail set SMTPD_LISTEN_REMOTE=yes and restart postfix.

  3. #3
    leiflende NNTP User

    Default Re: port 25

    Tried it, didnt do the trick.
    WEhat does SLES meen? Where do I find those forums?
    Leif

  4. #4

    Default Re: port 25

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    SLES = SUSE Linux Enterprise Server (the version you can pay for to get
    increased stability, non-forum/KB support, etc.).

    Verify Postfix is listening on something besides 127.0.0.1. When
    troubleshooting connection issues always try reaching the box from various
    locations using various IPs (remote to server, local to public IP on
    server, local to localhost on server). Also find out what the server
    thinks it is doing listening-wise:

    netstat -anp | grep 'LISTEN ' | grep :25

    Post the output, please.

    Good luck.





    leiflende wrote:
    > Tried it, didnt do the trick.
    > WEhat does SLES meen? Where do I find those forums?
    > Leif
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.9 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJKgsaYAAoJEF+XTK08PnB56JUQAL/RvPsfiZpwiA5odsyEHFfs
    wQWO2OtGXN2wAifFl72ZrEeuBjHEWNHg6J3qFbyLEscYmkhyzPARU/Zo8oncgjST
    33YhMKg2GDHELpC2HuknvlPxpKG5nSyUBzOHxFCMDnfYu77dseOXewhSxMhA/kC+
    YenAxCZOoing1KXAiubIRPVsYPitPA/g3IMVuVRJ14WVEepD6aRWlnVFCaMse3/g
    n0PrXGhQbQx7gW74hw0EERHbH0uqfIv7WEaGpFI/3smUkjvuqNkb+cFVSjYyCL1g
    /LTQcD+6mnmpfMGrH8fqbU8X/OXiTStiWNCqsboJL9IiyzEZ5QnKLdX0e/fJEJFX
    rcaTF2k5j26nMihXYidrEtXlqNR9+zPIsyYq6Xwmg2YIbuDvP6EqMg9Gvgy2Myr4
    e4MpFf8GIpHyXUP2GQmhroPKraToCkkET54Yqxt7UvH28qvLucMlJ7o9aHVqlUZi
    jaaOZCksWjEUTPmroaUxhvQlJBKTiX0lIlHOt5/Ap9qwjWa/GLbv/p6mb5b1PYGC
    j7WO/PeGHzlx0ISBUNs0CPvJypqZOEt8TWbW1kP0nwMtjc8f4OHrDRiFuzEc+vpk
    0cfy3Mf441r08Qe8zNeHC44oSzSr6ZLqFQgQE7jF/bwyTIac4Vm4RQQ4ELQIvW3Z
    h4G3bz1gI4RfiPUB8lRf
    =CwX/
    -----END PGP SIGNATURE-----

  5. #5
    leiflende NNTP User

    Default Re: port 25

    > netstat -anp | grep 'LISTEN ' | grep :25
    tcp 0 0 127.0.0.1:2544 0.0.0.0:* LISTEN 2420/zmd
    tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 4996/master
    tcp 0 0 ::1:25 :::* LISTEN 4996/master

    It is a sles 10 server then, si continue there.

    Leif

  6. #6
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: port 25

    Ah, forgot, you need this step if doing via the CLI. If you were doing it via YaST, it would do this for you.

    SuSEconfig --module postfix

    then restart postfix.

  7. #7

    Default Re: port 25

    I am having a very similar issue. I have postfix up and running. I can telnet to localhost 25 and it connects but when I run scans from the outside it shows port 25 closed. I have opened it from my external firewall and the firewall on the box with no change in state. I have tried all of the other suggestions in this thread and still no luck. Any help would be appreciated.

    netstat -an |grep LISTEN |grep 25
    tcp 0 0 127.0.0.1:10025 0.0.0.0:* LISTEN
    tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN
    tcp 0 0 ::1:10025 :::* LISTEN
    tcp 0 0 ::1:25 :::* LISTEN

    Here is the error from the outside port scan:
    25/tcp closed smtp.. Is this your external Mail Server -- turn on auth also in inetd

  8. #8

    Default Re: port 25

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Did you try the same things 'ken yap' suggested? Postfix isn't listening
    on 0.0.0.0:25 so you'll never reach it.

    Good luck.





    bellst wrote:
    > I am having a very similar issue. I have postfix up and running. I can
    > telnet to localhost 25 and it connects but when I run scans from the
    > outside it shows port 25 closed. I have opened it from my external
    > firewall and the firewall on the box with no change in state. I have
    > tried all of the other suggestions in this thread and still no luck. Any
    > help would be appreciated.
    >
    > netstat -an |grep LISTEN |grep 25
    > tcp 0 0 127.0.0.1:10025 0.0.0.0:* LISTEN
    > tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN
    > tcp 0 0 ::1:10025 :::* LISTEN
    > tcp 0 0 ::1:25 :::* LISTEN
    >
    > Here is the error from the outside port scan:
    > 25/tcp closed smtp.. Is this your external Mail Server -- turn on
    > auth also in inetd
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.9 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJKg3ddAAoJEF+XTK08PnB5u7wP/3EsDTfvt7a78GGOp6oR5iK3
    vbjyZSQQoP+CEsy+LGmQPSFOUEKUrrT7gBf4jcF+TVQpGO18NOrm04/xw1i2Ppst
    cYlkqGbHwFMBJFKjm8Y7sGrGqWHXZGxu4ln77jVzUQgDAR2LtfYGyOrTm0/U84Gp
    Avs07G9pynaYmkwa334/bU7rK+LRi49dhGsxFoUfeGi4znADxKM3T6Mdbv+D92Xe
    AcWhg29p90wSuVCDpo48lBclo+VqA3uwxTO6Sxqe+WqVwQ2gn4sUYGWx7LZPvVCm
    tt8DpniA8urlvxdcYRv0rAmZWiuQ3DdRREcjsemkbM/werGoO34e3+bDgimM1UsT
    X1OZo+V09nvswbJ+tauA6S6adzYS2EFY57YyiHYG6SgJxq45nY+HKd8ImLZSF3ut
    5uO77b7jBkNSJO31ifFtQ9SrqzPWkk+SefQtBB9OTWzhkLMpFMuBm1eVmek3weHi
    T5m1u4m4RZOHb6H8tCx0g779qPT9gtCMHM0W4Z/PS5vj1uT8G44ozsXkBW+8XmGU
    jmT9tMJSKMJaXzsW1lM6999Rhn7ai1CxBnbd+vwQmp/yGY/DRu8gpY41ZdLNTzQF
    scvkK8R/Nnsf/7I8cw4qaswDRPyYV0ty2r1e1TdTsMDo5n/mGXp++QIV7lfISsxr
    SS75ZhTg874wZcL0s0dZ
    =J7Q7
    -----END PGP SIGNATURE-----

  9. #9
    leiflende NNTP User

    Default Re: port 25

    Thak you:

    SuSEconfig --module postfix
    then restart postfix.

    Did the trick, exept for one thing:
    somehow and wonder why. in postfix: main.cf:
    inet_interfaces = 127.0.0.1 :::1
    was set automatic
    Changing it manually to actual inet interface IP:
    inet_interfaces = 192.168.1.3
    Opened up and mails are received from external smtp
    Leif

  10. #10
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,683
    Blog Entries
    4

    Default Re: port 25

    That line is generated from the sysconfig setting SMTPD_LISTEN_REMOTE that I showed you. For security reasons, if postfix is not required to listen for incoming mail, it only runs on localhost to deliver system messages to the sysadmin.

    Setting inet_interfaces in main.cf also does the same thing. But once you have modified main.cf, the configuration will no longer rely on sysconfig and you are responsible for maintaining main.cf yourself.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •